Seconda network lan TIM Hub DGA4132 (AGTHP)



tim hub dga4132

La procedura seguente può essere seguita previo sblocco del router con le guide che ci sono in questo forum: https://www.ilpuntotecnico.com/forum/index.php/topic,78162.0.html ma anche su altri.

Io ad esempio dopo aver sbloccato il router con autoflashgui e aggiornato alla versione AGTHP_1.1.0_002 seguendo il commento ben fatto dell’utente irobyx933: https://www.ilpuntotecnico.com/forum/index.php/topic,78162.msg229396.html#msg229396 e quindi sbloccata anche la GUI Tim, ho seguito anche questo forum: http://forum.kitz.co.uk/index.php/topic,20343.420.html dove l’utente shdf, che ringrazio per la pazienza che ha avuto nel rispondermi in pm a numerosi messaggi e che definire internazionale è un eufemismo, assieme ad altri spiegano come risolvere dei bug e aggiungere feature (come ad esempio, nella tab banda larga la modalità wan della porta eth4 che dopo la versione 1.0.3 era sparita e la selezionabilità del bridge mode e gpon nello switch connection mode o aggiungere il “Setup Wizard” nella schermata principale).
La guida è stata testata sul router DGA4132 ma ritengo sicuramente possibile che possa funzionare anche per altri modelli, come ad esempio agtef, anche se ovviamente ognuno è responsabile di quello che farà e che succederà al proprio router se deciderà di seguirla, io non me ne assumo nessuna responsabilità . Fatta questa premessa, doverosa, andiamo nello specifico; come da oggetto essa permette di creare una seconda lan ethernet (qui nell’esempio sotto ho scelto eth0), che sarà visibile anche sulla tab rete locale della webui una volta impostata: https://screenshots.firefox.com/0wz1QqL9TaQLKutf/192.168.0.1

Prima di cominciare è bene eseguire un backup del file

/etc/config/network

utilizzando i tool appropriati come ad esempio putty o winscp o quel che volete.

Andiamo quindi a modificare il file in questo modo:

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.x.x'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ipv6 '0'
option ifname 'eth1 eth2 eth3 eth5'
 
config interface 'eth0'
option proto 'static'
option ipaddr '192.168.y.x'
option netmask '255.255.255.0'
option ifname 'eth0'

Togliamo dalla stringa “option ifname” la porta eth0 nell’ interfaccia lan come nell’esempio, copincollare le ultime 5 righe con un nuovo ip e dando un nome che si vuole all’interfaccia nuova in “config interface” (come vedete nell’esempio ho assegnato all’interfaccia lo stesso nome della porta), avere cura di leggere il resto della guida tenendo in considerazione il nome che avete dato all’interfaccia e non eth0 ma soprattutto a NON assegnargli, come feci io, un ip della stessa network della sfp, dopodichè:

/etc/init.d/network restart
per far ripartire il servizio.
Fatto, la seconda interfaccia è stata creata, potrete pingare il router sul suo secondo ip, nell’esempio 192.168.3.1 , impostando il pc su quella stessa network (quindi 192.168.3.2 o superiore)

Dopodichè, se si vuole avere accesso in ssh anche sul nuovo ip basta editare il file

/etc/config/dropbear
ed aggiungere questa stringa:

config dropbear 'eth0'
option enable '1'
option IdleTimeout '600'
option PasswordAuth 'on'
option RootPasswordAuth 'on'
option Port '22'
option Interface 'eth0'

Infine dare in bel:

/etc/init.d/dropbear restart

Fatto, dovrebbe funzionare, dovreste cioè avere accesso in ssh sul nuovo ip.

Andiamo ora ad abilitare la nuova interfaccia(che è stata “sbriggiata” ) sul file 

/etc/config/firewall
per poter accedere in internet andando ad aggiungere questo (io l’ho messo dopo le 6 righe del “config defaults”):

config zone 'eth0'
option name 'eth0'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option mtu_fix '1'
option wan '0'
list network 'eth0'

e questa dopo le tre righe di “config forwarding ‘lan_wan’ :

config forwarding 'eth0_wan'
option src 'eth0'
option dest 'wan'

Altra chicca, nei sistemi Unix e Linux, anche se ho effettuato lo sblocco con Autoflashgui su windows, almeno a me è capitato di non avere accesso in ssh(mentre invece con putty da windows tutto ok), infatti:

N752VX:~$ ssh root@192.168.3.1
Unable to negotiate with 192.168.3.1 port 22: no matching host key type found. Their offer: ssh-rsa

Per risolvere il problema basta dare:

N752VX:~$ ssh -oHostKeyAlgorithms=+ssh-dss root@192.168.3.1
root@192.168.3.1's password:

Successivamente abilitare il secondo ip per l’accesso alla webui editando il seguente file con putty o winscp o da riga di comando linux (o nel modo che ritenete più opportuno)

/etc/config/dhcp

ed aggiungere le seguenti righe:

config dhcp 'eth0'
option interface 'eth0'
option start '2'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option force '1'
option ra_max_mtu '1500'
option dhcpv4 'server'
option limit '253'
option leasetime '21600s'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,6,"4132"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,5,"CP1741SA737"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,4,"A491B1"'
list dhcp_option '6,192.168.3.1'

Sulla prima e seconda riga il nome sarà ovviamente quello che avete dato voi alla seconda interfaccia mentre nell’ultima riga, l’ip sarà quello che gli avete assegnato, salvate ed uscite, dopodiché date un:

/etc/init.d/dnsmasq restart

Ora, per coloro che utilizzeranno questa guida con il router connesso in pppoe (che poi dovrebbero essere la maggior parte) dovrebbe essere finita qui, a meno di non essermi dimenticato qualcosa, mentre per coloro che utilizzano il DGA in cascata c’è dell’altro.
Tra le altre cose è bene precisare che la procedura è stata testata proprio mettendo il router in cascata ad altro e attivando la modalità wan (su eth4): https://screenshots.firefox.com/h9kGu8jSNtPGcKzH/192.168.0.1, cioè collegato al router direttamente connesso ad internet attraverso la eth4 e poi utilizzare il “setup wizard”, che si trova nella schermata principale della webui in alto a destra: https://screenshots.firefox.com/9CwT5EtBGV5SIkRJ/192.168.0.1, anche se mi rendo conto che coloro che non hanno la gui Tim unlocked o la gui di Ansuel non ritrovandosi quel tasto abilitato potrebbero non saper come fare. Per quest’ultimi quindi si può risolvere anche accedendo al file

/etc/config/network
 e andando a modificare questo:
config interface 'wan'
option auto '1'
option proto 'pppoe'
option demand '0'
option keepalive '4,30'
option username '***@00000.agcombo.unica'
option password 'alicenewag'
option graceful_restart '1'
option macaddr 'A4:xx:xx:xx:xx:02'
option ipv6 '0'
option peerdns '1'
option reqopts '1 3 6 15 33 42 51 121 249'
option keepalive_adaptive '0'
option dns_metric '0'
option ifname 'waneth4'

con questo:

config interface 'wan'
option auto '1'
option demand '0'
option graceful_restart '1'
option macaddr 'A4:xx:xx:xx:xx:02'
option ipv6 '0'
option keepalive_adaptive '0'
option dns_metric '0'
option ipaddr '192.168.1.251'
option netmask '255.255.255.0'
option proto 'static'
list dns '8.8.8.8'
list dns '208.67.222.222'
option metric '1'
option gateway '192.168.1.1'
option ifname 'eth4'

Dove su “option macaddr” metterete il mac della vostra interfaccia, su “option ipaddr” un ip della network lan del router che è connesso direttamente ad internet(nell’esempio 192.168.1.151) e su “option gateway” l’ip del router che è connesso ad internet(nell’esempio 192.168.1.1).

Successivamente bisogna ricordarsi, se si vuole utilizzare il router in cascata, di abilitare il mascheramento dell’Ip sul router stesso (banalmente abilitare il NAT) o sulla tab “Accesso ad Internet”: https://screenshots.firefox.com/YtYhUezMX6sc2PIi/192.168.0.1 oppure per i puristi impostando la regola di iptables con il comando:

iptables -t nat -A POSTROUTING -o eth4 -s eth0 -j MASQUERADE
regola che probabilmete verrà persa ad ogni riavvio a meno che, ma se siete puristi dovreste saperlo, la editiate nel file
/etc/rc.local
.
Io personalmente ho scelto la terza via, cioè ho abilitato due route statiche(una per l’interfaccia “lan” e una per l’interfaccia “eth0”) sul router direttamente connesso ad internet che punta sul nostro DGA. Dato che anche sul mio router principale ho openwrt mi è bastato pertanto aggiungere queste righe alla fine del file /etc/config/network del router direttamente connesso ad internet e NON sul DGA:
config route
option interface 'lan'
option target '192.168.0.0'
option netmask '255.255.255.0'
option gateway '192.168.1.251'
 
config route
option interface 'lan'
option target '192.168.3.0'
option netmask '255.255.255.0'
option gateway '192.168.1.251'

Enjoy, fatemi sapere se funziona tutto

Per finire i ringraziamenti; oltre a coloro che ho già citato in premessa, ringrazio tutti quelli che hanno contribuito, anche solo scrivendo semplicemente un post nelle guide per lo sblocco dei router Technicolor, non solo in questo forum ma anche in quello inglese che ho già linkato, permettendo di arricchire le conoscenze di base di tutti.

Infine il mio ultimo ringraziamento va all’utente ^NiCo^, che nel nostro scambio di pm nello sbatterci per trovare una soluzione nell’abilitazione delle VLAN in questo router, cosa che alla fine non è servita, almeno per quello che serviva a me dato che ho ripiegato per questa soluzione obiettivamente più semplice(ma cmq non demordo, ci deve essere un modo per abilitarle ), mi ha spronato nello scrivere questa guida.

Vi invitiamo a partecipare al topic ufficiale dell’articolo sul forum, in cui potete scrivere anche in caso di dubbi o domande.

Copyright 2018 Tutti i diritti riservati.
La presente guida non può essere copiata, modificata, distribuita, con alcun mezzo senza l’esplicita autorizzazione dell’autore e dello staff de ilpuntotecnico.com

 

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*