USB 4G/LTE WAN con AGTHP rooted

  • 9 Risposte
  • 227 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline krono86

  • Nuovo Iscritto
  • *
  • 47
USB 4G/LTE WAN con AGTHP rooted
« il: 05 Febbraio 2020, 01:56 »
Ciao a tutti,
sto entrando da poco in confidenza con un modem AGTHP che mi è capitato per le mani.
Seguendo le varie procedure sul forum ho effettuato il downgrade, ottenuto i diritti di amministratore, ed installato la GUI di Ansuel.
Sarei interessato a rendere il modem un acces point che utilizza come WAN una chiavetta USB 4G con SIM ho-mobile.
Vi dico fin dove sono arrivato:
- Seguendo soltanto la GUI, vedo una scheda dedicata alla connessione mobile, ma nel momento in cui collego la chiavetta non viene rilevato alcun dispositivo.
- Accedendo via SSH ed osservando dmesg, mi sono accorto che la chiavetta viene vista come un dispositivo di massa, non viene quindi effettuata il usb-modemswitch necessario all'utilizzo come modem.
Qualcuno di voi ha esperienza a riguardo? Devo trovare il modo di far funzionare il tutto da GUI, oppure dovrò condigurare la chiavetta da riga di comando? In quest'utimo caso, sarà possibile continuare ad utilizzare la GUI per la gestione del router?
Vi ringrazio per la disponibilità.
Buona serata.

Ivan

Offline natalinux

  • VIP
  • *****
  • 7397
  • Sesso: Maschio
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #1 il: 05 Febbraio 2020, 06:36 »
ciao che versione di gui hai installato?
edit: prova la dev
« Ultima modifica: 05 Febbraio 2020, 10:31 da natalinux »
•••─ ─ ─••• •••─ ─ ─••• •••─ ─ ─•••

Offline krono86

  • Nuovo Iscritto
  • *
  • 47
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #2 il: 05 Febbraio 2020, 09:25 »
v9.4.70

Offline krono86

  • Nuovo Iscritto
  • *
  • 47
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #3 il: 09 Febbraio 2020, 13:21 »
Ciao a tutti,
installando l'ultima versione della GUI la chiavetta viene riconosciuta correttamente.
Funziona in modalità RNDIS, stabilisce una rete (192.168.1.0) ed assegna via dhcp l'indirizzo al router.
Riesco ad accedere alla chiavetta (192.168.1.1) dai pc connessi alla rete del router (192.168.10.0), e la chiavetta si connette correttamente da internet.
Purtroppo il router non riesce ad uscire su internet. Quando esegui il ping di qualche sito noto, sembra che il DNS funzioni perchè viene associato l'indirizzo IP giusto, ma non si riceve risposta.
Potreste aiutarmi a capire cosa sta succedendo?
Via allega il file di configurazione della rete.
Grazie per la disponibilità.

Ivan

Codice: [Seleziona]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'wan'
option ifname 'usb0'
option proto 'dhcp'
option username '[email protected]'
option ipv6 '0'
option peerdns '1'
option auto '1'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ipv6 '0'
list pppoerelay '<set by script>'
option ipaddr '192.168.10.1'
option ifname 'eth0 eth1 eth2 eth3 eth4 eth5'

config switch 'bcmsw'
option reset '1'
option enable_vlan '0'
option qosimppauseenable '0'
option jumbo '0'

config interface 'wlnet_b_24'
option proto 'static'
option ip6assign '64'
option ipv6 '0'
option ip6hint '1'
option netmask '255.255.255.128'
option ipaddr '192.168.168.1'
option ifname 'wl0_1'
option force_link '0'
option name 'Ospiti-TIM-29047693'

config interface 'wlnet_b_5'
option proto 'static'
option ip6assign '64'
option ipv6 '0'
option ip6hint '2'
option netmask '255.255.255.128'
option ipaddr '192.168.168.129'
option ifname 'wl1_1'
option force_link '0'
option name 'Ospiti-TIM-29047693'

config device 'wlnet_b_5eth5'
option type '8021q'
option name 'wl1_1'
option enabled '1'
option ifname 'eth5'
option vid '3'
option ipv6 '0'

config interface 'sfptag'
option proto 'static'
option netmask '255.255.255.128'
option ipaddr '192.168.50.1'

config config 'config'

Online larsen64it

  • Esperto
  • ****
  • 1317
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #4 il: 09 Febbraio 2020, 14:46 »
Prova a mettere come dns l'ip della chiavetta. Se è una zte o simile  potrebbe esserti di aiuto
https://openwrt.org/docs/guide-user/network/wan/wwan/3gdongle
Intorno alla pagina 180 del tg789vacV2 e seguenti c'è spiegato anche come configurare il voip.

Offline krono86

  • Nuovo Iscritto
  • *
  • 47
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #5 il: 09 Febbraio 2020, 15:30 »
No, non è una ZTE, poi utilizza un protocollo diverso.
Anche impostando il dns, ottengo lo stesso risultato.
D’altronde, la propagazione del DNS sembra funzionare bene...
Non riesco ad uscirne.
E se fosse un problema di routing? Il comando route non mi da alcun gateway impostato...

EDIT:
Impostando manualmente il default gateway funziona!
Come faccio a rendere persistenti queste impostazioni?

EDIT 2:
Altro problema che ho notato è che all’accensione del router, il server DHCP della chiavetta non assegna indirizzo al router, se faccio un reboot via ssh l’ip viene correttamente assegnato.
« Ultima modifica: 09 Febbraio 2020, 16:12 da krono86 »

Offline natalinux

  • VIP
  • *****
  • 7397
  • Sesso: Maschio
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #6 il: 09 Febbraio 2020, 15:36 »
ciao che chiavetta è e quale sim usi?
•••─ ─ ─••• •••─ ─ ─••• •••─ ─ ─•••

Offline krono86

  • Nuovo Iscritto
  • *
  • 47
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #7 il: 09 Febbraio 2020, 15:42 »
È una Alcatel con protocollo RNDIS, la SIM è ho-mobile.

Ivan


Offline krono86

  • Nuovo Iscritto
  • *
  • 47
Re:USB 4G/LTE WAN con AGTHP rooted
« Risposta #9 il: 09 Febbraio 2020, 17:31 »
Seguire questa guida è stata la prima cosa che ho fatto, ovviamente...
Comunque, non so per quale ragione, ora sembra funzionare anche alla riaccensione.
Per qualcuno che fosse interessato, per rendere la chiavetta il default gateway ho fatto due cose (non so quale delle due sia stata risolutiva):
1) in /etc/config/network ho attivato l’opzione defaultroute
2) per sicurezza ho anche aggiunto una riga a /etc/rc.local in cui aggiungo l’ip della chiavetta come default gateway.
Buona serata.

Ivan