[GUIDA] Flash, Root e Modding Technicolor TG788vn v2 (VDNT-W)

  • 323 Risposte
  • 41857 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Enrico98

  • Membro Giovane
  • **
  • 83
  • Sesso: Maschio
Salve, vorrei sapere se c'è un metodo per sbloccare questo modem di tiscali oppure installare un firmware senza brand operatore
« Ultima modifica: 12 Marzo 2020, 20:45 da LuKePicci »

Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #1 il: 05 Febbraio 2019, 19:55 »
https://www.ilpuntotecnico.com/forum/index.php/topic,79634.msg240778.html#msg240778

firmware no brand non ce ne sono, ce ne era uno di un isp greco mi sembra che era poco brandizzato, il migliore per questo modem sembra sia il firmware infinitum che e' la versione 17.2 con openwrt ma non si trova l'RBI
« Ultima modifica: 05 Febbraio 2019, 19:56 da FrancYescO »

Offline Enrico98

  • Membro Giovane
  • **
  • 83
  • Sesso: Maschio
Re:technicolor tg788vn-v2
« Risposta #2 il: 06 Febbraio 2019, 13:33 »
« Ultima modifica: 06 Febbraio 2019, 14:01 da MisterFTTH »

Offline Enrico98

  • Membro Giovane
  • **
  • 83
  • Sesso: Maschio
Re:technicolor tg788vn-v2
« Risposta #3 il: 07 Febbraio 2019, 02:21 »
Si può fare il root su questo modem? E poi è possibile rendere la GUI di Ansuel compatibile per questo modem?

Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #4 il: 07 Febbraio 2019, 21:35 »
se si trovasse l'RBI di quel firmware probabilmente si alla GUI, il modem puo' essere sbloccato con il firmware tiscali ma non avere accesso completo root (un po come per gli AGTOT TIM)

Offline Enrico98

  • Membro Giovane
  • **
  • 83
  • Sesso: Maschio
Re:technicolor tg788vn-v2
« Risposta #5 il: 08 Febbraio 2019, 15:06 »
guarda che dentro l'archivio di quel link di google drive c'è il firmware formato RBI se non hai visto
« Ultima modifica: 08 Febbraio 2019, 15:20 da MisterFTTH »

Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #6 il: 09 Febbraio 2019, 09:59 »
Quello del drive è un firmware 10.x: non è quello che si vede nel video.

Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #7 il: 15 Febbraio 2019, 21:35 »
Qui un firmware 17.2 per 788vnv2 http://gateway.telmex.com/test/vdnt-w_TG788vnV2_17.2.0279_Upgrade.rbi

Ci dovrebbe essere anche la versione 17.2 0360 (quella che si vede nel video sopra) ma e' caccia all'rbi ...
« Ultima modifica: 15 Febbraio 2019, 21:37 da FrancYescO »

Offline larsen64it

  • Esperto
  • ****
  • 1651
Re:technicolor tg788vn-v2
« Risposta #8 il: 22 Marzo 2019, 03:03 »
Cerchiamo di allungare la vita anche a questo senza ucciderlo prima:


Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #9 il: 22 Marzo 2019, 05:53 »
Oh un'altro che ha completato l'impresa (proprio non ti piacciono i modelli più nuovi eh?)

Comunque servirebbe un bel bug report delle varie card (e anche dello scrip rootdevice se ha dato errori) su questo dispositivo: molti comportamenti son diversi...

Offline larsen64it

  • Esperto
  • ****
  • 1651
Re:technicolor tg788vn-v2
« Risposta #10 il: 22 Marzo 2019, 09:27 »
Su alcuni modelli nuovi mi sono già espresso, quindi mi astengo.
Essendo appassionato di trashware e homebrew, se mi capita qualcosa di più vecchio, tornerò a tediarvi.
Tornando seri, prima di parlare di bug delle card mi preoccuperei dell'installazione.
Non avendo l'accesso ad internet, avevo la penultima stabile caricata sul server http ed ho installato quella. Ho dato /etc/init.d/rootdevice debug e sembrava tutto ok. Problema, forse perché venivo dalla bank_2 con il fail boot (banale su questo router), mi ha clonato la bank e messo un clone in /overlay saturandolo. Non si è bloccato per una manciata di byte, occhio quindi.
Ho installato l'ultima dev, ma  al momento del re-zip, forse ha esaurito la ram, è andato in panic riavviandosi, completando il re-root al riavvio, da indagare.   

Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #11 il: 22 Marzo 2019, 13:33 »
le stable/dev precedenti alla versione 9 sono delle bombe ad orologeria per i device con poca rom, sono state fatte parecchie migliorie a riguardo nelle ultime versioni (in primis viene copiato in rom in pacchetto di dimensioni minori e in generale ci si preoccupa che ce ne sia solo uno in /root ripulendo i vecchi rimasugli)

fare la prima installazione quando si e' in bank2 e' un'ulteriore complicanza (nella pratica se non sbaglio dovrebbe clonare la GUI in entrambi gli overlay per poi rebootarsi al primo e lo spazio potrebbe non essere abbastanza)

Poi soprattutto gli ultimi fix (ma oddio, anche eventuali bug) sono sempre e solo presenti nelle dev quindi soprattutto quando si sta portando su un nuovo device bisogna analizzare il tutto con la piu' recente possibile, c'e anche la nuova funzione che crea zip di debug nella parte system extra che potrebbe aiutare molto nello sviluppo

Offline larsen64it

  • Esperto
  • ****
  • 1651
Re:technicolor tg788vn-v2
« Risposta #12 il: 22 Marzo 2019, 13:58 »
Fatta nuova installazione da 0. L'installazione va a buon fine. Prima del canonico /etc/init.d/rootdevice force/debug ho dato
sync && echo 3 |  tee /proc/sys/vm/drop_caches per liberare spazio nella ram.
log primo ingresso nella gui
Codice: [Seleziona]
2017/10/31 02:29:59 [error] 3749#0: *1 [lua] sessionmgr.lua:231: redirectIfNotAuthorized(): Unauthorized request, client: 192.168.1.233, server: localhost, request: "GET / HTTP/1.1", host: "192.168.1.254", referrer: "http://192.168.1.254/"
[email protected]:/tmp/log/nginx# cat erro*
2017/10/31 02:29:59 [error] 3749#0: *1 [lua] sessionmgr.lua:231: redirectIfNotAuthorized(): Unauthorized request, client: 192.168.1.233, server: localhost, request: "GET / HTTP/1.1", host: "192.168.1.254", referrer: "http://192.168.1.254/"
2017/10/31 02:42:00 [error] 6900#0: *4 open() "/www/docroot/img/gateway_MediaAccess TG788vn v2.png" failed (2: No such file or directory), client: 192.168.1.233, server: localhost, request: "GET /img/gateway_MediaAccess%20TG788vn%20v2.png HTTP/1.1", host: "192.168.1.254", referrer: "http://192.168.1.254/cards.lp"
log installazione
https://www74.zippyshare.com/v/kj5OKg2s/file.html
Con calma provo le cards.


Offline FrancYescO

  • VIP
  • *****
  • 2496
Re:technicolor tg788vn-v2
« Risposta #13 il: 22 Marzo 2019, 15:08 »
oddio per essere un device su cui non e' mai stato testato nulla l'installazione va piu' che bene... per ora messa l'iconcina nella dev :D

Offline larsen64it

  • Esperto
  • ****
  • 1651
Re:technicolor tg788vn-v2
« Risposta #14 il: 22 Marzo 2019, 17:15 »
Ho fatto un primo giro sulle cards a video mi ha dato questi errori.
Codice: [Seleziona]
rete locale
Exact data not found in this paths:
Key eth4_wanmode : [email protected]

Dispositivi -> monitoraggio traffico
Si è verificato un errore interno del server.
Contatta l´amministratore
Questo è il log con gli errori con il nome della card di rifermiento a seguire
https://www66.zippyshare.com/v/EUDHavD8/file.html
Ora inizierei a fare le prove di funzionamento vero e proprio e vedere cosa salta fuori.
Forse si riesce a sganciare una eth per farla diventare wan, mentre si riesce sicuramente a gestire il wifi in dual band
L'acqua è poca e non so se la papera galleggia.