Bridge da DGA4131FWB ad altro Router

  • 3 Risposte
  • 188 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline matteoa91

  • Nuovo Iscritto
  • *
  • 4
Bridge da DGA4131FWB ad altro Router
« il: 19 Maggio 2020, 09:11 »
Buongiorno a tutti,

Vi scrivo per chiedere aiuto nel creare un bridge tra un modem DGA4131 e un router con installato OpenWRT.
Il mio obbiettivo tenere sul DGA4131 solo il minimo indispensabile per potervi accedere, per il resto creare un bridge verso la porta WAN (la porta 4 in teoria), e poi configurare l'altro router (un Netgear D7800 con openwrt installato).
Avrei usato il netgear direttamente, ma avendo messo openwrt ho perso la parte modem in quanto non supportata.

Vi chiedo aiuto chiarimenti per le seguenti cose:
1- come configurare correttamente il bridge nel DGA4131 (sotto il /etc/config/network attuale)
2- come disabilitare correttamente tutto lasciando solo un dhcp su lan per poter accedere al modem in ssh, se fosse necessario
3- come configurare opportunamente il router netgear per il ponte (da quello che ho capito sufficiente mettere client dhcp sulla porta wan)
4- come configurare le option 60 e 61 per il clone del mac e il client id nel router netgear
5- eventuali altre cose che mi sono perso?  :rotfl:

Attualmente il DGA4131 stock con i permessi di root sbloccati, ha la configurazione di default e una sola variazione (ip e dmz).

Grazie a tutti per l'eventuale aiuto!

/etc/config/network attuale:
Codice: [Seleziona]

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd2d:292b:fdc6::/48'
option default_ps '0'

config interface 'lan'
option ifname 'eth0 eth1 eth2 eth3'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ip6class '6rd'
option ip6hint '0'
option ip6weight '1'
option stp '1'
option rpfilter '1'
option ipv6 '0'
option ipaddr '192.168.0.254'

config interface 'Guest'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.78.1'
option ifname 'wl0_2'
option ip6assign '64'
option ip6class '6rd'
option ipv6 '1'
option ip6hint '1'
option ip6weight '0'
option force_link '0'
option rpfilter '1'
list pppoerelay ''

config switch 'bcmsw'
option reset '1'
option enable_vlan '0'
option qosimppauseenable '0'
option jumbo '0'

config interface 'wan'
option proto 'dhcp'
option reqopts '1 3 6 15 33 42 43 51 121 249 212'
option vendorid 'Technicolor_DGA4131FWB/dslforum.org'
option authfail '0'
option iface6rd '6rd'
option zone6rd 'wan'
option mtu '1500'
option initboot '1'
option ipv6 '0'
option notused '10:13:31:F3:7B:F1'
option auto '1'
option ifname '@vlan_wan'

config interface 'mgmt'
option vendorid 'Technicolor_DGA4131FWB/dslforum.org'

config device 'vlan_ptm0'
option type '8021q'
option ifname 'ptm0'
option mtu '1500'
option name 'vlan_ptm0'
option vid '100'

config interface 'wantag'
option proto 'dhcp'
option reqopts '1 3 6 15 33 42 51 121 249 212'
option vendorid 'Technicolor_DGA4131FWB/dslforum.org'
option authfail '0'
option iface6rd '6rd'
option zone6rd 'wan'
option mtu '1500'
option initboot '1'
option ipv6 '0'
option ifname '@vlan_wan'
option auto '0'

config interface 'wwan'
option proto 'mobiled'
option session_id '0'
option profile '1'
option iface_464xlat '0'
option auto '0'
option enabled '0'

config interface 'vlan_wan'
option ifname 'vlan_ptm0'

config device 'if0atm'
option enable '1'
option name 'atm0'
option macaddr '10:13:31:F3:7B:F0'

config device 'if1atm'
option enable '1'
option name 'atm1'
option macaddr '10:13:31:F3:7B:F1'

config device 'vlan_eth4'
option type '8021q'
option ifname 'eth4'
option mtu '1500'
option name 'vlan_eth4'
option vid '835'

config interface 'vlan_wan_eth4'
option ifname 'vlan_eth4'

config interface 'sfp'
option proto 'static'
option ifname 'eth4'
option ipaddr '169.0.0.2'
option netmask '255.255.255.0'

config config 'config'

config interface 'hotspot'
option type 'bridge'
option proto 'static'

config interface 'gre'
option peeraddr '10.254.3.85'
option mtu '1400'
option df '1'
option zone 'wan'
option tunlink 'wan'
option ttl '100'
option proto 'gretap'
option network 'hotspot'


Offline matteoa91

  • Nuovo Iscritto
  • *
  • 4
Re:Bridge da DGA4131FWB ad altro Router
« Risposta #1 il: 21 Maggio 2020, 15:54 »
Sperando che qualcuno prima o poi mi risponda, ho fatto un po' di prove anche guardando quello che avevano gi fatto altre persone come @ArnoldWeber in questo post https://www.ilpuntotecnico.com/forum/index.php/topic,80598.msg258301.html#msg258301 e @anglet nel medesimo su consiglio di altri utenti.

Da quello che intuisco, la mia linea utilizza la vlan 100.
Attualmente non va nulla, e non riesco a capire cosa sto sbagliando. il router manda pacchetti ma non ne riceve indietro.
allego le 2 configurazioni che ho provato l'ultima volta:

Codice: [Seleziona]
### config DGA4131

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd2d:292b:fdc6::/48'
option default_ps '0'

config interface 'lan'
option ifname 'eth1 eth2 eth3'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ip6class '6rd'
option ip6hint '0'
option ip6weight '1'
option stp '1'
option ipv6 '0'
    list pppoerelay ''
option ipaddr '192.168.0.254'

config switch 'bcmsw'
option reset '1'
option enable_vlan '0'
option qosimppauseenable '0'
option jumbo '0'

config device 'vlan_ptm0'
option type '8021q'
option ifname 'ptm0'
option mtu '1500'
option name 'vlan_ptm0'
option vid '100'

config interface 'wan'
    option type 'bridge'
    option ifname 'eth0 vlan_ptm0'

config interface 'mgmt'
option vendorid 'Technicolor_DGA4131FWB/dslforum.org'

config interface 'wwan'
option proto 'mobiled'
option session_id '0'
option profile '1'
option iface_464xlat '0'
option auto '0'
option enabled '0'

config device 'if0atm'
option enable '1'
option name 'atm0'
option macaddr 'MAC DGA4131'

config device 'if1atm'
option enable '1'
option name 'atm1'
option macaddr 'MAC WIFI'

config interface 'sfp'
option proto 'static'
option ifname 'eth4'
option ipaddr '169.0.0.2'
option netmask '255.255.255.0'

config config 'config'

config interface 'hotspot'
option type 'bridge'
option proto 'static'

config interface 'gre'
option peeraddr '10.254.3.85'
option mtu '1400'
option df '1'
option zone 'wan'
option tunlink 'wan'
option ttl '100'
option proto 'gretap'
option network 'hotspot'


Codice: [Seleziona]
### config D7800

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdb7:dd80:0567::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option macaddr 'MAC DGA4131'
option peerdns '0'
option dns '1.1.1.1 1.0.0.1'

option device 'wan_dev'
option name 'eth0.2'
option macaddr 'MAC DGA4131'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option auto '0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '6t 1 2 3 4'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 5'
option vid '2'

config interface 'nordvpntun'
option proto 'none'
option ifname 'tun0'


non capisco cosa sto sbagliando, in teoria cos facendo ho messo in comunicazione i 2 dispositivi senza virtual lan, e quando arriva sul DGA dovrebbe metterci il tag 100 e poi mandare tutto sul ptm0, giusto?
allego anche il risultato del comando ifconfig sul DGA:
Codice: [Seleziona]
6rd-6rd   Link encap:IPv6-in-IPv4
          inet6 addr: 2001:b07:5d29:ffb1::1/32 Scope:Global
          inet6 addr: ::93.41.255.177/96 Scope:Compat
          UP RUNNING NOARP  MTU:1280  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

bcmsw     Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17186 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17155 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7351324 (7.0 MiB)  TX bytes:6956532 (6.6 MiB)
          Base address:0xffff

br-hotspot Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F1
          inet6 addr: fe80::1213:31ff:fef3:7bf1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1400  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:1042 (1.0 KiB)

br-lan    Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          inet addr:192.168.0.254  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:33100 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35311 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:12932534 (12.3 MiB)  TX bytes:20189119 (19.2 MiB)

eth0      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30259 errors:0 dropped:10 overruns:0 frame:0
          TX packets:34532 errors:0 dropped:2 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12477220 (11.8 MiB)  TX bytes:19454963 (18.5 MiB)


eth1      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


eth2      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


eth3      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


eth4      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          inet addr:169.0.0.2  Bcast:169.0.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

gre4t-gre Link encap:Ethernet  HWaddr 6E:18:2E:66:2B:20
          inet6 addr: fe80::6c18:2eff:fe66:2b20/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1400  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:766 (766.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:69 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8927 (8.7 KiB)  TX bytes:8927 (8.7 KiB)

ptm0      Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          inet6 addr: fe80::1213:31ff:fef3:7bf0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35058 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20277198 (19.3 MiB)  TX bytes:13413313 (12.7 MiB)

vlan_ptm0 Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F0
          inet addr:93.41.255.177  Bcast:93.41.255.255  Mask:255.255.255.128
          inet6 addr: fe80::1213:31ff:fef3:7bf0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3711 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4002 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:541502 (528.8 KiB)  TX bytes:376184 (367.3 KiB)

wl0       Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F1
          inet6 addr: fe80::1213:31ff:fef3:7bf1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2867 errors:0 dropped:0 overruns:0 frame:5872
          TX packets:3659 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1016941 (993.1 KiB)  TX bytes:1179704 (1.1 MiB)
          Interrupt:92

wl0_1     Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F1
          inet6 addr: fe80::1213:31ff:fef3:7bf1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:5872
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl0_2     Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F1
          inet addr:192.168.78.1  Bcast:192.168.78.255  Mask:255.255.255.0
          inet6 addr: fe80::1213:31ff:fef3:7bf1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:5872
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl0_3     Link encap:Ethernet  HWaddr 10:13:31:F3:7B:F1
          inet6 addr: fe80::1213:31ff:fef3:7bf1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:5872
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl1       Link encap:Ethernet  HWaddr 12:13:31:F3:7B:F9
          inet6 addr: fe80::1013:31ff:fef3:7bf9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:135691 (132.5 KiB)

wl1_1     Link encap:Ethernet  HWaddr 12:13:31:F3:7B:F9
          inet6 addr: fe80::1013:31ff:fef3:7bf9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:135611 (132.4 KiB)

wl1_2     Link encap:Ethernet  HWaddr 12:13:31:F3:7B:F9
          inet6 addr: fe80::1013:31ff:fef3:7bf9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:135611 (132.4 KiB)

wl1_3     Link encap:Ethernet  HWaddr 12:13:31:F3:7B:F9
          inet6 addr: fe80::1013:31ff:fef3:7bf9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:135611 (132.4 KiB)


Offline FrancYescO

  • VIP
  • *****
  • 2381
Re:Bridge da DGA4131FWB ad altro Router
« Risposta #2 il: 21 Maggio 2020, 16:54 »
stata fatta la stessa identica cosa in qualche altro topic di recente

comunque direi che devi spoffare il vendor_class e il MAC del DGA sul D7800, sul DGA invece metti un mac a caso basta che non utilizzi il suo originale che avrai assegnato al D7800

Offline matteoa91

  • Nuovo Iscritto
  • *
  • 4
Re:Bridge da DGA4131FWB ad altro Router
« Risposta #3 il: 21 Maggio 2020, 17:17 »
ok, come posso spoffare il vendor?
sufficiente aggiungere
Codice: [Seleziona]
option vendorid 'Technicolor_DGA4131FWB/dslforum.org' al wan del D7800?