[MOD] Technicolor Custom GUI di Ansuel

  • 1987 Risposte
  • 192759 Visite

0 Utenti e 2 Visitatori stanno visualizzando questo topic.

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2412
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1980 il: 14 Gennaio 2021, 15:50 »
Il wifi del 2130 è molto meglio di entrambi, l'ideale sarebbe supportare quello

Offline putipower

  • Membro Anziano
  • ***
  • 163
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1981 il: 15 Gennaio 2021, 17:48 »
timhub collegato con pppoe relay in modalita pppoe routed con firmware 2.2.1 e gui 9.5.58  su linea tim
ho abilitato senza troppe convinzioni ipv6 e devo dire con mia immensa sorpresa che funziona benissimo,login password [email protected]
non servendomi voip essendo questo modem praticamente un accesspoint ho aggiunto dns google perche stranamente da client wifi non mi vedeva ipv4?1?!?!
se qualcuno volesse provare a replicare questa prova con ipv6 magari potrebbe essere utile
timhub 2.2.3-003 gui 9.6.48 TIM 100-20
sercomm vd625

Offline Nanjerd

  • Nuovo Iscritto
  • *
  • 10
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1982 il: 16 Gennaio 2021, 00:20 »
Ciao a tutti,
Sono riuscito a risolvere il problema del DHCP Lease Time!!! Confrontando i due TCPDUMP del DGA4131 e DGA4132 ho notato che il Bound della richiesta del rinnovo partiva dall'IP dell'interfaccia SFP (192.168.2.2 sul TIMHUB di default) e non dal IP Pubblico della WAN, ho quindi eliminato l'interfaccia SFP dentro il file network (forse bastava anche solo cancellare l'ip dentro la scheda apposita ma ho voluto provare subito la soluzione drastica) ed ora la richiesta viene inviata dal IP della WAN esatto e rinnovato correttamente. Magari può servire a qualcuno che vorrà usare il modem con Fastweb e riscontrerà lo stesso problema.

Offline greyhand

  • Nuovo Iscritto
  • *
  • 29
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1983 il: 16 Gennaio 2021, 20:10 »
Se non è già presente (non mi sembra) è possibile creare un menu per l'interfaccia "afg" come per le altre con relativi parametri?

Offline natf

  • Nuovo Iscritto
  • *
  • 23
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1984 il: 16 Gennaio 2021, 22:47 »
Ciao a tutti; ricorro al forum perché, dopo un anno, ho ripreso un DGA4130 a cui avevo fatto correttamente il root dopo aver fatto il downgrade alla 1.0.3 dalla 2.0.0 e aver installato la GUI di Ansuel. Tutto funzionava ma poi lo avevo lasciato li nella scatola.
SIccome mi servirebbe ho pensato di caricare, sempre tramite la GUI di Ansuel, come da guide, l' ultimo FW disponibile, ossia il 2.2.1 rilasciato la scorsa estate per AGTEF.
Terminato l' aggiornamento il modem continua a resettarsi da solo; attivando il ping continuo a 192.168.1.1 ottengo, in fase iniziale, circa 15-20 risposte con TTL=100 (se non sbaglio dovrebbe essere il bootloader che risponde) dopo di che altre risposte "Errore generale" e infine 10 risposte circa con TTL=64.
Terminata questa fase il modem si resetta da solo e riparte tutto da capo; ho provato a spegnerlo e riaccenderlo ma ovviamente non ho ottenuto nulla.
Non ho effettuato alcun reset HW perché vorrei chiedere aiuto qui.

Grazie in anticipo

Offline lorenzocanalelc

  • Membro Anziano
  • ***
  • 462
  • Sesso: Maschio
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1985 il: Ieri alle 21:56 »
Chiedo qua prima di aprire un issue su GitHub per capire se sia un mio problema o un problema della GUI.
Ho notato con piacere che usando le famose credenziali username e password : [email protected] riesco finalmente ad ottenere un IPV6 (Precedentemente non ero mai riuscito) con il Tg789vac V2 con FW UNO. L'IP viene assegnato ma sulla GUI rimane la scritta "IPV6 Connecting" oltre all'IPV6 fe80::1, c'è qualcosa di errato nella mia configurazione o nella GUI?
Allego il mio file network e l'ifconfig
Codice: [Seleziona]
[email protected]:/etc/config# cat network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'auto'
option default_ps '0'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option force_link '0'
option igmp_snooping '1'
option ip6assign '64'
option ipaddr '192.168.10.1'
list pppoerelay 'atmwan'
option ipv6 '1'
list ifname 'vlan_eth0'
list ifname 'vlan_eth1'
list ifname 'vlan_eth2'
list ifname 'vlan_eth3'

config device 'eth0'
option mtu '1500'
option name 'eth0'

config device 'eth1'
option mtu '1500'
option name 'eth1'

config device 'eth2'
option mtu '1500'
option name 'eth2'

config device 'eth3'
option mtu '1500'
option name 'eth3'

config device 'vlan_eth0'
option type '8021q'
option ifname 'eth0'
option name 'vlan_eth0'
option mtu '1500'
option vid '1'

config device 'vlan_eth1'
option type '8021q'
option ifname 'eth1'
option name 'vlan_eth1'
option mtu '1500'
option vid '1'

config device 'vlan_eth2'
option type '8021q'
option ifname 'eth2'
option name 'vlan_eth2'
option mtu '1500'
option vid '1'

config device 'vlan_eth3'
option type '8021q'
option ifname 'eth3'
option name 'vlan_eth3'
option mtu '1500'
option vid '1'

config switch 'bcmsw_int'
option reset '1'
option type 'bcmsw'
option qosimppauseenable '0'
option jumbo '1'
option unit '0'
option enable_vlan '0'

config switch 'bcmsw_ext'
option reset '1'
option type 'bcmsw'
option qosimppauseenable '0'
option unit '1'
option enable_vlan '1'
option jumbo '1'

config switch_vlan 'lan_switch'
option device 'bcmsw_ext'
option vlan '1'
option ports '1* 2* 3* 4* 8t'

config interface 'wan'
option reqopts '1 3 6 15 33 42 51 121 249'
option vendorid 'Technicolor'
option authfail '0'
option mtu '1500'
option release '1'
option iface6rd '0'
option ifname 'atmwan'
option proto 'pppoe'
option peerdns '1'
option password '[email protected]'
option auto '1'
option ipv6 '1'
option username '[email protected]'

config device 'eth4'
option name 'eth4'
option mtu '1508'

config device 'ptm0'
option mtu '1508'
option name 'ptm0'

config interface 'wwan'
option auto '1'
option metric '10'
option proto 'mobiled'
option session_id '0'
option profile '1'

config interface 'wan6'
        option ifname   '@wan' # use same ifname as in wan-section or "@wan"
        option proto    'dhcpv6'

config interface 'guest'
option proto 'static'
option type 'bridge'
option ip6hint '1'
option netmask '255.255.255.128'
option ipaddr '192.168.168.126'
list ifname 'wl0_1'
list ifname 'wl1_1'
option force_link '0'
option ipv6 '1'

config config 'config'
option wan_mode 'pppoe'

config interface 'ipoe'
option proto 'dhcp'
option metric '1'
option reqopts '1 3 6 43 51 58 59'
option release '1'
option neighreachabletime '1200000'
option neighgcstaletime '2400'
option ipv6 '1'

config device 'waneth4'
option enabled '1'
option type '8021q'
option name 'waneth4'
option vid '835'
option ipv6 '1'

config device 'wanptm0'
option enabled '1'
option type '8021q'
option name 'wanptm0'
option vid '835'
option ipv6 '1'


Codice: [Seleziona]
[email protected]:/etc/config# ifconfig
atmwan    Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          inet6 addr: fe80::xxxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:165049 errors:0 dropped:8443 overruns:0 frame:0
          TX packets:106814 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:108531867 (103.5 MiB)  TX bytes:16338293 (15.5 MiB)

bcmsw     Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Base address:0xda00

br-guest  Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2F 
          inet addr:192.168.168.126  Bcast:192.168.168.127  Mask:255.255.255.128
          inet6 addr: fe80::xxxxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:736394 (719.1 KiB)

br-lan    Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: 2a01:xxxxx/64 Scope:Global
          inet6 addr: fe80:xxxxx/64 Scope:Link
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:92968 errors:0 dropped:0 overruns:0 frame:0
          TX packets:160428 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16322662 (15.5 MiB)  TX bytes:130142938 (124.1 MiB)

eth0      Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         

eth1      Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         

eth2      Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         

eth3      Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
         

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4124 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4124 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:385075 (376.0 KiB)  TX bytes:385075 (376.0 KiB)

pppoe-wan Link encap:Point-to-Point Protocol 
          inet addr:79.xxxx  P-t-P:192.168.100.1  Mask:255.255.255.255
          inet6 addr: 2a01:xxxxxx/64 Scope:Global
          inet6 addr: fe80::1/10 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1462  Metric:1
          RX packets:68850 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45542 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:60833313 (58.0 MiB)  TX bytes:8093984 (7.7 MiB)

vlan_eth0 Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vlan_eth1 Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vlan_eth2 Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vlan_eth3 Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2E 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl0       Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2F 
          inet6 addr: fe80::e2b9:e5ff:fe69:f22f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3253 errors:0 dropped:0 overruns:0 frame:596083
          TX packets:16761 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:306283 (299.1 KiB)  TX bytes:2339483 (2.2 MiB)
          Interrupt:15 Base address:0x4000

wl0_1     Link encap:Ethernet  HWaddr E0:B9:E5:69:F2:2F 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:596083
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wl1       Link encap:Ethernet  HWaddr E2:B9:E5:69:F2:37 
          inet6 addr: fe80::xxxx7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:89769 errors:0 dropped:0 overruns:0 frame:126704
          TX packets:135692 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15684078 (14.9 MiB)  TX bytes:115002711 (109.6 MiB)
          Interrupt:48

wl1_1     Link encap:Ethernet  HWaddr E2:B9:E5:69:F2:37 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:126704
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Ho censurato gli IPV6 anche se non essendo molto esperto non so se fosse necessario nascondere anche quelli della lan.

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2412
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1986 il: Ieri alle 22:35 »
In ipv6 ci sono tre pezzi, il primo prefisso iniziale degli indirizzi global si riferisce a fastweb, la seconda parte è specifica tua della tua rete, e l'ultimo pezzo è relativo al singolo dispositivo in LAN, ed è sostanzialmente il suo mac address. Quest'ultimo pezzo è in comune agli indirizzi local, quelli fe80.

A me sembra tutto ok nei file che hai mostrato.

Offline natf

  • Nuovo Iscritto
  • *
  • 23
Re:[MOD] Technicolor Custom GUI di Ansuel
« Risposta #1987 il: Oggi alle 00:16 »
Dopo la prima richiesta di aiuto per il 4130 brickato, per aver effettuato l' aggiornamento del FW alla 2.2.1 senza aver aggiornato la GUI di Ansuel ad una versione recente, ho letto un po' di post in giro.
Se ho ben capito il FW è stato caricato nel bank1 e il fatto che il router continui a ritentare il boot (senza successo) mi farebbe pensare che il bank attivo potrebbe essere proprio il bank1.
Un downgrade del FW ad una versione sicuramente funzionante (la 2.0.0 prima dell' aggiornamento) potrebbe risolvere il problema?
Pensavo al caricamento del FW tramite TFTP facendo entrare il 4130 in BOOTP mode tenendo premuto il pulsante di reset all' avvio.
E' corretto quello che ho scritto oppure mi sta sfuggendo qualcosa? Prima di fare altri danni chiedo a chi ne sa più di me.

Grazie