Aggiunta del supporto ufficiale dell'AGPWI su OpenWrt

  • 32 Risposte
  • 1402 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline mavelot

  • Administrator
  • Esperto
  • *****
  • 1672
  • Live Long and Prosper
Re:Aggiunta del supporto ufficiale dell'AGPWI su OpenWrt
« Risposta #30 il: 12 Aprile 2020, 13:36 »
no a me non vanno le mappature originali...manco una funziona

sorry...sbagliavo config
« Ultima modifica: 12 Aprile 2020, 13:41 da mavelot »

Offline Daniele Castro

  • Nuovo Iscritto
  • *
  • 10
Re:Aggiunta del supporto ufficiale dell'AGPWI su OpenWrt
« Risposta #31 il: 12 Aprile 2020, 22:20 »
Ciao, non ho ben compreso se state ancora parlando del router AGPWI (ADB P.DG A4001N A-000-1A1-AX). Comunque se vuoi tutti i LED funzionanti e correttamente mappati su di esso, devi necessariamente compilarti la mia immagine di OpenWrt. Sto aggiungendo il supporto per questo router obsoleto proprio per avere tutti i LED funzionanti ed un'immagine stock di OpenWrt appositamente fatta per l'AGPWI

Trovi il link alla mia pull request nel post iniziale.

Nel caso tu stia pensando di compilarti la mia immagine tieni conto di queste cose:

 1) Non potrai istallare moduli del kernel (a meno di compilarli con esso) dopo aver generato l'immagine perchè il magik number del kernel ricompilato sarà differente da quello che si aspettano i pacchetti nel repository. Se ci provi opkg ti dirà che il modulo che stai cercando di istallare non è stato compilato per il kernel in uso e fallirà l'istallazione. C'è un modo per ovviare al problema ma devi "hakerare" un po l'image builder di OpenWrt.

2) La mia immagine è basata su trunk: la versione di sviluppo/testing/instabile di OpenWrt.

3) Devi necessariamente compilare l'immagine col kernel di testing 4.19 e non con il kernel 4.14 (con l'ultimo snapshot che ho provato e con cui ho costruito l'immagine col 4.14, non riesce a creare la partizione JFFS e, quindi, crasha all'avvio).

Se vuoi posso inviarti l'ultima immagine che ho fatto col kernel 4.19 un mese fa ma comunque tieni conto di quanto ho scritto sopra.

edit:
ho confrontato il dts fatto da me con quello dell'immagine A4001N1 di OpenWrt. A parte il fatto che i nomi dei LED sono diversi da quelli sullo chasis e che ci sono LED mappati in più che non esistono sull'AGPWI, sembra siano tutti mappati ad eccezione del "power green" che non è mappato affatto. Quindi con l'immagine attuale dell'A4001N1 puoi controllare tutti i LED a meno del "power green".
Nello specifico:

chasis LED name -> LuCI name
power_red            -> A4001N1:red:power
power_green        -> (mappato altrove, dove non c'è collegato alcun LED nell'AGPWI)
adsl_red                -> A4001N1:red:ppp
adsl_green            -> A4001N1:green:ppp
internet_red         -> A4001N1:red:inet
internet_green     -> A4001N1:green:inet
wifi_red                 -> A4001N1:red:wlan
wifi_green             -> A4001N1:green:wlan
service_red           -> A4001N1:red:3g
service_green       -> A4001N1:green:3g
« Ultima modifica: 23 Maggio 2020, 11:15 da Daniele Castro »

Offline Daniele Castro

  • Nuovo Iscritto
  • *
  • 10
Re:Aggiunta del supporto ufficiale dell'AGPWI su OpenWrt
« Risposta #32 il: 22 Maggio 2020, 21:59 »
Sono lieto di annunciarvi che la mia Pull Request è stata accettata!! :D


Da oggi AGPWI ha la sua immagine OpenWrt ufficiale!! :)


Se qualcuno di voi avesse voglia di provare questa immagine su anche AGTWI o su qualunque altro router che credete possa avere la stessa mappatura dei LED, mi faccia sapere se tutti i LED sono correttamente mappati ed hanno il nome corretto. Nel caso estendiamo il supporto OpenWrt anche ad altri modelli simili  ;)

Pull request link: https://github.com/openwrt/openwrt/pull/2598#event-3365959694

Snapshot link: https://downloads.openwrt.org/snapshots/targets/bcm63xx/generic/openwrt-bcm63xx-generic-adb_pdg-a4001n-a-000-1a1-ax-squashfs-cfe.bin
« Ultima modifica: 23 Maggio 2020, 20:40 da Daniele Castro »