[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware

  • 220 Risposte
  • 26869 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #135 il: 05 Marzo 2020, 13:25 »
Allora, sono nella abitazione dove ho collegato il tim hub, nella porta WAN ho attaccato il cavo che proviene dal ONT, ossia da dove arriva internet, ma aime' dando il comando route |grep voip   non mi rende nulla....devo abilitare qualcosa nella GUI del router? ho una linea fibra 1000 di Vodafone...
https://ibb.co/DgQ5sY4

mi sono riletto tutta pagina 8, il mio ONT e' esterno,non mi ha dato mai nessun gateway neppure classe 255.1... avro' bruciato il mac adress +1? non ho ancora cancellato la voce voip4...attendo qualche anima pia :(

mi  faccio edit di nuovo, dato che sono in FTTH leggendo il post 2 di francesco leggo   INTERFACE="ptm0" #se FTTH cambiare in "eth4" (ptm0 = VDSL),quindi immagino che debba inserire al posto di config device 'voipptm0'   config device 'voipeth4'  giusto?


Grazie
« Ultima modifica: 05 Marzo 2020, 17:52 da maxking »

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #136 il: 05 Marzo 2020, 19:33 »
Devi mettere eth4 al posto di ptm0 in tutti e quattro i punti in cui lo vedi alla fase 3 in prima pagina.

ptm0 è il modem, e tu non vuoi utilizzare il modem, vuoi usare l'ont connesso ad eth4

@gacchu un paio di patch (ti riporto di sana pianta i primi due codebox di fase 3):
Codice: [Seleziona]
option password 'vodafone'
option username 'D-X12345678912345' # al posto di X123… inserite il seriale della vostra Vodafone Station
option host_uniq '583132333435363738393132333435' # inserite il vostro host_uniq di 30 caratteri (alfa)numerici
Codice: [Seleziona]
config device 'voipptm0' # o voipeth4 con ONT o modem ethernet esterno
 option type '8021q'
 option name 'voipptm0' # o voipeth4 con ONT o modem ethernet esterno
 option macaddr 'mac_address' # inserite il MA generato precedentemente
 option ifname 'ptm0' # o eth4 con ONT o modem ethernet esterno
 option ipv6 '0'
 option vid '1035'

config interface 'voip'
 option auto '1'
 option proto 'pppoe'
 option demand '0'
 option macaddr 'mac_address' # inserite lo stesso MA di voipptm0
 option ipv6 '0'
 option keepalive_adaptive '0'
 option ifname 'voipptm0' # o voipeth4 con ONT o modem ethernet esterno
 option password 'vodafone'
 option username 'V-X12345678912345' # al posto di X123… inserite il seriale della vostra Vodafone Station
 option host_uniq '583132333435363738393132333435' # inserite il vostro host_uniq di 30 caratteri (alfa)numerici
 option keepalive '4,20'
 option defaultroute '0'
« Ultima modifica: 05 Marzo 2020, 19:47 da LuKePicci »

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #137 il: 05 Marzo 2020, 20:15 »
Immaginavo che era quello il problema, editato ed ora mi rende il gateway, prima di andare avanti, e' valido questo gateway?
1.255.120.1

Attendo una risposta prima di procedere, grazie

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #138 il: 05 Marzo 2020, 21:25 »
Controlla tu stesso, in prima pagina è scritto come fare a verificare che funzioni. Dovresti riuscire a fare un ping al proxy.

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #139 il: 06 Marzo 2020, 05:15 »
Buongiorno.... notte passata a smanettare un po, tanto per non farci mancare nulla... mi piacciano queste cose, sempre quando vanno a buon fine, per ora nulla.
Io ho cercato in tutte le parti di non sbagliare valori, ma purtroppo oltre che il voip, neppure riesco a navigare
Questi sono i vari file che ho modificato, ora il gateway inserendo il mac adress che avete postato a pagina 7 mi rende 1.94.128.1, ma il ping al proxy non va, sono arrivato fino alla fine della guida
dove sto sbagliando? fiducioso di risolvere
ho aggiunto anche il file mmpbxrvsipnet per ultimo, che come vedete ho oscurato i miei dati...ho dovuto mettere su  option interface 'wan'  ho messo voip...

Aggiungo che da quando ho variato il file dhcp  devo inserire un ip fisso nelle impostazioni della scheda di rete, altrimenti non mi fa entrare dentro il 192.168.1.1

https://ibb.co/M16zvHT

Grazie ancora


Codice: [Seleziona]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'none'
option default_ps '0'

config device 'waneth4'
option type '8021q'
option name 'waneth4'
option macaddr 'A4:21:C3:17:B3:33'  <--- e' un altro
option ifname 'eth4'
option vid '835'
option ipv6 '0'

config device 'wanptm0'
option type '8021q'
option name 'wanptm0'
option macaddr 'A4:21:C3:17:B3:33'   <--- e' un altro
option ifname 'ptm0'
option vid '835'
option ipv6 '0'

config interface 'wan'
option auto '1'
option proto 'pppoe'
option demand '0'
option username 'D-WXXXXXXXXX'  OSCURATO
option password 'vodafone'
option macaddr 'A4:21:C3:17:B3:33'  <--- e' un altro
option ipv6 '0'
option peerdns '1'
option reqopts '1 3 6 15 33 42 51 121 249'
option keepalive_adaptive '0'
option dns_metric '0'
option host_uniq 'XXXXXXXXXXXXXXXXXXX'   OSCURATO
option ifname 'waneth4'

config route 'voip_private'
option interface 'voip'
option netmask '255.0.0.0'
option metric '1'
option target '10.0.0.0/8'
option gateway '1.94.128.1' # inserite qui il vostro gateway

config config 'config'
option wan_mode 'pppoe'

config interface 'wwan'
option auto '1'
option proto 'mobiled'
option session_id '0'
option profile '1'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
option reqopts '12 21 22 23 24 25 31 56 64 67 82 83'
option noslaaconly '1'
option iface_464xlat '0'
option auto '0'
option dns_metric '20'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ipv6 '0'
option ifname 'eth0 eth1 eth2 eth3 eth5'
list pppoerelay 'waneth4'

config switch 'bcmsw'
option reset '1'
option enable_vlan '0'
option qosimppauseenable '0'
option jumbo '0'

config interface 'wlnet_b_24'
option proto 'static'
option ip6assign '64'
option ipv6 '0'
option ip6hint '1'
option netmask '255.255.255.128'
option ipaddr '192.168.168.1'
option ifname 'wl0_1'
option force_link '0'
option name 'Ospiti-TIM-18332035'

config interface 'wlnet_b_5'
option proto 'static'
option ip6assign '64'
option ipv6 '0'
option ip6hint '2'
option netmask '255.255.255.128'
option ipaddr '192.168.168.129'
option ifname 'wl1_1'
option force_link '0'
option name 'Ospiti-TIM-18332035'

config device 'wlnet_b_5eth5'
option type '8021q'
option name 'wl1_1'
option enabled '1'
option ifname 'eth5'
option vid '3'
option ipv6 '0'

config interface 'sfptag'
option proto 'static'
option netmask '255.255.255.128'
option ifname 'eth4'
option ipaddr '192.168.10.1'

config interface 'ipoe'
option proto 'dhcp'
option metric '1'
option reqopts '1 3 6 43 51 58 59'
option release '1'
option neighreachabletime '1200000'
option neighgcstaletime '2400'
option ipv6 '1'

config device 'voipeth4'
option type '8021q'
option name 'voipeth4'
option macaddr 'E4:8F:34:3A:82:15'
option ifname 'eth4'
option ipv6 '0'
option vid '1035'

config interface 'voip'
option auto '1'
option proto 'pppoe'
option demand '0'
option macaddr 'E4:8F:34:3A:82:15' MESSO QUELLO POSTATO PERCHE ALTRO ERA 1.255
option ipv6 '0'
option keepalive_adaptive '0'
option ifname 'voipeth4'
option password 'vodafone'
option username 'V-WXXXXXXXXXXX'
option host_uniq 'XXXXXXXXXXXXXXXXXXXXXX'
option keepalive '4,20'
option defaultroute '0'



Codice: [Seleziona]
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option drop_invalid '1'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option mtu_fix '1'
option wan '0'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
list network 'wwan'
        list network 'voip'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
option masq '1'
option conntrack '1'
option mtu_fix '1'
option wan '1'

config forwarding
option src 'lan'
option dest 'wan'

config zone 'z_wlnetb24'
option name 'z_wlnetb24'
list network 'wlnet_b_24'
option input 'DROP'
option output 'ACCEPT'
option forward 'REJECT'
option mtu_fix '1'
option wan '0'

config forwarding 'for_wlnetb24'
option src 'z_wlnetb24'
option dest 'wan'

config rule 'Drop_non_TCP_SYN'
option name 'Drop_non_TCP_SYN'
option src 'wan'
option dest '*'
option proto 'tcp'
option target 'DROP'
option extra '! --tcp-flags ALL SYN'

config rule 'drop_lan_2_z_wlnetb24'
option name 'drop_lan_2_z_wlnetb24'
option src 'lan'
option dest 'z_wlnetb24'
option proto 'all'
option target 'DROP'

config rule 'drop_z_wlnetb24_2_lan'
option name 'drop_z_wlnetb24_2_lan'
option src 'z_wlnetb24'
option dest 'lan'
option proto 'all'
option target 'DROP'

config rule 'drop_lan_2_z_wlnetb24_GW'
option name 'drop-lan_2_z_wlnetb24_GW'
option src 'lan'
option proto 'all'
option target 'DROP'
option family 'ipv4'
option dest_ip '192.168.168.1'

config rule 'Allow_z_wlnetb24_ICMP'
option name 'Allow_z_wlnetb24_ICMP'
option src 'z_wlnetb24'
option proto 'igmp'
option target 'ACCEPT'
option family 'ipv4'
option dest_ip '192.168.168.1'

config rule 'Allow_z_wlnetb24_DHCP'
option name 'Allow_z_wlnetb24_DHCP'
option src 'z_wlnetb24'
option proto 'udp'
option dest_port '67'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb24_DNS'
option name 'Allow_z_wlnetb24_DNS'
option src 'z_wlnetb24'
option proto 'udp'
option dest_port '53'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb24_ICMPv6'
option name 'Allow-z_wlnetb24_ICMPv6'
option src 'z_wlnetb24'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config zone 'z_wlnetb5'
option name 'z_wlnetb5'
list network 'wlnet_b_5'
option input 'DROP'
option output 'ACCEPT'
option forward 'REJECT'
option wan '0'

config forwarding 'for_wlnetb5'
option src 'z_wlnetb5'
option dest 'wan'

config rule 'drop_lan_2_z_wlnetb5'
option name 'drop_lan_2_z_wlnetb5'
option src 'lan'
option dest 'z_wlnetb5'
option proto 'all'
option target 'DROP'

config rule 'drop_z_wlnetb5_2_lan'
option name 'drop_z_wlnetb5_2_lan'
option src 'z_wlnetb5'
option dest 'lan'
option proto 'all'
option target 'DROP'

config rule 'drop_lan_2_z_wlnetb5_GW'
option name 'drop-lan_2_z_wlnetb5_GW'
option src 'lan'
option proto 'all'
option target 'DROP'
option family 'ipv4'
option dest_ip '192.168.168.129'

config rule 'Allow_z_wlnetb5_ICMP'
option name 'Allow_z_wlnetb5_ICMP'
option src 'z_wlnetb5'
option proto 'igmp'
option target 'ACCEPT'
option family 'ipv4'
option dest_ip '192.168.168.129'

config rule 'Allow_z_wlnetb5_DHCP'
option name 'Allow_z_wlnetb5_DHCP'
option src 'z_wlnetb5'
option proto 'udp'
option dest_port '67'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb5_DNS'
option name 'Allow_z_wlnetb5_DNS'
option src 'z_wlnetb5'
option proto 'udp'
option dest_port '53'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb5_ICMPv6'
option name 'Allow-z_wlnetb5_ICMPv6'
option src 'z_wlnetb5'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule1'
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule 'rule2'
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule 'rule3'
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule4'
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule5'
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule6'
option name 'access_2_LAN_IP'
option src 'lan'
option proto 'tcp'
option family 'ipv4'
option extra '-m multiport --dports 80,22,8080,443,8443 -m addrtype --limit-iface-in ! --dst-type LOCAL'
option target 'REJECT'

config rule 'rule7'
option name 'close_port_139'
option src 'wan'
option proto 'tcp'
option dest_port '139'
option family 'ipv4'
option target 'DROP'

config rule 'rule8'
option name 'close_port_445'
option src 'wan'
option proto 'tcp'
option dest_port '445'
option family 'ipv4'
option target 'DROP'

config rule 'rule10'
option name 'Deny-CUPS-wan'
option src 'wan'
option proto 'tcp'
option dest_port '631'
option family 'ipv4'
option target 'DROP'

config rule 'rule12'
option name 'Deny-CUPS-wan-v6'
option src 'wan'
option proto 'tcp'
option dest_port '631'
option family 'ipv6'
option target 'DROP'

config rule 'SSH_wan'
option name 'SSH_wan'
option src 'wan'
option proto 'tcp'
option dest_port '22'
option target 'DROP'
option family 'ipv4'

config include
option path '/etc/firewall.user'

config include 'tchext_restart'
option type 'script'
option path '/lib/functions/firewall-restart-ext-tch.sh'

config include 'tchext'
option type 'script'
option path '/lib/functions/firewall-ext-tch.sh'
option reload '1'

config cone 'cone1'
option name 'PS and XBox Live 1'
option src 'wan'
option dest_port '88'

config cone 'cone2'
option name 'PS and XBox Live 2'
option src 'wan'
option dest_port '3074:3658'

config cone 'cone3'
option name 'PS and XBox Live 3'
option src 'wan'
option dest_port '10070'

config cone 'cone4'
option name 'PS and XBox Live 4'
option src 'wan'
option dest_port '4500'

config include 'tod'
option type 'script'
option path '/lib/functions/tod.sh'
option reload '1'

config include 'intercept'
option type 'script'
option path '/usr/lib/intercept/firewall.sh'

config fwconfig 'fwconfig'
option defaultoutgoing_lax 'ACCEPT'
option defaultoutgoing_normal 'ACCEPT'
option defaultoutgoing_high 'DROP'
option defaultoutgoing_user 'ACCEPT'
option defaultincoming_lax 'REJECT'
option defaultincoming_normal 'DROP'
option defaultincoming_high 'DROP'
option defaultincoming_user 'DROP'
option level 'normal'
option dmz '0'

config rulesgroup 'pinholerules'
option enabled '1'
option name 'FW rules for opening pinholes'
option type 'pinholerule'

config redirectsgroup 'userredirects'
option enabled '1'
option name 'FW redirects defined by the user'
option type 'userredirect'

config redirectsgroup 'dmzredirects'
option enabled '0'
option name 'FW redirects for the DMZ functionality'
option type 'dmzredirect'

config dmzredirect 'dmzredirect'
option name 'DMZ rule'
option src 'wan'
option dest 'lan'
option family 'ipv4'
option target 'DNAT'
option proto 'tcpudp'
option enabled '0'

config rulesgroup 'normalrules'
option enabled '1'
option name 'FW rules for normal level'
option type 'normalrule'

config rulesgroup 'laxrules'
option enabled '0'
option name 'FW rules for lax level'
option type 'laxrule'

config rulesgroup 'highrules'
option enabled '0'
option name 'FW rules for high level'
option type 'highrule'

config rulesgroup 'userrules'
option enabled '0'
option name 'FW rules for user level'
option type 'userrule'

config rulesgroup 'userrules_v6'
option enabled '0'
option name 'FW rules for user level IPv6'
option type 'userrule_v6'

config rulesgroup 'defaultrules'
option enabled '1'
option name 'FW rules for default behavior'
option type 'defaultrule'

config highrule 'highrule1'
option name 'HTTP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '80'
option target 'ACCEPT'

config highrule 'highrule2'
option name 'HTTPS'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '443'
option target 'ACCEPT'

config highrule 'highrule3'
option name 'SMTP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '25'
option target 'ACCEPT'

config highrule 'highrule4'
option name 'POP3'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '110'
option target 'ACCEPT'

config highrule 'highrule5'
option name 'IMAP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '445'
option target 'ACCEPT'

config highrule 'highrule6'
option name 'SSH'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '22'
option target 'ACCEPT'

config defaultrule 'defaultipv6incoming'
option name 'Default action for incoming IPv6 traffic'
option src 'wan'
option dest 'lan'
option proto 'all'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'

config defaultrule 'defaultipv6outgoing'
option name 'Default action for outgoing IPv6 traffic'
option src 'lan'
option dest 'wan'
option proto 'all'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'

config defaultrule 'defaultoutgoing'
option name 'Default action for outgoing NAT'
option src 'lan'
option dest 'wan'
option proto 'all'
option target 'ACCEPT'

config helper 'helper1'
option helper 'ftp'
option dest_port '21'
option proto 'tcp'

config helper 'helper2'
option helper 'tftp'
option dest_port '69'
option proto 'udp'

config helper 'helper3'
option helper 'snmp'
option family 'ipv4'
option dest_port '161'
option proto 'udp'

config helper 'helper4'
option helper 'pptp'
option family 'ipv4'
option dest_port '1723'
option proto 'tcp'

config helper 'helper5'
option enable '0'
option helper 'sip'
option dest_port '5060'
option proto 'udp'

config helper 'helper6'
option helper 'sip'
option dest_port '5060'
option proto 'udp'
option intf 'loopback'

config helper 'helper7'
option helper 'irc'
option family 'ipv4'
option dest_port '6667'
option proto 'tcp'

config helper 'helper8'
option helper 'amanda'
option dest_port '10080'
option proto 'udp'

config helper 'helper9'
option helper 'rtsp'
option dest_port '554'
option family 'ipv4'
option proto 'tcp'

config include 'cwmpd'
option type 'script'
option path '/lib/functions/firewall-cwmpd.sh'
option reload '1'

config include 'dhcpsnooper'
option type 'script'
option path '/lib/functions/firewall-dhcpsnooper.sh'
option reload '1'

config include 'snmpd'
option type 'script'
option path '/lib/functions/firewall-net-snmp.sh'
option reload '1'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd-tch/firewall.include'
option family 'IPv4'
option reload '1'

config include 'mmpbx'
option type 'script'
option path '/lib/functions/firewall-mmpbx.sh'
option reload '1'

config include 'weburl'
option type 'script'
option path '/lib/functions/weburl-tch.sh'
option reload '1'

config include 'dropbear'
option type 'script'
option path '/lib/functions/firewall-dropbear.sh'
option reload '1'


Codice: [Seleziona]
config dnsmasq 'dnsmasq'
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '0'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'homenet.telecomitalia.it'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
        option cachelocal '1'
        option cachesize '200'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option strictorder '1'
option dhcpscript '/lib/dnsmasq/dhcp-event.sh'
list hostname 'dsldevice'
option allservers '1'
        option addmac '0'
list server '/proxy.dsl.vodafone.it/91.80.35.167' #risolvi i proxy voip tramite dns vodafone/primario
list server '/proxy.dsl.vodafone.it/91.80.35.134' #risolvi i proxy voip tramite dns vodafone/secondario
list rebind_domain '/proxy.dsl.vodafone.it/' #ammetti rebind per nomi proxy voip
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,6,"4132"'
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,5,"CP1750RAQCG"'
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,4,"A491B1"

config odhcpd 'odhcpd'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'lan'
option interface 'lan'
option start '2'
option limit '254'
option leasetime '21600'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1500'
option force '1'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,6,"4132"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,5,"CP1736SA2AG"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,4,"A491B1"'
option ignore '0'

config dhcp 'wlnet_b_24'
option interface 'wlnet_b_24'
option start '2'
option leasetime '1h'
option force '1'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1480'
option limit '125'

config dhcp 'wlnet_b_5'
option interface 'wlnet_b_5'
option start '130'
option leasetime '1h'
option force '1'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1480'
option limit '125'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config dhcp 'wan6'
option interface 'wan'
option ignore '1'

config dhcp 'wwan'
option interface 'wwan'
option ignore '1'

config opassthrud 'opassthrud'
option passthruscript '/lib/dhcpopassthrud/dnsmasq.sh'
option options_needed '0'

config relay 'relay'

config dnsmasq 'dnsmasq'


Codice: [Seleziona]
config mmpbxrvsipnet 'global'
option trace_level '2'
option radvision_trace_level '0'

config syslog 'syslog'
option registration '1'
option call_signalling '1'
option syslog_priority '6'
option hide_user_identity '0'
option log_sip_message '0'

config network 'sip_net'
option user_friendly_name 'SIP network'
option cac '-1'
option transparent_soc_transmission '0'
option interface 'voip'
option local_port '5060'
option domain_name 'ims.vodafone.it'
option primary_proxy 'proxy1-XXXXX-XXXXXXX.proxy.dsl.vodafone.it'
option primary_proxy_port '5060'
option primary_registrar 'registrar1-XXXXXX-XXXXXX.proxy.dsl.vodafone.it'
option primary_registrar_port '5060'
option secondary_proxy_port '5060'
        option secondary_proxy 'proxy2-XXXXXX-XXXXX.proxy.dsl.vodafone.it'
option secondary_registrar 'registrar2-XXXXX-XXXXXX.proxy.dsl.vodafone.it'
option secondary_registrar_port '5060'
option transport_type 'UDP'
option reg_expire '3600'
option reg_expire_T_before '1'
option reg_back_off_timeout '60'
option reg_back_off_timeout_algorithm 'fixed'
option reg_back_off_timeout_max '900'
option reg_back_off_timeout_min '600'
option re_registration_mode 'ims'
option realm 'digest.telecomitalia.it'
option realm_check '0'
option 401_407_waiting_time '0'
option dtmf_relay 'rfc2833'
option dtmf_relay_translation '0'
option timer_T1 '500'
option timer_T2 '4000'
option timer_T4 '5000'
option timer_B '32000'
option timer_D '50000'
option timer_F '32000'
option timer_J '32000'
option provisional_timer '1200'
option remote_hold_tone_enabled '0'
option sdp_direction_call_hold 'sendonly'
option sdp_direction_call_hold_answer 'recvonly'
option uri_clir_format 'standard'
option privacy_handling 'apply'
option rejection_response '486'
option no_answer_response '480'
option call_waiting_provisional_response '180'
option call_waiting_alert_info '0'
option call_waiting_reject_response '486'
option reliable_provisional_response 'when_supported'
option forking_mode 'replace'
option ingress_media_timeout '1000'
option session_timer 'disabled'
option min_session_expires '90'
option session_expires '180'
option fail_behaviour 'stop'
option min_period_proxy_redundancy '0'
option escape_hash '1'
option escape_star '0'
option control_qos_field 'dscp'
option control_qos_value '40'
option realtime_qos_field 'dscp'
option realtime_qos_value '40'
option from_anonymous_handling 'withheld'
option sip_over_ipv6 '0'
option rtp_local_port_min '16384'
option rtp_local_port_max '32767'
option user_param_value 'phone'
option include_sip_instance '1'
option feature_tag_value 'urn%3Aurn-7%3A3gpp-service.ims.icsi.mmtel'
option waiting_time_for_registration_on_400_or_503_response '60'
option conference_factory_uri_user_part '[email protected]'
option hide_serial_number '1'
option use_domain_in_contact '0'
option use_domain_in_via '0'
option update_support '1'
option sdp_direction_attribute_media_level_only '1'
option stick_to_outbound_proxy '1'
option registration_delay '5'
option enable_re_register_on_cancel_timeout '1'
option rport_in_via '1'
option optimized_authentication '1'
option repeat_ringing_interval '0'
option re_register_on_403 '0'
option check_ttl_for_dns_record '1'
option dns_query_timeout '5000'
option sip_message_max_size '4096'
option switch_back_to_primary_proxy_timer '0'
option conference_release_call_after_transfer '0'
option disconnect_on_bye_response '1'
option cancel_invite_timer '64000'
option dnd_response '486'
option early_media_detection '0'
option hide_userinfo_and_port_in_subscription_request '0'
option user_agent 'Technicolor / VBNT-S / AGTHP_1.0.3 / AGTHP_1.0.3'

config profile 'sip_profile_0'
option network 'sip_net'
option enabled '1'
option password 'line0'
option user_name '[email protected]'
option uri '+39075XXXXXXXX'
        option display_name '+3907XXXXXXX'
        option password 'xxxxxxxxxxxxxxxxxxxxxxxxx'

config profile 'sip_profile_1'
option network 'sip_net'
option enabled '0'
option password 'line1'
option user_name 'line1'
option uri 'line1'

config profile 'sip_profile_2'
option network 'sip_net'
option enabled '0'
option password 'line2'
option user_name 'line2'
option uri 'line2'

« Ultima modifica: 06 Marzo 2020, 10:42 da maxking »

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #140 il: 06 Marzo 2020, 11:54 »
Hai configurato perfettamente il voip e la sua rete, ,ma hai toppato con la configurazione della rete internet lasciando un VID sbagliato in waneth4.

Il MAC precedente non ti dava un gateway voip corretto perchè per fargli prendere un nuovo mac è necessario che la connessione wan con lo stesso tag sia nel mentre già attiva. Finchè non lo è l'unico mac capace di funzionare è quello precedente. Se prima di configurare il voip ti occupavi di far funzionare internet non avresti avuto quel problema.

Il ping ai proxy su rete voip non funziona senza aver attivato anche la rete internet perchè la risoluzione dei loro nomi passa per la seconda, con un ping ai loro ip dovrebbe già funzionare.

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #141 il: 06 Marzo 2020, 11:59 »
Grazie luke, non sparire.... hehehe  quindi che VID devo mettere in waneth4?
quindi provo a rimettere anche il +1 dopo che ho cambiato il vid... ci sto impazzendo da ieri :(

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #142 il: 06 Marzo 2020, 12:08 »
Il vid corretto è ovviamente 1036, come da docu ufficiale, ma anche nel primo link in cima alla prima pagina di questo thread. Qui @gacchu ha descritto solo la parte di configurazione ine3rente il VoIP, è dato per scontato che la rete dati sia già a posto.

Il mac che hai usato indicto a pagina 6 è un MAC che qualcuno ha già "attivato" per questo funziona, è meglio se ne usi uno tuo che non sia il clone di nient'altro. Se col +1 hai problemi fatti un +2

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #143 il: 06 Marzo 2020, 12:18 »
infatti che non era  completa spiegazione anche per il discorso della rete, ok ho impostato 1036 il waneth4, ho messo il +1 del mio mac nelle 2 voci  e oggi quando torno cambio anche il gateway( immagino che cambiando mac adress, vari anche il gateway), ora non lo posso connettere... e spero che fili tutto liscio
Grazie infintie per ora

EDIT aggiornamento:  Ora navigo tranquillamente, purtroppo variando il mac adress con +1 o +2 o+3 mi rende sempre la classe 1.255,
con il mac adress di pagina 7 tutto funziona anche il TELEFONO !!! :D
Unica cosa che sto notando che ancora devo impostare un ip fisso per accedere al router e se entro nella gui del modem clicco su rete locale mi rende un errore 500 server interno
Ce' sicuramente un problema nel file DNS masq, prima mi funzionava,non prende il dhcp neppure con  wifi

e' giusto avere questa configurazione?   io ho inserito per i dati internet il vid 1036 
Codice: [Seleziona]
[/config device 'voipeth4'
option type '8021q'
option name 'voipeth4'
option macaddr 'XXXXXXXX'
option ifname 'eth4'
option ipv6 '0'
option vid '1035'
code]
« Ultima modifica: 06 Marzo 2020, 15:30 da maxking »

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #144 il: 07 Marzo 2020, 02:57 »
Vedete qualcosa di anomalo in questo file DHCP, non riesce a prenderlo in automatico, ma devo impostare sia da pc che nei telefoni un ip fisso....
se entro dentro il modem la sezione rete locale mi rende un errore 500 ,dopo averlo modificato, prima il dhcp lo prendeva in automatico senza impsotare IP

E cmq ho ritprovato decine di mac adress differenti e mi rende sempre 1.255, host uniq lo calcolo qua  https://codebeautify.org/string-hex-converter  inserendo anche la lettera del seriale in MAIUSCOLO...e ' ok? vengono fuori 30 numeri

Codice: [Seleziona]
[/
config dnsmasq 'dnsmasq'
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '0'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'homenet.telecomitalia.it'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
        option cachelocal '1'
        option cachesize '200'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option strictorder '1'
option dhcpscript '/lib/dnsmasq/dhcp-event.sh'
list hostname 'dsldevice'
option allservers '1'
        option addmac '0'
list server '/proxy.dsl.vodafone.it/91.80.35.167' #risolvi i proxy voip tramite dns vodafone/primario
list server '/proxy.dsl.vodafone.it/91.80.35.134' #risolvi i proxy voip tramite dns vodafone/secondario
list rebind_domain '/proxy.dsl.vodafone.it/' #ammetti rebind per nomi proxy voip
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,6,"4132"'
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,5,"CP1750RAQCG"'
list dhcp_option_force 'tag:cpewan-id,vi-encap:3561,4,"A491B1"

config odhcpd 'odhcpd'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'lan'
option interface 'lan'
option start '2'
option limit '254'
option leasetime '21600'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1500'
option force '1'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,6,"4132"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,5,"CP1736SA2AG"'
list dhcp_option 'tag:cpewan-id,vi-encap:3561,4,"A491B1"'
option ignore '0'

config dhcp 'wlnet_b_24'
option interface 'wlnet_b_24'
option start '2'
option leasetime '1h'
option force '1'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1480'
option limit '125'

config dhcp 'wlnet_b_5'
option interface 'wlnet_b_5'
option start '130'
option leasetime '1h'
option force '1'
option dhcpv6 'server'
option ra 'server'
option ra_management '0'
option ra_mininterval '200'
option ra_maxinterval '600'
option ra_lifetime '1800'
option ra_hoplimit '64'
option ra_max_mtu '1480'
option limit '125'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config dhcp 'wan6'
option interface 'wan'
option ignore '1'

config dhcp 'wwan'
option interface 'wwan'
option ignore '1'

config opassthrud 'opassthrud'
option passthruscript '/lib/dhcpopassthrud/dnsmasq.sh'
option options_needed '0'

config relay 'relay'

config dnsmasq 'dnsmasq'

code]
« Ultima modifica: 07 Marzo 2020, 08:09 da maxking »

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #145 il: 07 Marzo 2020, 18:07 »
@maxking questo problem al dhcp locale non ha nulla a che vedere con la config voip per Vodafone, prova a chiedere el thread relativo al tuo 4132 (se non hai applicato la gui custom) o nel thread della custom gui (nel caso in cui il problema si sia presentato dopo averla installata). Se non sai cosa ha causato quel problema ti suggerisco di resettare tutto e ricominciare da capo. Non tornare a preoccuparti della configurazione del voip prima di avere internet e rete locale perfettamente funzionante. A quel punto torna pure qui a chiedere nuovamente aiuto se hai ancora problemi con la configurazione voip

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #146 il: 08 Marzo 2020, 05:50 »
invece e' proprio dopo aver modificato il file dhcp.... dopo averlo resettato 2 volte viene fuori questo problema, tra altro lo scripth di francesco non carica tutto,si ferma qua  https://ibb.co/wNpC15q
ora sinceramente mi sono un po stancato,spero più avanti che si trovi una soluzione migliore, al momento lo ho accantonato per una soluzione più definitiva
Grazie per tutto il lavoro che state facendo,ma a parer mio e' ancora beta, specialmente nel macadress voip clonato




Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2305
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #147 il: 08 Marzo 2020, 11:39 »
Non mi viene in mente nessun motivo per cui modificando quelle 7 righe (se ne hai modificate altre stai sbagliando qualcosa) l'assegnazione automatica di IP su LAN possa rompersi.

Il mac address non va clonato, come detto piu volte se uno segue correttamente la guida sui giusti presupposti il tutto funziona regolarmente. Se qualcosa va storto invece iniziano le rogne perché c'è poi da fare i conti con quello che l'AC di Vodafone ha capito dai precedenti tentativi andati male. In tutto ciò per quanto riguarda il tuo caso non abbiamo mai valutato l'idea che tu possa aver sbagliato a configurare gli host_uniq. Quando non si riesce in nessun modo ad usare il mac impostato di solito il problema è lì.

Offline maxking

  • Membro Giovane
  • **
  • 57
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #148 il: 08 Marzo 2020, 17:02 »
se ho tempo ritento per la terza volta... ma sono certo che e' il file dhcp

i presupposti sono giusti, ma rimane il fatto che rende sempre 1.255

Offline FrancYescO

  • VIP
  • *****
  • 2783
Re:[GUIDA] Configurazione VoIP Vodafone su OpenWrt e Homeware
« Risposta #149 il: 08 Marzo 2020, 18:38 »
non carica tutto,si ferma qua  https://ibb.co/wNpC15q
non mi sembra sia bloccato, anzi.. e' arrivato fino in fondo e devi dare l'ultimo invio per fare il restart di quel servizio