IlPuntoTecnico

Hardware e Software => Connessioni ADSL/VDSL/FTTC => Topic aperto da: Ponz - 05 Maggio 2021, 09:08

Titolo: Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 09:08
salve, mi e' stato dato un altro modem Technicolor TG789vac Xtream 35b proveniente da contratto fastweb, ne ho gia' uno sbloccato che uso quotidianamente.
questo, anche dopo averlo resettato, non mi assegna ip dalle porte ethernet, solo se attacco il cavo nella WAN rossa mi da ip 192.168.1.254, riesco a vedere l' interfaccia web , ma ne inserendo Administrator ne fastweb come utente non riesco ad accedere, mi da "nome utente o password non validi"
ce qualche possibilita' di entarci ? come mai solo dalla porta WAN ?
grazie
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 12:01
A meno di particolari esigenze, ti consiglio di eliminare il firmware di fasteweb con quello di tim S.Marino. Molto pi nuovo di concezione e con meno bugs. Non esiste il file .rbi ma solo il dump:
https://hack-technicolor.readthedocs.io/en/stable/Repository/#tim-san-marino
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 12:24
grazie della risposta
lo cambierei molto volentieri, ma sono bloccato alla schermata di accesso del router e non mi entra con nessuna password, quindi non saprei come fare, anche perche' via lan non va, e' un router di una connessione fftc business fastweb attaccata alla rete WAN con un aehtra messo in lan e li dava la rete
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 12:34
Che abbia un firm diverso da quelli noti?
Prova admin/access_key o tch-exploit per avere il root
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 12:46
Prova admin/access_key
ok questo provato con access key sotto il router ma niente

tch-exploit come lo faccio ? grazie
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 12:48
https://github.com/BoLaMN/tch-exploit
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 05 Maggio 2021, 12:56
puoi postare uno screenshot della pagina web di accesso che vedi? brandizzata?
hai controllato se per caso c' anche telnet esposto?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 13:57
Altra cosa, se il dhcp non rilascia ip via lan probabile che sia disattivato, ma non detto che tu non possa accederci mettendo un ip fisso.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 15:12
puoi postare uno screenshot della pagina web di accesso che vedi? brandizzata?
hai controllato se per caso c' anche telnet esposto?

vedo questo tramite cavo attaccato dal pc alla porta WAN rossa e il dhcp funziona, ip router 192.168.1.254
(https://i.postimg.cc/dkRL2RRz/IMG-20210505-144425-Media.jpg) (https://postimg.cc/dkRL2RRz)

https://github.com/BoLaMN/tch-exploit

mi rimane fermo qua
(https://i.postimg.cc/wyY1R4NX/IMG-20210505-143644-Media.jpg) (https://postimg.cc/wyY1R4NX)
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 15:44
Se non riesci in nessun modo a proseguire non ti resta che caricarci un firmware con TFTP, sbloccarlo e procedere come meglio credi. Con la speranza che la bank_1 sia attiva altrimenti devi usare il failboot per passare in bank_2.

P.S. Non credo che i/il firmware/s presenti nel router siano particolarmente interessanti visto la data della pagina del login (2015).
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 16:14
sempre nella mia ignoranza... che significa TFTP ?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 16:22
Vale per tutti i tecnocolorati:
https://www.ilpuntotecnico.com/forum/index.php/topic,77981.msg245030.html#msg245030
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 05 Maggio 2021, 17:24
per quanto vecchio resta comunque curioso che abbiano un firmware apposito per le linee business
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 18:57
Vale per tutti i tecnocolorati:
https://www.ilpuntotecnico.com/forum/index.php/topic,77981.msg245030.html#msg245030

ok adesso provo quella procedura, nel caso che firmware mi consigli da buttarci su ? grazie
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 19:29
Il punto di arrivo dovrebbe essere il 16.3 di S. Marino del quale per non abbiamo l'RBI da caricare tramite TFTP ma solo il dump da mettere con mtd write.
Quindi per iniziare basta un 16.2.8706 qualsiasi da sbloccare per poi sostituirlo con il 16.3.
Una volta sbloccato se ci fai il favore di fare il dump del firmware vecchio
Codice: [Seleziona]
dd if=/dev/mtd4 of=/tmp/dump.bin e postarlo da qualche parte per poterlo esaminare
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 21:20
allora questo e' quello che succede con la procedura sopra segnalata in TFTP
in sequenza quello che succede
(https://i.postimg.cc/zHJZ72WM/IMG-20210505-205520.jpg) (https://postimg.cc/zHJZ72WM) (https://i.postimg.cc/qNWPSvy2/IMG-20210505-205536.jpg) (https://postimg.cc/qNWPSvy2) (https://i.postimg.cc/JyJfLC5v/IMG-20210505-205549.jpg) (https://postimg.cc/JyJfLC5v) (https://i.postimg.cc/CBgWMrv1/IMG-20210505-205604.jpg) (https://postimg.cc/CBgWMrv1) (https://i.postimg.cc/QKNw19ZZ/IMG-20210505-205636.jpg) (https://postimg.cc/QKNw19ZZ) (https://i.postimg.cc/SnX0gM2y/IMG-20210505-205640.jpg) (https://postimg.cc/SnX0gM2y) (https://i.postimg.cc/gntFyD0S/IMG-20210505-205646.jpg) (https://postimg.cc/gntFyD0S) (https://i.postimg.cc/jCXr2KYr/IMG-20210505-205648.jpg) (https://postimg.cc/jCXr2KYr) (https://i.postimg.cc/xc1Vb79N/IMG-20210505-205656.jpg) (https://postimg.cc/xc1Vb79N) (https://i.postimg.cc/KkDC17V5/IMG-20210505-205737.jpg) (https://postimg.cc/KkDC17V5) (https://i.postimg.cc/hfjNGd09/IMG-20210505-205804.jpg) (https://postimg.cc/hfjNGd09) (https://i.postimg.cc/bdqKKMDV/IMG-20210505-205810.jpg) (https://postimg.cc/bdqKKMDV) (https://i.postimg.cc/bdLK8T1y/IMG-20210505-205819.jpg) (https://postimg.cc/bdLK8T1y) (https://i.postimg.cc/mt5J1gdK/IMG-20210505-205857.jpg) (https://postimg.cc/mt5J1gdK) (https://i.postimg.cc/QBLzSnZb/IMG-20210505-205912.jpg) (https://postimg.cc/QBLzSnZb) (https://i.postimg.cc/87f3Rg9c/IMG-20210505-205919.jpg) (https://postimg.cc/87f3Rg9c)

in pratica mentre e dopo aver uppato il firmware led arancio e verde blinkano poi si spengono tutti e 2 e riappaiono arancione e verde, si rispengono e riappaiono sempre, a un certo punto si spengono e si accende il led ROSSO, niente dhcp niente di niente, dopo un po' si accende il led dietro la porta di rete a led rosso ma non da ancora dhcp ne entro in web.
arrivata a questa situazione stacco il cavo dalla lan e lo metto sulla WAN e rida' il dhcp e entro nell interfaccia del router 192.168.1.254 fastweb , quella postata sopra
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 21:48
Da quello che vedo Il firmware lo ha caricato correttamente. E la buona notizia che eri in bank_1. La cattiva notizia che la configurazione presente va in conflitto con quella che cerca di caricare e devi provare di eseguire il reset  prima che si riavvii in bank_2.
Se appena lo accendi hai
https://postimg.cc/hfjNGd09
e subito dopo
https://postimg.cc/bdqKKMDV
per 3 volte.
vuol dire che sta andando in fail boot
Tasto reset basta tenerlo pigiato per una decina di secondi per poi rilasciarlo.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 05 Maggio 2021, 22:11
Ho provato pi modi ma.torna sempre a led rosso fisso, ossia alla configurazione con la.porta Wan che da DHCP e suo ip 192.168.1.254 😭😭
Che posso fare oltre a farlo volare dalla finestra?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 05 Maggio 2021, 22:26
Dopo che ha finito di caricare in memoria il firm
https://postimg.cc/QKNw19ZZ
quanto tempo trascorso prima del riavvio? (in pratica dopo la scomparsa della finestra del caricamento avviene il controllo e il flash vero e proprio, quindi un po' di tempo passa, e se si riavviato subito il flash non andato a buon fine)
Quando lo accendi quanto tempo passa prima che si inneschi il fail boot (le 2 foro che ti ho segnalato), e per quante volte compaiono.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: lorenzocanalelc - 06 Maggio 2021, 11:46
Ah ricordo benissimo i problemi di reset con questo router.. Non mi stupirebbe che in realt il firmware sia il solito ma con qualche casino nelle configurazioni... Mi ricordo che io per riuscire a resettarlo dovetti corrompere la Bank1 (Mentre il firmware veniva flashato, dopo l'avvenuto caricamento tramite TFTP, ho spento il router) e solo in questo modo avviandosi in bank2 sono riuscito a fare un reset, potresti provare
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 06 Maggio 2021, 12:00
Qui il problema diverso dal tuo, leggi i post 1 e 3   di @Ponz. Se poi era fallato dall'inizio lo ignoro.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 06 Maggio 2021, 18:43
ho fatto prima a fare un video di quello che succede
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 06 Maggio 2021, 19:13
Il video chiaro carica e fa il flash del firmware e parte in bank_1 o 2 non si sa. Ma non la sequenza riprodotta dalle foto. Che cosa cambiato tra i 2 eventi?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 06 Maggio 2021, 20:42
stessa procedura ho solo cambiato pc da dove ho provato, non so, se si e' innescato qualcosaltro nel fare le circa 446345 prove....
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 06 Maggio 2021, 21:20
La procedura la stessa, ma non il comportamento del router: dopo il caricamento e il successivo riavvio il router si piantato per poi riavviarsi di nuovo. OK poco male.
1) Ora hai riprovato a resettarlo, al ravvio cambiato qualche cosa? Se no passa oltre.
2) Ricarica il firmware, ma questa volta una volta finito di caricare (la finestra del caricamento scopare) foto: https://postimg.cc/QKNw19ZZ.  Attendi che inizi a fare il flash (lampeggio veloce) conta 4/5 secondi e  togli brutalmente l'alimentazione. Questo corromper la bank_1 costringendolo a partire in bank_2.
Ora dovresti vedere  questi led https://postimg.cc/hfjNGd09 spegnersi per 3 volte.
Se s allora eri in bank_1. Al ravvio tenta di fare ripetutamente il reset fino che non si riavvia. Dimmi se cambiato qualche cosa.
Se no allora eri in bank_2. Al ravvio tenta di fare ripetutamente il reset fino che non si riavvia. Se non cambiato nulla ricarica il firmware e prova con il failboot a passare in bank_1.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 07 Maggio 2021, 15:41
allora dopo fatte tutte le prove sopra descritte, mi tornava sempe alla fase led rosso con porta WAN dhcp attivo e wei gui accessibile.
in sintesi, Quando ricaricavo il firmware e spegnevo brutalmente il router lui si riavviava, poi compariva, led arancio e led verde su lan e dopo un po' andava in led rosso e ritornava la situazione WAN attiva anche provandolo a resettare durante le fasi di accensione.
l' unica cosa che e' uscita fuori, non so come, e' la interfaccia wireless attiva, che mi ci collego ma non mi da dhcp
(https://i.postimg.cc/CK4N1y91/IMG-20210507-153559.jpg) (https://postimg.cc/LqnfCW9K)
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 07 Maggio 2021, 15:50
Mi sa tanto che intasato. Dhcp a parte se setti la scheda wifi con ip fisso succede qualche cosa?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 07 Maggio 2021, 16:08
messo scheda wireless su pc in classe192.168.1.x non pingo niente
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 07 Maggio 2021, 16:22
Secondo me non riesce a completare il boot. Se non ricordo male il wifi 2.4 la prima ad attivarsi per poi passare alla lan ed infine la 5 ghz. Sarebbe da attaccarci la seriale per capire cosa succede in realt. Boh. L'unica strada quella dei reset furibondi. La vedo scura.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 08 Maggio 2021, 11:14
allora, ora fase di stallo..

dopo aver provato a riflashare un tot di volte e' rimasto in questo modo con il led verde e non piu' rosso, provato a ricaricare anche dopo questa situazione e ora ritorno sempre cosi', prima mi tornava solo con il led rosso e wan attiva, niente non e'...
(https://i.postimg.cc/dZF0KBfn/2.jpg) (https://postimg.cc/dZF0KBfn)

se premo il pulsante del wifi cerchiato escono fuori i led per circa 4 secondi poi si spengono e rimane solo il led verde sopra
(https://i.postimg.cc/Fd3KqqT7/1.jpg) (https://postimg.cc/Fd3KqqT7)

se attacco la rete alla wan rossa, escono fuori tutti i led in foto e rimangono accesi
(https://i.postimg.cc/rR9wy4XT/3.jpg) (https://postimg.cc/rR9wy4XT)

nei primi 2 casi sopra non mi da dhcp neanhe in wireless

nel terzo caso con la wan attaccata mi da dhcp  e router raggiungibile con 192.168.1.254 ma wifi non da dhcp
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 08 Maggio 2021, 19:41
Ancora non tornato ha posto. Secondo me era stato smanettato in malo modo in origine.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 11 Maggio 2021, 20:41
problema risolto rimediando un altro fastgate un IAD che ho rootato in modo corretto e messa la gui di Ansuel senza problemi, ora e' sbloccato
mi dicevi di metterci il fw di san marino se non sbaglio ma era un file dump quindi da caricare in altro modo, come ? , e' meglio di questo che ho sopra ora ? ci ho messo l' ultima versione disponibile prima di metterci la GUI,  grazie
allego le info del modem sbloccato
(https://i.postimg.cc/qgzg97Dd/1.jpg) (https://postimg.cc/qgzg97Dd) (https://i.postimg.cc/D8G0wMKj/2.jpg) (https://postimg.cc/D8G0wMKj)
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 11 Maggio 2021, 23:12
si meglio, metti il firmware in /tmp e lo flashi con mtd:
https://hack-technicolor.readthedocs.io/en/stable/Upgrade/#flashing-firmware
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 11 Maggio 2021, 23:27
quindi prima fase

mtd -e $(cat /proc/banktable/booted) write "/tmp/timsm-vbnt-f_16.3.7446-bank_dump.xz" $(cat /proc/banktable/booted)

poi cosi ?

echo c > /proc/sysrq-trigger

??
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 11 Maggio 2021, 23:53
l'xz devi estrarlo prima, dovrebbe essere
tar xvf /tmp/timsm-vbnt-f_16.3.7446-bank_dump.xz
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 12 Maggio 2021, 04:20
Attenzione a fare tutto in /tmp potrebbe non bastare la memoria, il tar + il dump estratto pesano per 72  MB. Libera prima la cache per sicurezza con
sync && echo 3 |  tee /proc/sys/vm/drop_caches
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 12 Maggio 2021, 09:21
esce fuori questo

[email protected]:~# mtd -e $(cat /proc/banktable/booted) write "/tmp/timsm-vbnt-f_16.3.7446-
bank_dump" $(cat /proc/banktable/booted)
Unlocking bank_2 ...
Erasing bank_2 ...

Writing from /tmp/timsm-vbnt-f_16.3.7446-bank_dump to bank_2 ...  [w]
e poi
Writing from /tmp/timsm-vbnt-f_16.3.7446-bank_dump to bank_2 ...  [e]Failed to erase block
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 12 Maggio 2021, 09:35
la cosa un p bruttina, soprattutto per lo stato in cui ora il device (non riavviare)..

puoi provare a forzare e vedere se la situazione cambia, ma mi viene il dubbio il dump che stai flashando non corretto
Codice: [Seleziona]
mtd -e -f $(cat /proc/banktable/booted) write "/tmp/timsm-vbnt-f_16.3.7446-bank_dump" $(cat /proc/banktable/booted)
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 12 Maggio 2021, 09:56
se do quella stringa esce fuori questo

[email protected]:~# mtd -e -f $(cat /proc/banktable/booted) write "/tmp/timsm-vbnt-f
_16.3.7446-bank_dump" $(cat /proc/banktable/booted)
Usage: mtd [<options> ...] <command> [<arguments> ...] <device>[:<device>...]

The device is in the format of mtdX (eg: mtd4) or its label.
mtd recognizes these commands:
        unlock                  unlock the device
        refresh                 refresh mtd partition
        erase                   erase all data on device
        write <imagefile>|-     write <imagefile> (use - for stdin) to device
        jffs2write <file>       append <file> to the jffs2 partition on the devi                                ce
        fixtrx                  fix the checksum in a trx header on first boot
Following options are available:
        -q                      quiet mode (once: no [w] on writing,
                                           twice: no status messages)
        -n                      write without first erasing the blocks
        -r                      reboot after successful command
        -f                      force write without trx checks
        -e <device>             erase <device> before executing the command
        -d <name>               directory for jffs2write, defaults to "tmp"
        -j <name>               integrate <file> into jffs2 data when writing an                                 image
        -p                      write beginning at partition offset
        -o offset               offset of the image header in the partition(for                                 fixtrx)

Example: To write linux.trx to mtd4 labeled as linux and reboot afterwards
         mtd -r write linux.trx linux

[email protected]:~#
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: FrancYescO - 12 Maggio 2021, 11:10
vabbh la flag forse non da mettere in quel modo, direi prova con il comando che si sempre usato

Codice: [Seleziona]
mtd -r /tmp/timsm-vbnt-f_16.3.7446-bank_dump /dev/mtd4
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 12 Maggio 2021, 14:28
esce fuori questo come sopra, non va

[email protected]:~# mtd -r /tmp/timsm-vbnt-f_16.3.7446-bank_dump /dev/mtd4
Usage: mtd [<options> ...] <command> [<arguments> ...] <device>[:<device>...]

The device is in the format of mtdX (eg: mtd4) or its label.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 12 Maggio 2021, 15:56
mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    /dev/mtd4
o
mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    bank_2
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 12 Maggio 2021, 16:05
ma prima di quei comandi devo fare altro, devo dare altre righe di comando prima di fare la scrittura del firmware ?

cmq niente da fare

[email protected]:~# mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    /dev/mtd4
Unlocking /dev/mtd4 ...

Writing from /tmp/timsm-vbnt-f_16.3.7446-bank_dump to /dev/mtd4 ...  [e]Failed to erase block
[email protected]:~# mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    bank_2
Unlocking bank_2 ...

Writing from /tmp/timsm-vbnt-f_16.3.7446-bank_dump to bank_2 ...  [e]Failed to erase block
[email protected]:~#

ma dato che raggiungo ancora la gui se ci butto su il fw originale fastweb 16.2 lo ripristino senza rischio di rovinarlo ?
perche per adesso ancora non l' ho spento ne riavviato

ovviamente adesso sulle info nell gui del router mi dice
banco passivo bank_2
versione passiva firmware non presente in questo  banco
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 12 Maggio 2021, 16:36
Secondo me la frittata gi stata fatta nel senso che avevi installato la gui. Questo ti aveva cancellato il firmware in bank_1 per poter far il bank planning. Con il successivo
Codice: [Seleziona]
mtd -e $(cat /proc/banktable/booted) write "/tmp/timsm-vbnt-f_16.3.7446-bank_dump" $(cat /proc/banktable/booted)ti ha cancellato anche il firmware in bank_2. Ora non hai nessun firmware caricato. Se riavvii ora il router va in boot loop.
Ora visto che non ti permette di caricare nulla in bank_2 le soluzione sono 2 (si spera):
o si tenta di scrivere in bank_1 o si spegne e si ricarica il firmware con tftp.
Essendo attiva la bank_1 al riavvio parte direttamente.
Si carica il dump   /dev/mtd4-bank_2
Si da il comando switchover per passare in bank_2
Si sblocca il firmware 16.3
Si installa la gui.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 08:52
allora cercando di capirci bene,
la soluzione piu "semplice" sarebbe ricaricare il fw con tftp ?

oppure, caricare il dumb  /dev/mtd4-bank_2 ,  sarebbe dare questo comando ? mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    /dev/mtd4-bank_2 direttamente in console ?
che sarebbe il comando switchover , che riga e' ?
come sblocco fw 16.3 che intendi ? il caricamento con questa riga ?  mtd -r write /tmp/timsm-vbnt-f_16.3.7446-bank_dump    bank_2 ?
grazie
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 10:12
Io direi di ricominciare da capo.

1) Caricare un firmware fastweb via tftp.
2) Sblocco con afg
3) Pulire l'overlay mtd -r erase  rootfs_data (opzionale - consigliato)
   Al riavvio sbloccare nuovamente con afg
4) Cancellare bank_2 con mtd erase bank_2
   Riscrivere il firmware con mtd write /tmp/timsm-vbnt-f_16.3.7446-bank_dump bank_2 (se non dovesse funzionare rinominare timsm-vbnt-f_16.3.7446-bank_dump con un nome pi corto   p.es. bank_dump e riprovare con mtd write /tmp/bank_dump )
5) Passare in bank_2 con il comando switchover
6) Al riavvio sbloccare con afg (ip router 192.168.1.1)

P.S. Al punto in cui eri dovevi proseguire semplicemente seguendo la guida del topic dedicato:
https://www.ilpuntotecnico.com/forum/index.php/topic,78382.msg270492.html#msg270492
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 10:58
arrivato al punto 4


[email protected]:~# mtd erase bank_2
Unlocking bank_2 ...
Erasing bank_2 ...
[email protected]:~# mtd write /tmp/bank_dump bank_2
Unlocking bank_2 ...
Writing from /tmp/bank_dump to bank_2 ...  [e]Failed to erase block
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 11:29
Forse ho capito l'arcano, puoi usare questo file:
https://anonfiles.com/ddFdS4veu9/mtd3_dump
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 11:39
come cancello il contenuto della /tmp con il file vecchio ?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 11:41
rm /tmp/file_da_cancellare
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 12:55
ok firmware SM messo !!!!! versione aqua 16.3,
lo raggiungo via web con 192.168.1.1 e non mi chiede password per entrare, quando provo a rifare AFG non so che utente e password metteri, mi restituisce errore

OK trovato era admin e access key
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 13:27
L'arcano era come deve essere scompattato il file timsm-vbnt-f_16.3.7446-bank_dump.xz.
Con file-roller (linux) lo scompatta male: usare la linea di comando tar xvfJ timsm-vbnt-f_16.3.7446-bank_dump.xz (comando non utilizzabile da dentro il router).
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 17:30
perfetto ti ringrazio, ci sono riuscito
(https://i.postimg.cc/RqSjXK65/technicolor.jpg) (https://postimg.cc/RqSjXK65)
anche se.. in fase di installazione gui mi ha dato questo errore:

/etc/rc.common: line 1: can't create /proc/prozone/bootfail: nonexistent directory
/etc/rc.common: line 1: can't create /proc/prozone/bootcounter: nonexistent directory
/etc/rc.common: line 1: can't create /proc/prozone/bootbank: nonexistent directory
No internet connection detected, download manually!
/etc/rc.common: /etc/modgui_scripts/04_config.sh: line 600: /etc/init.d/mobiled: Permission denied
Root Script: Detected low flash space device...

ma lu gui sembra andare lostesso , anche se, per essere pignoli , vedo un errore di visualizzazione cerchiato il rosso sulla foto
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 17:57
Per problemi con la gui chiedi nel topic apposito.
Per il cerchietto rosso manca la foto dello xtream nell'installazione della gui.
Gli errori dovrebbero essere legati alla versione del firmware, ma non dovrebbero portare a nulla.
Vedo che hai fatto un installazione off line, appena puoi mandalo in internet e installa l'app specifica del router presente in impostazione gui.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 18:29
Per problemi con la gui chiedi nel topic apposito.
Per il cerchietto rosso manca la foto dello xtream nell'installazione della gui.
Gli errori dovrebbero essere legati alla versione del firmware, ma non dovrebbero portare a nulla.
Vedo che hai fatto un installazione off line, appena puoi mandalo in internet e installa l'app specifica del router presente in impostazione gui.

quando installo:

Installing wgetsh: bad number
sh: bad number
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
uci: Entry not found
sh: bad number

anche se su stato dice
"Stato App specifica gi installata"
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 18:35
Se sei on line prova a dare opkg update se non ricevi errori tutto ok.

P.S. Ho visto che giustamente hai postato sul topic di pertinenza, se hai altri problemi inerenti alla gui, proseguimo l.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 18:37
Se sei on line prova a dare opkg update se non ricevi errori tutto ok.

emh. da dove ? putty in ssh ?
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 13 Maggio 2021, 18:38
S

P.S. Ho visto che giustamente hai postato sul topic di pertinenza, se hai altri problemi inerenti alla gui, proseguimo l.
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 13 Maggio 2021, 23:58
ora ho l' altrto router con fw MOS 16.2 e gui dev che va
volevo portare anche lui a 16.3 san marino, ho fatto:

1) Caricare un firmware fastweb via tftp.
2) Sblocco con afg
3) Pulire l'overlay mtd -r erase  rootfs_data (opzionale - consigliato)
   Al riavvio sbloccare nuovamente con afg
4) Cancellare bank_2 con mtd erase bank_2

fin qui ok

poi a questo punto

5) Riscrivere il firmware con con mtd write /tmp/mtd3_dumpp bank_2
come do' il comando fa writing e rimane li fermo come non scrivesse , aspetto del tempo invano e mi ritrovo il router senza niente e sono costretto a ricaricare un FW con TFTP
Codice: [Seleziona]
[email protected]:~# mtd write /tmp/mtd3_dump bank_2
Unlocking bank_2 ...

Writing from /tmp/mtd3_dump to bank_2 ...

5) Passare in bank_2 con il comando switchover
6) Al riavvio sbloccare con afg (ip router 192.168.1.1)
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 14 Maggio 2021, 05:16
La cosa che non capisco perch tentando di scrivere su bank_2  sei costretto a ricaricare il fw con tftp che scrive su bank_1.
Mi dici come sei messo con le banks:
Codice: [Seleziona]
find /proc/banktable -type f -print -exec cat {} ';'
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 14 Maggio 2021, 08:37
Codice: [Seleziona]
[email protected]:~# find /proc/banktable -type f -print -exec cat {} ';'
/proc/banktable/notbootedoid
Unknown
/proc/banktable/bootedoid
5cc7ffb34f5d980688bd24c8
/proc/banktable/passiveversion
16.2.8706-3401002-20190430095635-7b7c7647291129d98ea436c767d61bebd6ea5151
/proc/banktable/activeversion
Unknown
/proc/banktable/inactive
bank_2
/proc/banktable/active
bank_1
/proc/banktable/notbooted
bank_1
/proc/banktable/booted
bank_2
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 14 Maggio 2021, 09:00
La cosa cambia segui le seguenti indicazioni:
https://www.ilpuntotecnico.com/forum/index.php/topic,78382.msg270492.html#msg270492
 
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: Ponz - 17 Maggio 2021, 08:38
grazie, si ha funzionato perfettamente , ora 16.3 anche sull' altro modem

rimane il mistero di quel terzo modem buiness
ho trovato chi ha avuto lo tesso problema qui : https://github.com/pietrotti97/pietrotti97.github.io/issues/1
Titolo: Re:Technicolor TG789vac Xtream 35b accesso web solo da porta WAN
Inserito da: larsen64it - 17 Maggio 2021, 09:15
Qui lo dico e qui lo nego. Smanettando un TG789vacV2, della serie o la va o lo spacco, ero riuscito anche a flasharlo con TFTP su bank_2. La cosa molto laboriosa, ma vista l'alta possibilit del mattone finale, ho lasciato perdere e tanto meno non ho pubblicato nulla, onde evitare maledizioni ed improperi.
Se tu avessi il modo da collegarci una seriale, va bene pure un router sbloccato (basta collegare terra con terra e tx con rx) in modo da poter monitorare la situazione sarebbe anche pi facile.
Appurato che il firmware lo carica.
Che in origine probabilmente aveva il fw standard. (agli inizi escono tutti con un fw solo in bank_1 e nulla in bank_2)
Ha ricevuto l'aggiornamento business  passando in bank_2.
Vi sono 2 possibilit:
1) Cerchi di riprodurre quello che successo nel link postato
2) Fail boot