d-link dsl-624t OpenWRT

  • 18 Risposte
  • 257 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
d-link dsl-624t OpenWRT
« il: 26 Maggio 2021, 20:32 »
Salve a tutti,
Ho salvato dalla discarica questo d-link dsl-624t, appurato che fosse funzionante ho deciso di installarci OpenWRT 14.07 seguendo la guida ufficiale https://openwrt.org/toh/d-link/dsl-624t



è andato tutto a buon fine, ma durante la procedura ho scoperto che la revisione hw in mio possesso (A5) è dotata di RAM 32Mb e Flash 32Mb 4Mb! (vedere qui https://www.ilpuntotecnico.com/forum/index.php/topic,84867.msg273184.html#msg273184)



Mi chiedevo questo:
  • so che l'immagine è di tipo squashfs ma visto che questo modello ha più spazio sarebbe possibile rendere permanenti le impostazioni?
  • il mio modello è dotato di wifi, esisterà un driver per abilitarlo?
  • potrei provare a compilare la versione 15.05 con ImageBuilder? (come riporta la wiki ufficiale l'immagine già pronta non funziona)

Codice: [Seleziona]
[email protected]'s password:


BusyBox v1.22.1 (2014-09-20 21:35:17 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (14.07, r42625)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
[email protected]:~# uname -a
Linux OpenWrt 3.10.49 #3 Wed Oct 1 13:55:11 CEST 2014 mips GNU/Linux

cpuinfo
Codice: [Seleziona]
[email protected]:~# cat /proc/cpuinfo
system type : TI AR7 (TNETD7300)
machine : Unknown
processor : 0
cpu model : MIPS 4KEc V4.8
BogoMIPS : 148.88
wait instruction : yes
microsecond timers : yes
tlb_entries : 16
extra interrupt vector : yes
hardware watchpoint : yes, count: 1, address/irw mask: [0x0fff]
isa : mips1 mips2 mips32r1
ASEs implemented :
shadow register sets : 1
kscratch registers : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available

ram
Codice: [Seleziona]
[email protected]:~# free
             total         used         free       shared      buffers
Mem:         29156        17880        11276            0         1984
-/+ buffers:              15896        13260
Swap:            0            0            0

flash
Codice: [Seleziona]
[email protected]:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                   14576        56     14520   0% /
/dev/root                 2624      2624         0 100% /rom
tmpfs                    14576       524     14052   4% /tmp
tmpfs                    14576        56     14520   0% /tmp/root
overlayfs:/tmp/root      14576        56     14520   0% /
tmpfs                      512         0       512   0% /dev

ifconfig
Codice: [Seleziona]
[email protected]:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:19:5B:1F:37:2D 
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd55:a7c1:ba01::1/60 Scope:Global
          inet6 addr: fe80::219:5bff:fe1f:372d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:44069 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42921 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3741157 (3.5 MiB)  TX bytes:4288185 (4.0 MiB)

eth0      Link encap:Ethernet  HWaddr 00:19:5B:1F:37:2D 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:44168 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43166 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4372780 (4.1 MiB)  TX bytes:4323457 (4.1 MiB)
          Interrupt:41

eth0.1    Link encap:Ethernet  HWaddr 00:19:5B:1F:37:2D 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:150 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:19499 (19.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr 00:19:5B:1F:37:2D 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:149 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:19421 (18.9 KiB)

eth1      Link encap:Ethernet  HWaddr 00:19:5B:1F:37:2D 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:150 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:19499 (19.0 KiB)
          Interrupt:27

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4104 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4104 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:281182 (274.5 KiB)  TX bytes:281182 (274.5 KiB)

Se avete bisogno di altre informazioni non esitate a chiedere.

Grazie.

P.S.
Sono un Ing. Inf. potete andarci pesante  :D
« Ultima modifica: 12 Giugno 2021, 19:40 da Porske »

Offline MisterFTTH

  • Global Moderator
  • Esperto
  • *****
  • 997
  • Sesso: Maschio
  • Io vi cercherò, vi troverò...e vi bannerò!
Re:d-link dsl-624t OpenWRT
« Risposta #1 il: 26 Maggio 2021, 20:41 »
Sono un Ing. Inf. potete andarci pesante  :D

Agli ingegneri piace risolvere i problemi. Se non ci sono problemi sottomano, gli ingegneri li creeranno. (Scott Adams)

 :giggle:
Prima di scrivere...leggi la Netiquette del Forum!

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #2 il: 27 Maggio 2021, 08:04 »
Touché

Allora provo da solo, se combino qualcosa magari scrivo una guida.

Offline larsen64it

  • VIP
  • *****
  • 2135
Re:d-link dsl-624t OpenWRT
« Risposta #3 il: 27 Maggio 2021, 10:03 »
Visto che sei nato per soffrire, gli AR7 sono supportati fino alla 18.06:
https://github.com/openwrt/openwrt/tree/openwrt-18.06/target/linux/ar7

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #4 il: 29 Maggio 2021, 12:44 »
Buonsalve
ho fatto alcune ricerche e sono un attimo perplesso, non riesco a capire come è stato impostato lo spazio a disposizione sulla flash, mi spiego

Questo è il setup preso direttamente da adam e come flashsize mi da 4Mb in fatti sottraendo 0x90400000 (fine di md3) a 0x90000000 (inizio di md0) ottengo quella dimensione


ma dando il comando df -h su OpenWRT la dimensione della sola rootfs è maggiore di 4Mb e il file /proc/mtd contiene degli indirizzi diversi rispetto a quelli di adam


volendo vederci chiaro ho staccato il gancetto che ferma il filo dell'antenna wifi (ma serve realmente a qualcosa quel gancetto?)

La flash è una Samsung K8D3216UBC e se non ho capito male è da 32Mb (8+24) https://www.elnec.com/en/device/Samsung/K8D3216UBC-D+%5BFBGA48%5D/ https://www.arrow.com/en/products/k8d3216ubc-pi07000/samsung-electronics
Quindi il "partizionamento" non sfrutta tutta la flash? ma perchè?

In ultimo facendo qualche ricerca ho scoperto che è possibile sostituire Adam2 con PSPBoot, mi chiedo se nel mio caso possa valere la candela e quali reali benefici porterebbe il cambio di bootloader; l'unico confronto decente tra i due che ho trovato è questo qui https://webcache.googleusercontent.com/search?q=cache:http://wikibin.org/articles/adam2.html

Visto che sei nato per soffrire, gli AR7 sono supportati fino alla 18.06:
https://github.com/openwrt/openwrt/tree/openwrt-18.06/target/linux/ar7
Mi stai tentando  :smirk:

Sono alle prime armi, me ne rendo conto e forse sto mettendo un po' troppa carne al fuoco  :D

Offline zoomx

  • Esperto
  • ****
  • 584
Re:d-link dsl-624t OpenWRT
« Risposta #5 il: 03 Giugno 2021, 21:00 »
La flash è divisa in 2 banchi indipendenti di 8 e 24 Mb
https://www.datasheets360.com/pdf/-6100829957635998730
quindi penso che le ulteriori suddivisioni debbano tenere conto di questo.
L'altro link non funziona ma questo credo di si
https://web.archive.org/web/20201030000441/http://wikibin.org/articles/adam2.html
Il gancetto serve ad evitare che il cavetto di antenna ballonzoli dentro al dispositivo.
Per il resto non conosco le MCU AR7 della TI


Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #6 il: 06 Giugno 2021, 18:59 »
Si ho dato anche io un'occhiata al datasheet, quello che hai detto è corretto, mi sembra di aver capito anche che possa gestirla solo con queste due configurazioni:
  • x8 partizioni da 4M
  • x16 partizioni da 2M
Non ne capisco il motivo però...

In questi giorni ho fatto un salto su RouterTech e seguendo una guida ho flashato il bootloader!! ora utilizzo PSPboot 1.4!!!


Ho anche smontato la scheda wifi per accertarmi fosse una TNETW1130ZVF come è risultato essere


Attualmente non sapendo come sfruttare (o se è effettivamente possibile) tutta la flash a disposizione, anche solo gli 8M del bank 1 sarebbe fantastico, proverò a compilare una versione di OpenWRT ultra minimale per vedere se riesco almeno a terminare il boot, poi si vedrà. In caso di fallimento rimarrò col firmware RouterTech  ::)

Grazie a tutti per l'aiuto  ;)

Offline zoomx

  • Esperto
  • ****
  • 584
Re:d-link dsl-624t OpenWRT
« Risposta #7 il: 07 Giugno 2021, 19:18 »
Non ne capisco il motivo però...
Di solito le flash per doppio firmware (uno di emergenza se quello che di solito va si corrompe) hanno 2 banchi con la stessa dimensione. Qui o il firmware d'emergenza è magari più piccolo, oppure lo scopo è diverso, tipo che il gruppo minimo da riscrivere tutto assieme è di lunghezza diversa e uno dei 2 è dedicato alla scrittura più frequente di piccoli dati, avendo questo gruppo minimo più piccolo. Se è così c'è scritto nel datasheet che, ti confesso, non ho letto integralmente ma solo la prima pagina e neanche con attenzione..

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #8 il: 10 Giugno 2021, 20:18 »
Salve a tutti
ho cercato di modificare il bootloader per espandere i 4M di flash in cui sono confinato... senza successo

Oltretutto ho scoperto che se provo a cambiare qualche impostazione che non gli va a genio resetta completamente tutte le impostazioni.

Allora mi sono scaricato la repo di OpenWRT e mi sono dato da fare e ragazzi ci siamo!!!!

Dopo giorni passati a compilare e flashare ho trovato la giusta combinazione delle mtd e la giusta configurazione per un firmware bootabile (ah non abbiate paura di abusare del comando defragenv salva la vita anche quando meno ve lo aspettate  :D).
Questi sono i settaggi fatti al botloader
Codice: [Seleziona]
Basic POST completed...     Success.
Last reset cause: Software reset (memory controller also reset)

PSPBoot 1.4 rev: 1.4.0.8
(c) Copyright 2002-2009 Texas Instruments, Inc. All Rights Reserved.

Press ESC for monitor..09
psbl> printenv

BUILD_OPS       0x201
bootloaderVersion       1.4.0.8
ProductID       AR7WRD
HWRevision      Unknown
SerialNumber    none
IPA             192.168.1.1
HWA_0           00:50:F1:12:27:06
mtd2            0x90000000,0x90010000
mtd3            0x90010000,0x90020000
mtd0            0x900B1000,0x90400000
mtd1            0x90020000,0x90400000
mtd4            0x90020000,0x90400000
MAC_PORT        1
MODETTY0        38400,n,8,1,hw
MODETTY1        38400,n,8,1,hw
CPUFREQ         150000000
MIPSFREQ        150000000
SYSFREQ         125000000
PROMPT          psbl>
MEMSZ           0x01000000
FLASHSZ         0x00400000
BOOTCFG         m:f:"mtd4"

psbl> info

CHIP ID: TNETD73XX (0x5), REV: 0x22

MIPS Processor   : 4KEc rev: 2.2.0
Cache mode       : write-back, write-allocate.
Instruction cache: Associativity: 4, Line size: 16, Total size: 16KB
Data cache       : Associativity: 4, Line size: 16, Total size: 16KB

Last reset cause: Software reset (memory controller also reset)

EMIF is running at the same speed of the processor.
Processor running in little endian mode.
Processor clock is asynchronous to internal bus clock.

psbl> fa
Current Flash Allocation:

section :   PSBL, base : 0xb0000000, size :      64336 bytes
section :    ENV, base : 0xb0010000, size :      65535 bytes

unallocated Space Start: 0xb0020000
unallocated Space End  : 0xb0400000

Seguendo questa guida https://openwrt.org/docs/guide-user/additional-software/saving_space ho alleggerito la versione di OpenWRT 18.06, appena 3,7Mb  :happy:
Ma anche se il boot avviene correttamente il router non risponde al ping  :'( anche con IP statico, ho aspettato ore, l'unico modo che ho per interagire è tramite la seriale.

Ecco un po' di dati
Codice: [Seleziona]
[email protected]:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:138 (138.0 B)  TX bytes:492 (492.0 B)

eth0      Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:180 (180.0 B)  TX bytes:1535 (1.4 KiB)
          Interrupt:41

eth1      Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:384 (384.0 B)
          Interrupt:27

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:132 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:8976 (8.7 KiB)  TX bytes:8976 (8.7 KiB)

Codice: [Seleziona]
[email protected]:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2368      2368         0 100% /rom
tmpfs                    14264        52     14212   0% /tmp
tmpfs                    14264        52     14212   0% /tmp/root
tmpfs                      512         0       512   0% /dev
/dev/mtdblock4             384       228       156  59% /overlay
overlayfs:/overlay         384       228       156  59% /
[email protected]:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00010000 00002000 "loader"
mtd1: 00010000 00010000 "config"
mtd2: 003e0000 00010000 "linux"
mtd3: 002b1060 00010000 "rootfs"
mtd4: 00060000 00010000 "rootfs_data"
[email protected]:~# free
             total       used       free     shared    buffers     cached
Mem:         28528      16700      11828        104       1816       6052
-/+ buffers/cache:       8832      19696
Swap:        13308          0      13308

Codice: [Seleziona]
[email protected]:~# uname -a
Linux OpenWrt 4.9.243 #0 Tue Nov 24 09:03:27 2020 mips GNU/Linux
[email protected]:~# cat /proc/cpuinfo
system type             : TI AR7 (TNETD7300)
machine                 : Unknown
processor               : 0
cpu model               : MIPS 4KEc V4.8
BogoMIPS                : 148.88
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 1, address/irw mask: [0x0fff]
isa                     : mips1 mips2 mips32r1
ASEs implemented        :
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

network
Codice: [Seleziona]
[email protected]:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

dhcp
Codice: [Seleziona]
[email protected]:/etc/config# cat dhcp
config dnsmasq
        option domainneeded     1
        option boguspriv        1
        option filterwin2k      0  # enable for dial on demand
        option localise_queries 1
        option rebind_protection 1  # disable if upstream must serve RFC1918 add     resses
        option rebind_localhost 1  # enable for RBL checking and similar service     s
        #list rebind_domain example.lan  # whitelist RFC1918 responses for domai     ns
        option local    '/lan/'
        option domain   'lan'
        option expandhosts      1
        option nonegcache       0
        option authoritative    1
        option readethers       1
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
        option nonwildcard      1 # bind to & keep track of interfaces
        #list interface         br-lan
        #list notinterface      lo
        #list bogusnxdomain     '64.94.110.11'
        option localservice     1  # disable to allow DNS requests from non-loca     l subnets

config dhcp lan
        option interface        lan
        option start    100
        option limit    150
        option leasetime        12h

config dhcp wan
        option interface        wan
        option ignore   1

firewall
Codice: [Seleziona]
[email protected]:/etc/config# cat firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

wireless
Codice: [Seleziona]
[email protected]:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/vlynq.0/vlynq0'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

dmesg
Codice: [Seleziona]
[email protected]:/etc/config# dmesg
[    0.000000] Linux version 4.9.243 ([email protected]) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r8080-9f2a40c72f) ) #0 Tue Nov 24 09:03:27 2020
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00018448 (MIPS 4KEc)
[    0.000000] TI AR7 (TNETD7300), ID: 0x0005, Revision: 0x22
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 14000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 16 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000014000000-0x0000000015ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000014000000-0x0000000015ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000014000000-0x0000000015ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 9449c044, node_mem_map 95000020
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  console=ttyS0,38400n8 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Memory: 27376K/32768K available (2926K kernel code, 147K rwdata, 628K rodata, 132K init, 198K bss, 5392K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] Clocks: prediv: 1, postdiv: 1, mul: 10
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 25483472618 ns
[    0.000044] sched_clock: 32 bits at 75MHz, resolution 13ns, wraps every 28633115129ns
[    0.024312] Calibrating delay loop... 148.88 BogoMIPS (lpj=744448)
[    0.113213] pid_max: default: 32768 minimum: 301
[    0.128030] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.148142] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.186194] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.216306] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.238058] NET: Registered protocol family 16
[    0.353746] clocksource: Switched to clocksource MIPS
[    0.375195] NET: Registered protocol family 2
[    0.392485] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.414036] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.433447] TCP: Hash tables configured (established 1024 bind 1024)
[    0.454152] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.472008] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.492215] NET: Registered protocol family 1
[    0.534197] ar7-gpio: registered 32 GPIOs
[    0.629416] No memory allocated for crashlog
[    0.657714] workingset: timestamp_bits=30 max_order=13 bucket_order=0
[    0.712237] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.730018] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.838742] io scheduler noop registered
[    0.850612] io scheduler deadline registered (default)
[    0.867074] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.887120] serial8250: ttyS0 at MMIO 0x8610e00 (irq = 15, base_baud = 3906250) is a AR7
[    0.911986] console [ttyS0] enabled
[    0.932998] bootconsole [early0] disabled
[    0.958365] serial8250: ttyS1 at MMIO 0x8610f00 (irq = 16, base_baud = 3906250) is a AR7
[    0.986972] physmap platform flash device: 02000000 at 10000000
[    1.005489] physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000ec Chip ID 0x0022a2
[    1.036866] physmap-flash.0: Found an alias at 0x400000 for the chip at 0x0
[    1.036919] physmap-flash.0: Found an alias at 0x800000 for the chip at 0x0
[    1.036964] physmap-flash.0: Found an alias at 0xc00000 for the chip at 0x0
[    1.037009] physmap-flash.0: Found an alias at 0x1000000 for the chip at 0x0
[    1.037053] physmap-flash.0: Found an alias at 0x1400000 for the chip at 0x0
[    1.037098] physmap-flash.0: Found an alias at 0x1800000 for the chip at 0x0
[    1.037143] physmap-flash.0: Found an alias at 0x1c00000 for the chip at 0x0
[    1.037227] Amd/Fujitsu Extended Query Table at 0x0040
[    1.053045]   Fixing Samsung's Amd/Fujitsu Extended Query version to 1.3
[    1.073560]   Amd/Fujitsu Extended Query version 1.3.
[    1.089092] number of CFI chips: 1
[    1.111890] 4 ar7part partitions found on MTD device physmap-flash.0
[    1.131453] Creating 4 MTD partitions on "physmap-flash.0":
[    1.148604] 0x000000000000-0x000000010000 : "loader"
[    1.175835] 0x000000010000-0x000000020000 : "config"
[    1.204316] 0x000000020000-0x000000400000 : "linux"
[    1.232178] 0x00000014efa0-0x000000400000 : "rootfs"
[    1.257435] mtd: device 3 (rootfs) set to be root filesystem
[    1.274993] 1 squashfs-split partitions found on MTD device rootfs
[    1.294016] 0x0000003a0000-0x000000400000 : "rootfs_data"
[    1.344140] libphy: Fixed MDIO Bus: probed
[    1.786274] libphy: cpmac-mii: probed
[    1.880078] cpmac cpmac.1: regs: 08612800, irq: 41, phy: fixed-0:01, mac: 00:50:f1:12:27:06
[    1.990149] cpmac cpmac.0: regs: 08610000, irq: 27, phy: fixed-0:00, mac: 00:50:f1:12:27:06
[    2.018705] vlynq0: regs 0x08611800, irq 29, mem 0x04000000
[    2.410911] vlynq0: local VLYNQ protocol rev. is 0x0001010b
[    2.428034] vlynq0: remote VLYNQ protocol rev. is 0x00010108
[    2.445408] vlynq0: using local clock divisor 8
[    2.573832] Found a VLYNQ device: 00000009
[    2.587187] vlynq1: regs 0x08611c00, irq 33, mem 0x0c000000
[    2.993785] random: fast init done
[    3.855710] NET: Registered protocol family 17
[    3.869834] 8021q: 802.1Q VLAN Support v1.8
[    3.904763] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    3.953395] Freeing prom memory: 1020k freed
[    3.970063] Freeing unused kernel memory: 132K
[    3.983837] This architecture does not have kernel memory protection.
[    5.355029] init: Console is alive
[    6.786665] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    6.810303] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    6.844574] init: - preinit -
[    8.393663] random: jshn: uninitialized urandom read (4 bytes read)
[    8.599642] random: jshn: uninitialized urandom read (4 bytes read)
[    8.751622] random: jshn: uninitialized urandom read (4 bytes read)
[    9.089269] cpmac cpmac.1 eth0: Link is Up - 100Mbps/Full - flow control off
[   12.811596] mount_root: loading kmods from internal overlay
[   12.919971] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[   12.943249] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[   13.749705] block: attempting to load /etc/config/fstab
[   13.766990] block: unable to load configuration (fstab: Entry not found)
[   13.788114] block: no usable configuration
[   13.804423] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[   13.917417] urandom-seed: Seed file not found (/etc/urandom.seed)
[   14.258507] procd: - early -
[   14.416204] cpmac cpmac.1 eth0: Link is Down
[   15.186337] procd: - ubus -
[   15.584711] urandom_read: 1 callbacks suppressed
[   15.584748] random: ubusd: uninitialized urandom read (4 bytes read)
[   15.842322] random: ubusd: uninitialized urandom read (4 bytes read)
[   16.181593] random: ubusd: uninitialized urandom read (4 bytes read)
[   16.210325] procd: - init -
[   17.482432] kmodloader: loading kernel modules from /etc/modules.d/*
[   17.535264] zram: Added device: zram0
[   17.598924] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[   17.623478] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[   17.777872] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[   18.074244] xt_time: kernel timezone is -0000
[   18.253363] ip_tables: (C) 2000-2006 Netfilter Core Team
[   18.864390] PPP generic driver version 2.4.2
[   18.890087] NET: Registered protocol family 24
[   18.935485] acx.acx_init_module: acx-mac80211, version: v0.6.0 (git: unknown)
[   18.957425] acx.acx_init_module: this driver is still EXPERIMENTAL
[   18.957425] acx: please read the README file and/or go to http://acx100.sourceforge.net/wiki for further information
[   19.008353] acx.acxpci_init_module: built with CONFIG_ACX_MAC80211_PCI
[   19.028385] acx.acxpci_init_module: compiled to use 32bit I/O access. I/O timing issues might occur, such as non-working firmware upload. Report them
[   19.069181] acx.acxpci_init_module: acx: running on a little-endian CPU
[   19.069181]  PCI/VLYNQ module initialized, waiting for cards to probe...
[   19.109877] Driver found for VLYNQ device: 00000009
[   19.125410] acx.acx_alloc_hw: wiphy: phy0
[   19.137350] acx.acx_init_mechanics: ie_cmd_buf_len=336
[   19.521142] vlynq0: local VLYNQ protocol rev. is 0x0001010b
[   19.538267] vlynq0: remote VLYNQ protocol rev. is 0x00010108
[   19.555637] vlynq0: using local clock divisor 1
[   19.569848] acx.vlynq_probe: found TI TNETW1130-based wireless network card at vlynq0, irq:80, phymem:0x4000000, mem:0xa4000000
[   19.604862] acx.vlynq_probe: the initial debug setting is 0x000A
[   19.623320] acx.vlynq_probe: using IRQ 80
[   19.635731] acx.acx_get_hardware_info: form_factor=0x01, radio_type=0x16
[   19.656301] acx.acxpci_load_firmware: Need firmware for acx111 chipset with radio ID 0x16: either combined firmware (single file 'tiacx111c16'), or two files: base-fw file 'tiacx111' + radio-fw file 'tiacx111r16'
[   19.713646] acx.acx_load_firmware: Required firmware: fw_image='tiacx111c16', radio_image='(null)'
[   19.741148] acx.acx_read_fw: requesting firmware image 'tiacx111c16'
[   20.049037] acx._acx_upload_fw: acx_write_fw (main): 0
[   20.128868] acx._acx_upload_fw: acx_validate_fw (main): 0
[   20.652526] acx.acx_init_packet_templates: initializing max packet templates
[   20.825044] acx.acx_allocate: bdev:95d50240 size:37536 phy:15ff0000 ptr:b5ff0000
[   20.848214] acx.acx_allocate: bdev:95d50240 size:1024 phy:15f9c000 ptr:b5f9c000
[   20.871765] acx.acx_allocate: bdev:95d50240 size:37536 phy:15440000 ptr:b5440000
[   20.894977] acx.acx_allocate: bdev:95d50240 size:1024 phy:15f9a000 ptr:b5f9a000
[   20.918544] acx.acx_allocate: bdev:95d50240 size:37536 phy:15450000 ptr:b5450000
[   20.941728] acx.acx_allocate: bdev:95d50240 size:1024 phy:15fe7000 ptr:b5fe7000
[   20.965329] acx.acx_allocate: bdev:95d50240 size:37536 phy:15460000 ptr:b5460000
[   20.988509] acx.acx_allocate: bdev:95d50240 size:1024 phy:1556e000 ptr:b556e000
[   21.012066] acx.acx_allocate: bdev:95d50240 size:37536 phy:15470000 ptr:b5470000
[   21.035230] acx.acx_allocate: bdev:95d50240 size:1024 phy:15578000 ptr:b5578000
[   21.057707] acx.acx_allocate: bdev:95d50240 size:448 phy:15579000 ptr:b5579000
[   21.081008] acx.acx_allocate: bdev:95d50240 size:38336 phy:15480000 ptr:b5480000
[   21.133894] acx.acx_interrogate: (type:ACX111_IE_QUEUE_CONFIG,len:56)
[   21.173921] acx.acx111_create_dma_regions: Queue head: len=56, tx_memory_block_address=1A7A0, rx_memory_block_address=163A0
[   21.207872] acx.acx111_create_dma_regions: Queue head: rx_queue_start=13994
[   21.229178] acx.acx111_create_dma_regions: Queue head: tx_queue_start[0]=149D4
[   21.251326] acx.acx111_create_dma_regions: Queue head: tx_queue_start[1]=14694
[   21.273445] acx.acx111_create_dma_regions: Queue head: tx_queue_start[2]=14354
[   21.295553] acx.acx111_create_dma_regions: Queue head: tx_queue_start[3]=14014
[   21.317657] acx.acx111_create_dma_regions: Queue head: tx_queue_start[4]=13CD4
[   21.339773] acx.acx_create_tx_desc_queue: adev->iobase2=a4022000,tx_queue_start=000149D4,tx->desc_start=a40369d4
[   21.370306] acx.acx_create_tx_desc_queue: adev->iobase2=a4022000,tx_queue_start=00014694,tx->desc_start=a4036694
[   21.401421] acx.acx_create_tx_desc_queue: adev->iobase2=a4022000,tx_queue_start=00014354,tx->desc_start=a4036354
[   21.431968] acx.acx_create_tx_desc_queue: adev->iobase2=a4022000,tx_queue_start=00014014,tx->desc_start=a4036014
[   21.463053] acx.acx_create_tx_desc_queue: adev->iobase2=a4022000,tx_queue_start=00013CD4,tx->desc_start=a4035cd4
[   21.494035] acx.acx_interrogate: (type:ACX111_IE_CONFIG_OPTIONS,len:332)
[   21.543969] acx.acx_parse_configoption: NVSv:
[   21.557127] 01
[   21.562457] 16
[   21.567408] 05
[   21.572734] 00
[   21.577687] 02
[   21.583014] 41
[   21.587966] 01
[   21.593290] 00
[   21.598228]
[   21.602812] acx.acx_parse_configoption: NVS_vendor_offs:01CD probe_delay:200 eof_memory:1114112
[   21.629400] acx.acx_parse_configoption: CCAModes:04 Diversity:01 ShortPreOpt:01 PBCC:01 ChanAgil:00 PHY:05 Temp:01
[   21.661007] acx.acx_parse_configoption: AntennaID:00 Len:02 Data:
[   21.679149] 01
[   21.684672] 02
[   21.689461]
[   21.694184] acx.acx_parse_configoption: PowerLevelID:01 Len:02 Data:
[   21.713086] 001E
[   21.719131] 000A
[   21.724610]
[   21.729177] acx.acx_parse_configoption: DataRatesID:02 Len:05 Data:
[   21.747820] 02
[   21.753148] 04
[   21.758115] 11
[   21.763441] 22
[   21.768406] 44
[   21.773913]
[   21.778476] acx.acx_parse_configoption: DomainID:03 Len:06 Data:
[   21.796334] 41
[   21.801664] 20
[   21.806630] 30
[   21.811957] 31
[   21.816920] 32
[   21.822247] 40
[   21.827193]
[   21.831771] acx.acx_parse_configoption: ProductID:04 Len:09 Data:TI ACX100
[   21.852838] acx.acx_parse_configoption: ManufacturerID:05 Len:07 Data:TI Test
[   21.874697] acx.acx_interrogate: (type:ACX1xx_IE_FWREV,len:24)
[   21.913881] acx.acx_get_firmware_version: Firmware: firmware_version='Rev 2.3.1.31' hw_id=03010101
[   21.941299] acx.acx_display_hardware_details: chipset TNETW1130, radio type 0x16 (Radia (RC2422?)), form factor 0x01 ((mini-)PCI / CardBus), EEPROM version 0x05, uploaded firmware 'Rev 2.3.1.31'
[   21.993898] acx.acx_interrogate: (type:ACX1xx_IE_DOT11_STATION_ID,len:6)
[   22.043899] acx.acx1xx_get_station_id: Got station_id: 00:19:5B:2F:EB:FB
[   22.064486] acx.acx_interrogate: (type:ACX1xx_IE_DOT11_CURRENT_ANTENNA,len:2)
[   22.113873] acx.acx1xx_get_antenna: Got antenna[0,1]: 0x4A 0x04
[   22.132047] acx.acx_interrogate: (type:ACX1xx_IE_DOT11_CURRENT_REG_DOMAIN,len:2)
[   22.183930] acx.acx_get_reg_domain: Got regulatory domain 0x41
[   22.201845] acx.acx_get_sensitivity: don't know how to get sensitivity for radio type 0x16
[   22.227104] acx.acx_set_interrupt_mask: adev->irq_mask: before: 0 devtype:0 chiptype:2 tobe: 39157
[   22.254463] acx.acx_update_ratevector: new ratevector:
[   22.269951] 82
[   22.275492] 84
[   22.280288] 0B
[   22.285836] 0C
[   22.290635] 12
[   22.296147] 16
[   22.300939] 18
[   22.306438] 24
[   22.311230] 2C
[   22.316729] 30
[   22.321520] 48
[   22.327019] 60
[   22.331812] 6C
[   22.337071] acx.acx_interrogate: (type:ACX1xx_IE_DOT11_TX_POWER_LEVEL,len:1)
[   22.383863] acx.acx1xx_get_tx_level: Got tx-power-level: 1
[   22.400713] acx.acx_update_hw_encryption: Enabling hw-encryption
[   22.419134] acx.acx_interrogate: (type:ACX1xx_IE_FEATURE_CONFIG,len:8)
[   22.494078] acx.acx_debugfs_add_adev: adev:95f214c0 nm:phy0 dirp:9589c5d8
[   22.518006] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   22.523216] Not using the 00000009 VLYNQ device's driver for VLYNQ device: 00000000
[   22.584733] kmodloader: done loading kernel modules from /etc/modules.d/*
[   32.183214] zram0: detected capacity change from 0 to 13631488
[   32.418085] Adding 13308k swap on /dev/zram0.  Priority:-1 extents:1 across:13308k SS
[   64.809406] br-lan: port 1(eth0) entered blocking state
[   64.825578] br-lan: port 1(eth0) entered disabled state
[   64.843337] device eth0 entered promiscuous mode
[   64.858978] cpmac cpmac.1 eth0: Link is Up - 100Mbps/Full - flow control off
[   65.039927] br-lan: port 1(eth0) entered blocking state
[   65.056087] br-lan: port 1(eth0) entered forwarding state
[   65.589701] cpmac cpmac.0 eth1: Link is Up - 100Mbps/Full - flow control off
[   65.710654] br-lan: port 2(eth1) entered blocking state
[   65.726824] br-lan: port 2(eth1) entered disabled state
[   65.744767] device eth1 entered promiscuous mode
[   65.759384] br-lan: port 2(eth1) entered blocking state
[   65.775512] br-lan: port 2(eth1) entered forwarding state
[   70.003692] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   70.143962] jffs2_build_filesystem(): unlocking the mtd device...
[   70.162379] done.
[   70.168474] jffs2_build_filesystem(): erasing all blocks after the end marker...
[   73.431758] done.
[   73.438018] jffs2: notice: (971) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[  133.112029] random: crng init done
[  133.122406] random: 3 urandom warning(s) missed due to ratelimiting

Non so che pesci pigliare, mi sembra tutto corretto, anche il wifi funziona!
Qualcuno ha un'idea? o vede qulcosa che mi è sfuggito?

Grazie.

Offline larsen64it

  • VIP
  • *****
  • 2135
Re:d-link dsl-624t OpenWRT
« Risposta #9 il: 11 Giugno 2021, 07:11 »
Mi viene da pensare che lo switch non sia configurato correttamente.
Questo è quello che c'era su BB e CC
Codice: [Seleziona]
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option type bridge
option ifname "eth0 eth1 eth0.1 eth0.2"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
option nat 1
option ip6assign 60

config interface wan6
        option ifname   @wan
        option proto    dhcpv6

config globals globals
        option ula_prefix auto
« Ultima modifica: 11 Giugno 2021, 07:27 da larsen64it »

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #10 il: 11 Giugno 2021, 16:40 »
Provato ma nulla  :'(

Codice: [Seleziona]
[email protected]:/# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 00:50:f1:12:27:06 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 00:50:f1:12:27:06 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:19:5b:2f:eb:fb brd ff:ff:ff:ff:ff:ff
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 00:50:f1:12:27:06 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
6: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 00:50:f1:12:27:06 brd ff:ff:ff:ff:ff:ff
7: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 00:50:f1:12:27:06 brd ff:ff:ff:ff:ff:ff
[email protected]:/# ls -l /sys/class/net
lrwxrwxrwx    1 root     root             0 Nov 24 09:06 br-lan -> ../../devices/virtual/net/br-lan
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth0 -> ../../devices/platform/cpmac.1/net/eth0
lrwxrwxrwx    1 root     root             0 Nov 24 09:08 eth0.1 -> ../../devices/virtual/net/eth0.1
lrwxrwxrwx    1 root     root             0 Nov 24 09:08 eth0.2 -> ../../devices/virtual/net/eth0.2
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth1 -> ../../devices/platform/cpmac.0/net/eth1
lrwxrwxrwx    1 root     root             0 Jan  1  1970 lo -> ../../devices/virtual/net/lo
lrwxrwxrwx    1 root     root             0 Nov 24 09:06 wlan0 -> ../../devices/platform/vlynq.0/vlynq0/net/wlan0
[email protected]:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:1 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:358 (358.0 B)  TX bytes:342 (342.0 B)

eth0      Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:386 (386.0 B)  TX bytes:1385 (1.3 KiB)
          Interrupt:41

eth0.1    Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0.2    Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:50:F1:12:27:06
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:728 (728.0 B)
          Interrupt:27

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:144 errors:0 dropped:0 overruns:0 frame:0
          TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:9792 (9.5 KiB)  TX bytes:9792 (9.5 KiB)

[email protected]:/#


Codice: [Seleziona]
[email protected]:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth1 eth0.1 eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'


Il fatto è che quando pingo la lucina sul router corrispondente alla porta dello switch alla quale sono collegato lampeggia, significa che qualcosa arriva, ma il router non risponde.

Offline larsen64it

  • VIP
  • *****
  • 2135
Re:d-link dsl-624t OpenWRT
« Risposta #11 il: 11 Giugno 2021, 17:31 »
Hai provato ad usare solo una sola ethX, configurandola manualmente e pingando da router verso pc o altra device.
Inserendo il cavo su tutte le porte nel log non succede nulla?
Con swconfig  o alro comando  non hai nessun segno?


Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #12 il: 12 Giugno 2021, 00:46 »
Si si ho provato tutte le combinazioni possibili, ma nulla.
Il comando swconfig list non restituisce nulla  :wtf: però lo switch ADM6996M appare tra quelli supportati https://openwrt.org/docs/techref/swconfig e comunque con Backfire funzionava, darò una ricompilata domani.

Offline Porske

  • Nuovo Iscritto
  • *
  • 12
  • Sesso: Maschio
Re:d-link dsl-624t OpenWRT
« Risposta #13 il: 12 Giugno 2021, 19:37 »
È stata una lunghissima giornata...
Ho ricompilato un migliaio di volte il firmware con varie combinazioni di pacchetti per fare alcuni test, preso dalla disperazione ho anche ri-flashato 14.07 ed appurato che tutte le porte dello switch funzionano, pingo in tutti i versi e il comando swconfig list non restituisce nulla anche qui.
A quanto ho capito il driver per ADM6996M viene caricato in automatico in quanto uso architettura AR7? https://dev.archive.openwrt.org/ticket/9057.html ma non so come verificarlo e cercando nel menu di compilazione non trovo nessuna voce a riguardo, ho solo trovato i sorgenti nella cartella della repo (qualcosa c'è ma non posso installarlo esplicitamente)


Nell'ultimo firmware ho installato ethtool ed ho ottenuto questo
Codice: [Seleziona]
[email protected]:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP AUI BNC MII FIBRE ]
        Supported link modes:   100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  100baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Link detected: yes
[email protected]:~# ethtool eth1
Settings for eth1:
        Supported ports: [ TP AUI BNC MII FIBRE ]
        Supported link modes:   100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  100baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Link detected: yes
[email protected]:~# ethtool wlan0
Settings for wlan0:
        Link detected: yes
[email protected]:~# ethtool eth0.1
Settings for eth0.1:
        Supported ports: [ TP AUI BNC MII FIBRE ]
        Supported link modes:   100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  100baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  100baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Link detected: yes

E la configurazione che sto utilizzando (presa pari pari da 14.07)
Codice: [Seleziona]
[email protected]:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0 eth1 eth0.1 eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option nat '1'
        option ip6assign '60'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config globals 'globals'
        option ula_prefix 'fd6f:41a7:754f::/48'

[email protected]:/# ls -l /sys/class/net
lrwxrwxrwx    1 root     root             0 Oct  1 11:58 br-lan -> ../../devices/virtual/net/br-lan
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth0 -> ../../devices/virtual/net/eth0
lrwxrwxrwx    1 root     root             0 Oct  1 11:58 eth0.1 -> ../../devices/virtual/net/eth0.1
lrwxrwxrwx    1 root     root             0 Oct  1 11:58 eth0.2 -> ../../devices/virtual/net/eth0.2
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth1 -> ../../devices/virtual/net/eth1
lrwxrwxrwx    1 root     root             0 Jan  1  1970 lo -> ../../devices/virtual/net/lo
[email protected]:/#

Sembra che lo switch venga riconosciuto, ma continua a non funzionare.

Cambiando approccio sono riuscito ad attivare l'AP wifi e collegarmi a LuCI!!!!

In wifi pingo in tutte le direzioni e anche la shell SSH funziona.

Ho modo di verificare quali driver sono istallati? Se volessi installare a mano quel driver come posso fare se non c'è un pacchetto kmod già pronto?
Grazie a tutti.

Offline larsen64it

  • VIP
  • *****
  • 2135
Re:d-link dsl-624t OpenWRT
« Risposta #14 il: 12 Giugno 2021, 21:27 »
lsmod
opkg list-installed | grep kmod*
swconfig credo che controlli kmod-swconfig
https://downloads.openwrt.org/releases/18.06.0/targets/ar7/generic/packages/
ma non credo che coincida con la versione da te compilata.
Puoi sempre ricompilare un singolo pacchetto senza ricompilare tutto.
Se bisogna modificare qualche parametro del kernel bisogna usare
make kernel_menuconfig