[RICERCA] FASTGate ZTE ZXHN H388Q

  • 142 Risposte
  • 2872 Visite

0 Utenti e 3 Visitatori stanno visualizzando questo topic.

Offline FrancYescO

  • VIP
  • *****
  • 2378
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #135 il: 21 Maggio 2020, 12:50 »
il primo di quei comandi ovviamente non va perchè la variabile IFStest non è definita

IFS è la variabile che definisce i separatori per gli argomenti (appunto \s\t\n son tutti validi di default), ma credo non riusciamo a cambiarlo runtime perchè non gli piace l'uguale, o forse perchè siamo in una (sub)shell che non sappiamo come funziona..

vsftpd riesci a guardare che versione è nell'handshake? aveva una backdoor in versioni passate

cosa hai avuto come responso nel log ai miei comandi? fate conto potrebbe fare una resolution sul dominio, quindi se non è connesso meglio mettere 127.0.0.1 o localhost che dovrebbe avere sempre successo, ma questo dovrebbero confermarlo i log

di sicuro li vengono definiti due user root:admin123 e admin:qwerty ma dovresti lanciare /lxc/root-ecnt752x/etc/init.d/klish-init start per eseguirlo, oltre al fatto che le condizioni degli if non farebbero eseguire quel codice, l'unica speranza è che sia attivo di default e che nessuno tocchi quegli user dopo

hai provato a loggarti con ftp con quegli user?

Offline lorenzocanalelc

  • Membro Anziano
  • ***
  • 360
  • Sesso: Maschio
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #136 il: 21 Maggio 2020, 13:09 »
Allora, nmap riporta solo
Codice: [Seleziona]
vsftpd 2.0.8 or later c'è un altro modo per verificare la versione?
Mi sono reso conto che senza wan collegata non riporta quel dns fail, però il reboot funziona sempre quindi non saprei cosa succeda li dentro
Purtroppo i due users non funzionano

Offline FrancYescO

  • VIP
  • *****
  • 2378
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #137 il: 21 Maggio 2020, 13:15 »
telnettalo su porta 21, la 2.3.4 era quella affetta

Offline lorenzocanalelc

  • Membro Anziano
  • ***
  • 360
  • Sesso: Maschio
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #138 il: 21 Maggio 2020, 13:20 »
Codice: [Seleziona]
telnet 192.168.1.254 21   
Trying 192.168.1.254...
Connected to 192.168.1.254.
Escape character is '^]'.
220 Welcome to virtual FTP service.
EDIT:
Codice: [Seleziona]
USER user:)
331 Please specify the password.
PASS pass
530 Login incorrect.
Non sembra vulnerabile
« Ultima modifica: 21 Maggio 2020, 13:24 da lorenzocanalelc »

Offline FrancYescO

  • VIP
  • *****
  • 2378
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #139 il: 21 Maggio 2020, 13:24 »
vabbe provaci lo stesso

Offline lorenzocanalelc

  • Membro Anziano
  • ***
  • 360
  • Sesso: Maschio
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #140 il: 21 Maggio 2020, 14:15 »
forse paradossalmente la cosa più veloce è editare il passwd, ricostruire la squashfs, criptarla, sostituirla nel bin di aggiornamento e ricalcolare bene i vari crc.

edit:
per poi hostarlo su un server acs
Mmm non credo che il modem accetti qualsiasi firmware gli venga propinato, farà qualche check immagino

Offline ilsalvopss

  • Nuovo Iscritto
  • *
  • 35
  • Sesso: Maschio
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #141 il: 21 Maggio 2020, 14:46 »
farà qualche check immagino

sui crc di sicuro ma si possono ricalcolare

Offline lorenzocanalelc

  • Membro Anziano
  • ***
  • 360
  • Sesso: Maschio
Re:[RICERCA] FASTGate ZTE ZXHN H388Q
« Risposta #142 il: 21 Maggio 2020, 15:01 »
Se tu riesci e vuoi mandarmi il bin posso provare a flasharlo e vedere che succede

EDIT: Finalmente riesco a capire un po' meglio che comandi prende quello script, questa stringa
Codice: [Seleziona]
;/bin/vsftpd&&sh$IFS/mnt/usb1_1/funziona/prova&& viene riportata così
Codice: [Seleziona]
;/bin/vsftpd&&sh\$IFS/mnt/usb1_1/funziona/prova&&, Il log completo è [ You must login or register to view this spoiler! ]
La cosa strana è che dopo la prima volta che spunta questo errore poi non spunta più, neanche dopo un reboot... forse ci vuole per forza un reset
EDIT:   Aggiornamento, il segno del dollaro viene sempre preceduto dal \ infatti
Codice: [Seleziona]
;/bin/vsftpd;$IFS;%20;$1;$2;$3;$cmd;$4;$sep_un;$sep_NL;$5 diventa
Codice: [Seleziona]
;/bin/vsftpd;\$IFS;%20;\$1;\$2;\$3;\$cmd;\$4;\$sep_un;\$sep_NL;\$5Ma invece tramite cwmp o magari con i metodi che usa Fastweb per lo speedtest non è possibile mandargli un file? Così in questo modo potrebbe essere eseguibile
« Ultima modifica: 22 Maggio 2020, 09:58 da lorenzocanalelc »