[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x

  • 260 Risposte
  • 41340 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline lorenzocanalelc

  • Esperto
  • ****
  • 651
  • Sesso: Maschio
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #255 il: 22 Maggio 2022, 11:19 »
Se I feed sono stati impostati correttamente dalla GUI devi soltanto dare: "opkg update" prima di installare il pacchetto

Offline kira

  • Membro Giovane
  • **
  • 54
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #256 il: 22 Maggio 2022, 19:20 »
Se I feed sono stati impostati correttamente dalla GUI devi soltanto dare: "opkg update" prima di installare il pacchetto
..capito ma non so come impostare i Fedd e se dòil comando che dici ottengo questo:



 mi daresti una mano ?

Grazie
Kira
« Ultima modifica: 22 Maggio 2022, 19:23 da kira »

Offline lorenzocanalelc

  • Esperto
  • ****
  • 651
  • Sesso: Maschio
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #257 il: 23 Maggio 2022, 14:28 »
Strano, la gui di Ansuel avrebbe dovuto impostarli,
puoi impostarli manualmente seguendo questa guida:
https://www.macoers.com/blog/antonio-macolino/feeds_openwrt_homeware_19_brcm6xxx_tch


Offline stonex

  • Nuovo Iscritto
  • *
  • 30
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #258 il: 08 Ottobre 2022, 20:14 »
Ciao a tutti. Ho installato il pacchetto su DGA4131FBW e connessione IPsec. Le connessioni dall'esterno funzionano correttamente perchè vedo che tutto il traffico passa dal modem e vedo anche l'IP corretto.
Tuttavia non riesco a far apparire i dispositivi che si connettono esternamente come se fossero nella rete locale.

Io vorrei riuscire ad accedere ai dispostivi in LAN dall'esterno (TV, stampanti e dispostivi di rete). Anche il server SAMBA del modem non risulta raggiungibile dalla VPN.
C'è qualche impostazione che devo cambiare?

PS: non sono sicuro sia il topic giusto, chiedo scusa nel caso.

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2778
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #259 il: 15 Ottobre 2022, 11:06 »
@stonex non sono sicuro di che sottorete IP usi per i client questo pacchetto. Se la rete di tali client VPN fosse una rete IP pura, quindi IPsec senza L2TP, sarebbe normale che non funzionino alcuni protocolli di autorilevamento per periferiche condivise di rete che lavorano in L2. Ad esempio è normale che di base tu non veda apparire automaticamente un certo PC con condivisioni SMB, stampanti o altro server/player dlna, miracast o altro. Però inserendo manualmente l'ip nel percorso della condivisione dovresti raggiungere le periferiche lan correttamente.

Esempio pratico, ho due PC in lan senza VPN, da Windows vado in Rete (ex "Risorse di") e vedo elencati entrambi, e posso accedere dall'uno alle condivisioni dell'altro. Scollego un pc e lo porto via, mi collego in VPN torno in Rete e non vedo il PC che ho lasciato a casa, Puoi comunque entrarci inserendo a mano come percorso della cartella da esplorare \\IP_DEL_PC_A_CASA\nome_condivisione

Il pacchetto in oggetto di questo thread tuttavia implementa L2TP al di sopra di IPsec quindi questi protocolli dovrebbero poter funzionare, a patto che la rete L2 creata dal pacchetto sia la stessa, ovvero una estensione di quella locale della lan e non una distinta e intercomunicante con la rete lan soltanto a livello IP. In quest0ultimo caso vale quanto detto per la IPsec pura.
« Ultima modifica: 15 Ottobre 2022, 11:12 da LuKePicci »

Offline lucash78

  • Nuovo Iscritto
  • *
  • 49
Re:[GUIDA] xl2tpd/strongSwan per VPN L2TP/IPsec su DGA413x/TG78x
« Risposta #260 il: 29 Ottobre 2022, 11:57 »
Ho fatto un po' di prove ma nulla è cambiato.
Se da ssh do il comando spuctl stop ottengo questo:
Codice: [Seleziona]
[email protected]:~# spuctl stop
ERROR[OpenBcmSpuCfg.84]: SpuCtl: open error 2
di conseguenza il driver spu sembra rimanere funzionante:
Codice: [Seleziona]
[email protected]:~# spuctl showstats
ERROR[OpenBcmSpuCfg.84]: SpuCtl: open error 2

Encryption stats
     Ingress -1229992408
     Fallback 1
     Egress 1
     Error 264
     Dropped 0
Decryption stats
     Ingress -1231716128
     Fallback -1100173844
     Egress 0
     Error 135504
     Dropped -1100174228
Quindi non riesco a disattivarlo.

Ho provato a creare il file /etc/config/hardwarecrypto così:
Codice: [Seleziona]
config hardwarecrypto 'global'
        option enable '0'
Ho riavviato il router, pensando così di disattivarlo ma niente; se lancio il comando spuctl showstats mi ritorna dell'output tipo quello sopra.

Ho provato a cambiare il file ipsec.conf in modo da non usare SHA256 così:
Codice: [Seleziona]
esp=aes128-sha1-modp1024
ike=aes128-sha1-modp1024
ma potrebbe non essere giusto quello che ho scritto nel file .conf

Il risultato è che continuo ad avere il modem che si riavvia.


Ciao a tutti, mi autoquoto :)
Ho ripreso in mano la situazione dopo molto tempo e aggiornando il modem al firmware AGTHP_2.2.3_003 (credo sia l'ultimo della serie 2.2.x) i problemi di riavvio che avevo sono spariti!!
Ora strongswan funziona una meraviglia e spero che questo post possa essere di aiuto a qualcuno.