Aiuto con asterisk e firmware 2

  • 2 Risposte
  • 322 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline Plasmodium

  • Nuovo Iscritto
  • *
  • 30
  • Sesso: Maschio
Aiuto con asterisk e firmware 2
« il: 21 Marzo 2019, 11:24 »
Ciao a tutti, oggi ho aggiornato con il firmware 2 e gui 9 e ho visto che il problema con asterisk persiste, per non creare necrosi creo questo nuovo post per riassumere e aggiornare.
E', secondo mio parere, derivato in parte dal firewall; uccidendo tutti i demoni sembra funzionare correttamente come in altri router.
Ho creato due regole che però non funzionano o almeno non riesco a vedere nei log iptable, nei log asterisk invece sembra ok.
Per la prova basta installare solo asterisk base senza nulla asterisk13 brcm63xx-tch.ipk
Le config che ho usato:
- in /etc/asterisk/logger.conf tolgo ";" da full
- /etc/asterisk/manager.conf
Codice: [Seleziona]
[general]
enabled = yes
webenabled = yes
port = 5048  ;da mettere nella rule del firewall
bindaddr = 127.0.0.1
displayconnects = no
[admin]
secret = admin
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate,message
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate,message
writetimeout = 5000
;la port = 5048  da mettere nella rule del firewall
;ho aggiunto qualche permesso in piu anche se i moduli non sono necessari per questa prova
- /etc/asterisk/http.conf
Codice: [Seleziona]
[general]
enabled = yes
enablestatic = yes
redirect = / /static/config/index.html
bindaddr = 0.0.0.0
bindport = 8098  ;da mettere nella rule del firewall
[post_mappings]
backups = /var/lib/asterisk/gui_backups
moh = /var/lib/asterisk/moh
;la port = 8098  da mettere nella rule del firewall
e do
Codice: [Seleziona]
]
/etc/init.d/asterisk reload
[/code
le iptable per il log non le metto per non rischiare di bloccare il router
Le regole sono:
[code]
config rule 'Allow_asterisk'
option target 'ACCEPT'
option src '*'
option proto 'all'
option dest_port '5048'
Codice: [Seleziona]
config rule 'Allow_webenabled'
option target 'ACCEPT'
option src '*'
option proto 'all'
option dest_port '8098'
diamo
Codice: [Seleziona]
uci commit firewall
/etc/init.d/firewall reload
L'url target che dovrebbe funzionare sempre con la risposta
http://192.168.1.1:5938/manager?action=login&username=admin&secret=admin
risposta
Codice: [Seleziona]
Asterisk Call Manager/2.10.2
Response: Error
Message: Missing action in request
oppure
http://192.168.1.41:8988/manager?action=login&username=admin&secret=admin
risposta
Codice: [Seleziona]
Manager Tester
Action:
CLI Command
user pass
Response Error
Message Authentication failed
Saluti
« Ultima modifica: 22 Marzo 2019, 16:35 da Plasmodium »

Online FrancYescO

  • Esperto
  • ****
  • 1435
Re:Aiuto con asterisk e firmware 2
« Risposta #1 il: 21 Marzo 2019, 19:28 »
ma il manager non funzionava dopo che si installava in questa maniera?
https://www.ilpuntotecnico.com/forum/index.php/topic,79984.msg245981.html#msg245981

le porte sicuramente erano le default ma non ricordo ci fossero problemi

Offline Plasmodium

  • Nuovo Iscritto
  • *
  • 30
  • Sesso: Maschio
Re:Aiuto con asterisk e firmware 2
« Risposta #2 il: 22 Marzo 2019, 16:32 »
Si FrancYescO, avevo dimenticato un pezzo, nel firmware 2 sembra funzionare meglio il manager;
volevo vedere se si riusciva ad eliminare il
while [ "$code" == "" ] do
perchè appunto uccidendo i demoni sembra ok mentre con i demoni e un restart del demone asterisk va 1 volta si  e 1 no (un po meglio di prima no)
Saluti