OpenVPN su AGTEF/AGTHP

  • 278 Risposte
  • 73902 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2602
Re:OpenVPN su AGTEF/AGTHP
« Risposta #270 il: 27 Giugno 2020, 21:42 »
Si possono compilare ma crashano quando li usi.

Offline kisspachyousee

  • Membro Anziano
  • ***
  • 195
Re:OpenVPN su AGTEF/AGTHP
« Risposta #271 il: 16 Ottobre 2020, 01:05 »
ok, ho fatto crashare il modem 3 volte prima di leggere le ultime pagine e capire che la guida non è usabile con gli ultimi firmware  :facepalm:
Qualche consiglio su qualche guida alternativa che posso seguire?
vorrei accedere da remoto all'HDD collegato al modem AGTHP, con firmware 2.2.1_001.

Offline a1pollo

  • Membro Anziano
  • ***
  • 154
Re:OpenVPN su AGTEF/AGTHP
« Risposta #272 il: 16 Ottobre 2020, 06:59 »
Per la vpn dovrebbe funzionare strongswan:
Codice: [Seleziona]
https://www.ilpuntotecnico.com/forum/index.php/topic,82673.0.html

Se hai la gui mod potresti provare:
Codice: [Seleziona]
https://www.ilpuntotecnico.com/forum/index.php/topic,81299.0.html

Offline krono86

  • Membro Giovane
  • **
  • 54
Re:OpenVPN su AGTEF/AGTHP
« Risposta #273 il: 27 Gennaio 2021, 11:13 »
Ciao a tutti!
Utilizzo già da qualche anno con soddisfazione il buon vecchio TIM HUB con la custom GUI di Ansuel per fornire connettività internet ad alcuni PC non raggiunti da connessione internet cablata; il collegamento WAN è garantito da un dongle 4G (rndis).
Ho già una VPN, configurata con OpenVPN, composta da un server nel cloud e diversi client sparsi per la rete internet; inoltre ho un terminale off-line che utilizzo come certificate authority per la generazione delle chiavi e dei file di configurazione .ovpn per ciascun client.
Vorrei collegare il router suddetto alla VPN, come client, in modo da esporre ad altri client della VPN (non a tutti, quindi non intendo fare un "push" da parte del server, ma modificherò opportunamente i file .ovpn dei client che necessiteranno l'accesso) tutti i computer appartenenti alla LAN del router.

Al file .ovpn dei client abilitati all'accesso ho aggiunto la direttiva:
Codice: [Seleziona]
route 192.xxx.yyy.0 255.255.255.0 10.8.0.Xdove 192.xxx.yyy.0 è la sottorete della LAN che voglio esporre (di cui il router fa parte), e 10.8.0.X è l'indirizzo IP con cui il router si espone alla VPN.

Ho già generato un file di configurazione .ovpn corredato di chiavi correttamente "issued" per il router.
Immagino che oltre a questo servano delle direttive al firewall del router per consentire il traffico proveniente da tun0... Quale sarebbe la procedura?
Vi ringrazio in anticipo per l'aiuto.

Ivan
« Ultima modifica: 27 Gennaio 2021, 14:40 da krono86 »

Offline flyingwings

  • Nuovo Iscritto
  • *
  • 3
Re:OpenVPN su AGTEF/AGTHP
« Risposta #274 il: 21 Marzo 2021, 11:52 »
Ho scritto questa guida per la configurazione di OpenVPN su AGTEF e AGTHP in modalità routing.

Ciao purtroppo non sono un programmatore ed è la prima volta che provo ad inserire un vpn client per internet sul mio router. Potresti essere più specifico nei singoli passaggi? Purtroppo mi sono perso subito alle prime righe :D
« Ultima modifica: 21 Marzo 2021, 11:55 da flyingwings »

Offline FrancYescO

  • VIP
  • *****
  • 3078
Re:OpenVPN su AGTEF/AGTHP
« Risposta #275 il: 22 Marzo 2021, 11:10 »
cerca di essere tu più specifico sul cosa ti blocchi, per la maggiore son comandi da dare via ssh

Offline flyingwings

  • Nuovo Iscritto
  • *
  • 3
Re:OpenVPN su AGTEF/AGTHP
« Risposta #276 il: 27 Marzo 2021, 16:49 »
Verificare di avere opkg configurato correttamente per accedere al repository
#AGTEF < 1.1.0
https://repository.ilpuntotecnico.com/files/roleo/public/agtef/brcm63xx-tch/packages
#AGTHP < 1.1.0
https://repository.ilpuntotecnico.com/files/roleo/public/agthp/brcm63xx-tch/packages
#AGTEF/AGTHP >= 1.1.0
https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages

ed eseguire un aggiornamento con
Codice: [Seleziona]
opkg update


Per esempio già qui, da dove devo dare quel comando?

Offline FrancYescO

  • VIP
  • *****
  • 3078
Re:OpenVPN su AGTEF/AGTHP
« Risposta #277 il: 28 Marzo 2021, 11:23 »
terminale SSH, se hai quel firmware e installato la GUI custom avrai già quei repository impostati.

Offline Crist

  • Membro Giovane
  • **
  • 79
Re:OpenVPN su AGTEF/AGTHP
« Risposta #278 il: 10 Giugno 2021, 23:04 »
Salve a tutti.
Da un mesetto scarso non riesco più a connettermi ad openvpn server su AGTEF correttamente configurato.
Mi connettevo bene dai miei due client su Android (Openvpn per Android e Openvpn Connect) e il mio servizio DNS NoIP è funzionante (dall'esterno pingo il mio DNS) e correttamente settato nel router.
Il messaggio che sostanzialmente mi restituisce il client è "read UDP ECONNREFUSED: connection refused (code=111)". Capisco che il messaggio segnala una generica mancanza di connessione dovuta al fatto che non riesce a trovare la porta aperta (nel mio caso la classica 1194) ma non ne capisco il motivo, visto che non ho smanettato nulla.
Ho controllato con Nmap dal mio PC puntando il mio router sulla porta UDP 1194 e mi segnala che il servizio associato è effettivamente openvpn ma la porta risulta chiusa...perchè?
Ho risvuotato il file cofig di openvpn e firewall per poi ripopolarli; ho controllato il file config network; ho controllato i config lato client.
Non so speravo in qualche intuizione da parte vostra...
Grazie

openvpn config server
Codice: [Seleziona]
config openvpn 'vpnserver'
    option  enabled             1
    option  dev_type            'tun'
    option  dev                 'ovpns0'
    option  port                1194
    option  proto               'udp'
 
    option  comp_lzo            'yes'
    option  keepalive           '10 120'
    option  persist_key         1
    option  persist_tun         1
 
    option  ca                  '/etc/openvpn/ca.crt'
    option  cert                '/etc/openvpn/my-server.crt'
    option  key                 '/etc/openvpn/my-server.key'
    option  dh                  '/etc/openvpn/dh2048.pem'
    option  tls_auth            '/etc/openvpn/tls-auth.key 0'
 
    option  mode                'server'
    option  tls_server          '1'
    option  server              '192.168.200.0 255.255.255.0'
    option  topology            'subnet'
    option  route_gateway       'dhcp'
 
    option  client_to_client    '1'
    option log '/tmp/openvpn.log'
 
 
    list    push                'comp-lzo yes'
    list    push                'persist-key'
    list    push                'persist-tun'
    list    push                'route-gateway dhcp'
    list    push                'redirect-gateway def1'
    list    push                'route 192.168.200.0 255.255.255.0'
    list    push                'dhcp-option DNS 192.168.1.1'

config firewall
Codice: [Seleziona]
..............
config rule
 option name 'Allow-OpenVPN-Inbound'
 option target 'ACCEPT'
 option src '*'
 option proto 'udp'
 option dest_port '1194'

config zone
 option name 'vpnserver'
 option network 'vpnserver'
 option input 'ACCEPT'
 option forward 'REJECT'
 option output 'ACCEPT'
 option masq '1'

config forwarding
 option src 'vpnserver'
 option dest 'wan'

config forwarding
 option src 'vpnserver'
 option dest 'lan'
 
config forwarding
 option src 'lan'
 option dest 'vpnserver'
 
config forwarding
 option src 'wan'
 option dest 'vpnserver'

config redirect 'vpn_snat_lan_out'
option src 'vpn'
option dest 'lan'
option src_ip '10.8.0.0/24'
option src_dip '192.168.1.1'
option proto 'all'
option target 'SNAT'

config network
Codice: [Seleziona]
config interface 'vpnserver'
option ifname 'ovpns0'
option proto 'none'
option auto '1'

EDIT: Ho ripulito il config firewall dalle voci specifiche della openvpn e ripopolate tramite UCI (con conseguente reload delle impostazioni) ma non cambia niente. Il check l'ho fatto con:
Codice: [Seleziona]
nmap -sU -p 1190-1195 localhostLa porta UDP è correttamente associata a openvpn ma rimane chiusa. Come può essersi chiusa all'improvviso da sola e rimanere chiusa nonostante le impostazioni sul firewall?

« Ultima modifica: 16 Giugno 2021, 08:25 da Crist »