OpenVPN su AGTEF/AGTHP

  • 278 Risposte
  • 73779 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline FrancYescO

  • VIP
  • *****
  • 3069
Re:OpenVPN su AGTEF/AGTHP
« Risposta #255 il: 11 Novembre 2019, 21:42 »
nessuno ancora ha compilato modulo kernel compatibile con versioni >=2.1.0.

Offline danilos92

  • Nuovo Iscritto
  • *
  • 3
Re:OpenVPN su AGTEF/AGTHP
« Risposta #256 il: 20 Novembre 2019, 19:55 »
Salve, c'è qualche altro modo per settare la vpn sul router con AGTEF_2.2.0_001? dato che questa guida non è compatibile con i nuovi update, vorrei utilizzare expressvpn, grazie in anticipo per l'aiuto.

Offline FrancYescO

  • VIP
  • *****
  • 3069
Re:OpenVPN su AGTEF/AGTHP
« Risposta #257 il: 07 Gennaio 2020, 19:25 »
Credo puoi usare strongswan (IKEv2) o wireguard

Offline viesse

  • Nuovo Iscritto
  • *
  • 3
Re:OpenVPN su AGTEF/AGTHP
« Risposta #258 il: 10 Febbraio 2020, 10:49 »
Scusate la mia ignoranza in materia.
Ho un Tim hub sbloccato con la gui di Ansuel.
Ho speranza di poter installare i pacchetti per implementare una OpenWpn ?
Una piccola guida per utilizzare i repository è disponibile ?

Grazie e ciao a tutti

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2598
Re:OpenVPN su AGTEF/AGTHP
« Risposta #259 il: 10 Febbraio 2020, 11:29 »
No, passa a strongswan (esistono guide specifiche valide anche su Homeware) o wireguard (non so se possa funzionare, a sentire @FrancYescO pare di sì).

Gli unici driver tun funzionanti su Homeware esistono per VBNT-K/S 16.x e 17.x (linux 3.4) e altri su cui c'è già nel firmware stock.
« Ultima modifica: 10 Febbraio 2020, 11:32 da LuKePicci »

Offline viesse

  • Nuovo Iscritto
  • *
  • 3
Re:OpenVPN su AGTEF/AGTHP
« Risposta #260 il: 10 Febbraio 2020, 16:37 »
Ho scritto questa guida per la configurazione di OpenVPN su AGTEF e AGTHP in modalità routing.
@roleo
Scusa ma io con la versione sw AGTHP_1.0.3 devo seguire la guida per #AGTHP < 1.1.0 ? eseguendo passo passo tutti gli script ?
« Ultima modifica: 10 Febbraio 2020, 16:39 da MisterFTTH »

Offline darkangel85

  • Membro Giovane
  • **
  • 71
droppare traffico se openvpn è down
« Risposta #261 il: 06 Marzo 2020, 20:01 »
come da oggetto, ho configurato con successo un tunnel vpn (openvpn)

il problema è che allo stato attuale se il tunnel non viene instaurato, esce comunque.

il router (un dga4130) è in cascata a altro modem.

network.conf
Codice: [Seleziona]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'none'
option default_ps '0'

config device 'waneth4'
option type '8021q'
option name 'waneth4'
option macaddr ...
option vid '835'
option ipv6 '0'

config device 'wanptm0'
option type '8021q'
option name 'wanptm0'
option macaddr  ...
option ifname 'ptm0'
option vid '835'
option ipv6 '0'

config interface 'wan'
option demand '0'
option ipv6 '0'
option reqopts '1 3 6 15 33 42 51 121 249'
option keepalive_adaptive '0'
option dns_metric '0'
option username 'benvenuto'
option password 'ospite'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.2.106'
option gateway '192.168.2.1'
option ifname 'eth4'
option peerdns '0'
list dns '208.67.222.222'
list dns '208.67.220.220'

config config 'config'
option wan_mode 'static'

config interface 'wwan'
option proto 'mobiled'
option session_id '0'
option profile '1'
option auto '0'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
option reqopts '12 21 22 23 24 25 31 56 64 67 82 83'
option noslaaconly '1'
option iface_464xlat '0'
option dns_metric '20'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '64'
option force_link '0'
option ipv6 '0'
option ipaddr '192.168.10.1'
list ifname 'eth0'
list ifname 'eth1'
list ifname 'eth2'
list ifname 'eth3'
list ifname 'eth5'
list pppoerelay 'waneth4'
option dns '8.8.8.8 208.67.222.222'

config switch 'bcmsw'
option reset '1'
option enable_vlan '1'
option qosimppauseenable '0'
option jumbo '0'

config switch_vlan
option device 'bcmsw'
option vlan '1'
option ports '0 1 2'

config interface 'wlnet_b_5'
option proto 'static'
option ip6assign '64'
option ipv6 '0'
option ip6hint '2'
option netmask '255.255.255.128'
option ipaddr '192.168.168.129'
option ifname 'wl1_1'
option force_link '0'
option name '...'

config device 'wlnet_b_5eth5'
option type '8021q'
option name 'wl1_1'
option enabled '1'
option ifname 'eth5'
option vid '3'
option ipv6 '0'

config interface 'public_lan'
option ifname '@lan'
option proto 'static'
option ipaddr '0.0.0.0'
option netmask '0.0.0.0'
option auto '0'
option disabled_info 'proto=static,ip=0.0.0.0,mask=255.255.255.248'
option dns '8.8.8.8 208.67.222.222'

config interface 'ipoe'
option proto 'dhcp'
option metric '1'
option reqopts '1 3 6 43 51 58 59'
option release '1'
option neighreachabletime '1200000'
option neighgcstaletime '2400'
option ipv6 '1'

config switch_vlan
option device 'bcmsw'
option vlan '2'
option ports '3'

config interface 'purevpntun'
option proto 'none'
option ifname 'tun0'

firewall.conf
Codice: [Seleziona]

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option drop_invalid '1'

config zone 'lan'
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option mtu_fix '1'
option wan '0'

config zone 'wan'
option name 'wan'
list network 'wan'
list network 'wan6'
list network 'wwan'
option output 'ACCEPT'
option masq '1'
option conntrack '1'
option mtu_fix '1'
option wan '1'
option forward 'REJECT'
option input 'REJECT'

config forwarding 'lan_wan'
option src 'lan'
option dest 'wan'

config zone 'z_wlnetb24'
option name 'z_wlnetb24'
list network 'wlnet_b_24'
option input 'DROP'
option output 'ACCEPT'
option forward 'REJECT'
option mtu_fix '1'
option wan '0'

config forwarding 'for_wlnetb24'
option src 'z_wlnetb24'
option dest 'wan'

config rule 'Drop_non_TCP_SYN'
option name 'Drop_non_TCP_SYN'
option src 'wan'
option dest '*'
option proto 'tcp'
option target 'DROP'
option extra '! --tcp-flags ALL SYN'

config rule 'drop_lan_2_z_wlnetb24'
option name 'drop_lan_2_z_wlnetb24'
option src 'lan'
option dest 'z_wlnetb24'
option proto 'all'
option target 'DROP'

config rule 'drop_z_wlnetb24_2_lan'
option name 'drop_z_wlnetb24_2_lan'
option src 'z_wlnetb24'
option dest 'lan'
option proto 'all'
option target 'DROP'

config rule 'drop_lan_2_z_wlnetb24_GW'
option name 'drop-lan_2_z_wlnetb24_GW'
option src 'lan'
option proto 'all'
option target 'DROP'
option family 'ipv4'
option dest_ip '192.168.168.1'

config rule 'Allow_z_wlnetb24_ICMP'
option name 'Allow_z_wlnetb24_ICMP'
option src 'z_wlnetb24'
option proto 'igmp'
option target 'ACCEPT'
option family 'ipv4'
option dest_ip '192.168.168.1'

config rule 'Allow_z_wlnetb24_DHCP'
option name 'Allow_z_wlnetb24_DHCP'
option src 'z_wlnetb24'
option proto 'udp'
option dest_port '67'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb24_DNS'
option name 'Allow_z_wlnetb24_DNS'
option src 'z_wlnetb24'
option proto 'udp'
option dest_port '53'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb24_ICMPv6'
option name 'Allow-z_wlnetb24_ICMPv6'
option src 'z_wlnetb24'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config zone 'z_wlnetb5'
option name 'z_wlnetb5'
list network 'wlnet_b_5'
option input 'DROP'
option output 'ACCEPT'
option forward 'REJECT'
option wan '0'

config forwarding 'for_wlnetb5'
option src 'z_wlnetb5'
option dest 'wan'

config rule 'drop_lan_2_z_wlnetb5'
option name 'drop_lan_2_z_wlnetb5'
option src 'lan'
option dest 'z_wlnetb5'
option proto 'all'
option target 'DROP'

config rule 'drop_z_wlnetb5_2_lan'
option name 'drop_z_wlnetb5_2_lan'
option src 'z_wlnetb5'
option dest 'lan'
option proto 'all'
option target 'DROP'

config rule 'drop_lan_2_z_wlnetb5_GW'
option name 'drop-lan_2_z_wlnetb5_GW'
option src 'lan'
option proto 'all'
option target 'DROP'
option family 'ipv4'
option dest_ip '192.168.168.129'

config rule 'Allow_z_wlnetb5_ICMP'
option name 'Allow_z_wlnetb5_ICMP'
option src 'z_wlnetb5'
option proto 'igmp'
option target 'ACCEPT'
option family 'ipv4'
option dest_ip '192.168.168.129'

config rule 'Allow_z_wlnetb5_DHCP'
option name 'Allow_z_wlnetb5_DHCP'
option src 'z_wlnetb5'
option proto 'udp'
option dest_port '67'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb5_DNS'
option name 'Allow_z_wlnetb5_DNS'
option src 'z_wlnetb5'
option proto 'udp'
option dest_port '53'
option target 'ACCEPT'
option family 'ipv4'

config rule 'Allow_z_wlnetb5_ICMPv6'
option name 'Allow-z_wlnetb5_ICMPv6'
option src 'z_wlnetb5'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config zone 'public_lan'
option name 'public_lan'
list network 'public_lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option wan '0'
option log '1'
option log_limit '5/minute'

config forwarding 'public_lan_wan'
option src 'public_lan'
option dest 'wan'
option name 'subnet_out'
option enabled '1'

config forwarding 'wan_public_lan'
option src 'wan'
option dest 'public_lan'
option name 'subnet_in'
option enabled '1'

config rule 'rule1'
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule 'rule2'
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule 'rule3'
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule4'
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule5'
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule 'rule6'
option name 'access_2_LAN_IP'
option src 'lan'
option proto 'tcp'
option family 'ipv4'
option extra '-m multiport --dports 80,22,8080,443,8443 -m addrtype --limit-iface-in ! --dst-type LOCAL'
option target 'REJECT'

config rule 'rule7'
option name 'close_port_139'
option src 'wan'
option proto 'tcp'
option dest_port '139'
option family 'ipv4'
option target 'DROP'

config rule 'rule8'
option name 'close_port_445'
option src 'wan'
option proto 'tcp'
option dest_port '445'
option family 'ipv4'
option target 'DROP'

config rule 'rule9'
option name 'Deny-CUPS-lan'
option src 'lan'
option proto 'tcp'
option dest_port '631'
option family 'ipv4'
option target 'DROP'

config rule 'rule10'
option name 'Deny-CUPS-wan'
option src 'wan'
option proto 'tcp'
option dest_port '631'
option family 'ipv4'
option target 'DROP'

config rule 'rule11'
option name 'Deny-CUPS-lan-v6'
option src 'lan'
option proto 'tcp'
option dest_port '631'
option family 'ipv6'
option target 'DROP'

config rule 'rule12'
option name 'Deny-CUPS-wan-v6'
option src 'wan'
option proto 'tcp'
option dest_port '631'
option family 'ipv6'
option target 'DROP'

config rule 'rule13'
option name 'Allow-Ping6'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'

config rule 'SSH_wan'
option name 'SSH_wan'
option src 'wan'
option proto 'tcp'
option dest_port '22'
option target 'DROP'
option family 'ipv4'

config rule
option name 'Restrict-TCP-LAN-Input'
option src 'lan'
option dest_ip '!lan'
option proto 'tcp'
option family 'ipv4'
option extra '-m mark --mark 0/0x9000000'
option target 'REJECT'

config include
option path '/etc/firewall.user'

config include 'tchext_restart'
option type 'script'
option path '/lib/functions/firewall-restart-ext-tch.sh'

config include 'tchext'
option type 'script'
option path '/lib/functions/firewall-ext-tch.sh'
option reload '1'

config cone 'cone1'
option name 'PS and XBox Live 1'
option src 'wan'
option dest_port '88'

config cone 'cone2'
option name 'PS and XBox Live 2'
option src 'wan'
option dest_port '3074:3658'

config cone 'cone3'
option name 'PS and XBox Live 3'
option src 'wan'
option dest_port '10070'

config cone 'cone4'
option name 'PS and XBox Live 4'
option src 'wan'
option dest_port '4500'

config include 'tod'
option type 'script'
option path '/lib/functions/tod.sh'
option reload '1'

config include 'intercept'
option type 'script'
option path '/usr/lib/intercept/firewall.sh'

config fwconfig 'fwconfig'
option defaultoutgoing_lax 'ACCEPT'
option defaultoutgoing_normal 'ACCEPT'
option defaultoutgoing_high 'DROP'
option defaultoutgoing_user 'ACCEPT'
option defaultincoming_lax 'REJECT'
option defaultincoming_normal 'DROP'
option defaultincoming_high 'DROP'
option defaultincoming_user 'DROP'
option level 'lax'

config rulesgroup 'pinholerules'
option enabled '1'
option name 'FW rules for opening pinholes'
option type 'pinholerule'

config redirectsgroup 'userredirects'
option enabled '1'
option name 'FW redirects defined by the user'
option type 'userredirect'

config redirectsgroup 'dmzredirects'
option enabled '0'
option name 'FW redirects for the DMZ functionality'
option type 'dmzredirect'

config dmzredirect 'dmzredirect'
option name 'DMZ rule'
option src 'wan'
option dest 'lan'
option family 'ipv4'
option target 'DNAT'
option proto 'tcpudp'

config rulesgroup 'normalrules'
option name 'FW rules for normal level'
option type 'normalrule'
option enabled '0'

config rulesgroup 'laxrules'
option name 'FW rules for lax level'
option type 'laxrule'
option enabled '1'

config rulesgroup 'highrules'
option enabled '0'
option name 'FW rules for high level'
option type 'highrule'

config rulesgroup 'userrules'
option enabled '0'
option name 'FW rules for user level'
option type 'userrule'

config rulesgroup 'userrules_v6'
option enabled '0'
option name 'FW rules for user level IPv6'
option type 'userrule_v6'

config rulesgroup 'defaultrules'
option enabled '1'
option name 'FW rules for default behavior'
option type 'defaultrule'

config highrule 'highrule1'
option name 'HTTP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '80'
option target 'ACCEPT'

config highrule 'highrule2'
option name 'HTTPS'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '443'
option target 'ACCEPT'

config highrule 'highrule3'
option name 'SMTP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '25'
option target 'ACCEPT'

config highrule 'highrule4'
option name 'POP3'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '110'
option target 'ACCEPT'

config highrule 'highrule5'
option name 'IMAP'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '445'
option target 'ACCEPT'

config highrule 'highrule6'
option name 'SSH'
option src 'lan'
option dest 'wan'
option proto 'tcp'
option dest_port '22'
option target 'ACCEPT'

config defaultrule 'defaultipv6incoming'
option name 'Default action for incoming IPv6 traffic'
option src 'wan'
option dest 'lan'
option proto 'all'
option family 'ipv6'
option target 'ACCEPT'
option enabled '1'

config defaultrule 'defaultipv6outgoing'
option name 'Default action for outgoing IPv6 traffic'
option src 'lan'
option dest 'wan'
option proto 'all'
option family 'ipv6'
option target 'ACCEPT'
option enabled '1'

config defaultrule 'defaultoutgoing'
option name 'Default action for outgoing NAT'
option src 'lan'
option dest 'wan'
option proto 'all'
option target 'ACCEPT'

config helper 'ftphelper'
option helper 'ftp'
option dest_port '21'
option proto 'tcp'

config helper 'tftphelper'
option helper 'tftp'
option dest_port '69'
option proto 'udp'

config helper 'snmphelper'
option helper 'snmp'
option family 'ipv4'
option dest_port '161'
option proto 'udp'

config helper 'pptphelper'
option helper 'pptp'
option family 'ipv4'
option dest_port '1723'
option proto 'tcp'

config helper 'siphelper'
option enable '0'
option helper 'sip'
option dest_port '5060'
option proto 'udp'

config helper 'siploopback'
option helper 'sip'
option dest_port '5060'
option proto 'udp'
option intf 'loopback'

config helper 'irchelper'
option helper 'irc'
option family 'ipv4'
option dest_port '6667'
option proto 'tcp'

config helper 'amandahelper'
option helper 'amanda'
option dest_port '10080'
option proto 'udp'

config helper 'rtsphelper'
option helper 'rtsp'
option dest_port '554'
option family 'ipv4'
option proto 'tcp'

config zone
option name 'vpnfirewall'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'purevpntun'

config forwarding
option src 'lan'
option dest 'vpnfirewall'

config rule 'ovpn'
option name 'Allow-OpenVPN'
option src 'wan'
option dest_port '1194'
option proto 'udp'
option target 'ACCEPT'
option enabled '1'


oltre questo, come suggerito da nordvpn avevo aggiunto questo script in /etc/firewall.user
Citazione
if (! ip a s tun0 up) && (! iptables -C forwarding_rule -j REJECT); then
       iptables -I forwarding_rule -j REJECT
fi

Offline darkangel85

  • Membro Giovane
  • **
  • 71
Re:OpenVPN su AGTEF/AGTHP
« Risposta #262 il: 06 Marzo 2020, 21:13 »
Ringrazio per aver spostato il mio precedente messaggio in questa discussione, specifico: io lo uso in modalità client

Offline sturia

  • Nuovo Iscritto
  • *
  • 5
Re:OpenVPN su AGTEF/AGTHP
« Risposta #263 il: 20 Giugno 2020, 22:30 »
ciao,
sto cercando di far funzionare openvpn in modalità client su un TG789vac v2 con FW Tiscali a cui ho accesso root. Kernel 3.4.11. Tutti i moduli tun.ko che ho provato però - prendendoli da repository vari - crashano quando creo l'interfaccia per la vpn. Quello che non mi è chiaro in definitiva è quale immagine firmware caricare per potermi trovare nella condizione che rende possibile quanto descritto qui https://www.ilpuntotecnico.com/forum/index.php/topic,77856.0.html.
Mi sapreste consigliare? ho letto decine di post e forum vari, ma non riesco a trovare una risposta univoca e le prove finora effettuate non hanno dato risultati positivi.  :headbang:
Ho già in piedi una vpn basata su openvpn quindi cambiare tecnologia sarebbe in questo momento impraticabile.

grazie

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2598
Re:OpenVPN su AGTEF/AGTHP
« Risposta #264 il: 20 Giugno 2020, 23:35 »
Non ne esiste una disponibile che abbia o per cui esista un driver tun funzionante.

Offline ivan1970

  • Membro Giovane
  • **
  • 68
Re:OpenVPN su AGTEF/AGTHP
« Risposta #265 il: 24 Giugno 2020, 20:11 »
non so se questo è il thread gusto per questa domanda.. ma ho difficoltà a configurare opkg.
ho configurato il file /etc/opkg.conf in questo modo
Citazione
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlaya
arch all 100
arch brcm63xx 200
arch brcm63xx-tch 300
ho aggiunto nel file /etc/opkg/customfeeds.conf le seguenti righe
Citazione
src/gz chaos_calmer_base https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/base
src/gz chaos_calmer_packages https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/packages
src/gz chaos_calmer_luci https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/luci
src/gz chaos_calmer_routing https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/routing
src/gz chaos_calmer_telephony https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/telephony
src/gz chaos_calmer_management https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/management
ma quando lancio il comando
Citazione
opkg update

ricevo un sacco di questi errori:
Citazione
Package lcmd version 1.0 has no valid architecture, ignoring.
Package conf-dhcpcoptions version 1.1 has no valid architecture, ignoring.
Package mcsnooper-tch version 5.2 has no valid architecture, ignoring.
Package kmod-usb-storage version git_gitolite_openwrt__openwrt_broadcom_bcm963xx_5_02L_07_git-tch_bcm5_02L_07patch1-1 has no valid architecture, ignoring.
Package conf-ledfw version 1.0 has no valid architecture, ignoring.
Package mappings-cwmpd version 1.0 has no valid architecture, ignoring.
Package bulkdata version 1.0 has no valid architecture, ignoring.
Package libparsifal version 1.1.0-0 has no valid architecture, ignoring.
Package preloader-tch version 1.0 has no valid architecture, ignoring.
Package kmod-ipt-nfqueue version git_gitolite_openwrt__openwrt_broadcom_bcm963xx_5_02L_07_git-tch_bcm5_02L_07patch1-1 has no valid architecture, ignoring.
Package wifi-conductor version 6.11.14 has no valid architecture, ignoring.
Package kmod-bcm6xxx-tch-enet version git_gitolite_openwrt__openwrt_broadcom_bcm963xx_5_02L_07_git-tch_bcm5_02L_07patch1-1 has no valid architecture, ignoring.
Package conf-button version 1.0 has no valid architecture, ignoring.
Package kmodparams version 1.0 has no valid architecture, ignoring.
..........

se provo ad installare openssl-util ricevo questo errore:
Citazione
Installing openssl-util (1.0.2q-2) to root...
Downloading https://repository.ilpuntotecnico.com/files/roleo/public/agtef/1.1.0/brcm63xx-tch/packages/base/openssl-util_1.0.2q-2_brcm63xx-tch.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openssl-util:
 *      libc
 * opkg_install_cmd: Cannot install package openssl-util.
e se provo ad installare libc ricevo questo errore:
Citazione
Unknown package 'libc'.
Collected errors:
 * opkg_install_cmd: Cannot install package libc.

sto puntando a dei repository errati?

Offline FrancYescO

  • VIP
  • *****
  • 3069
Re:OpenVPN su AGTEF/AGTHP
« Risposta #266 il: 24 Giugno 2020, 22:05 »
Si sei nel topic sbagliato.
e si direi che stai usando feed sbagliati quello vanno bene quelli vanno bene per i firmware con kernel 4.1.38 e processore arm (>=2.1.0 <2.2.2)

Offline ivan1970

  • Membro Giovane
  • **
  • 68
Re:OpenVPN su AGTEF/AGTHP
« Risposta #267 il: 24 Giugno 2020, 23:07 »
ok @FrancYescO grazie..
Comunque, sono riuscito a configurare il repository, ho installato il pacchetto openssl-util  ma se provo ad installare openvpn-openssl ricevo questo errore:
Citazione
Configuring kmod-tun.
//usr/lib/opkg/info/kmod-tun.postinst: /usr/lib/opkg/info/kmod-tun.postinst-pkg: line 4: insert_modules: not found
Collected errors:
 * pkg_run_script: package "kmod-tun" postinst script returned status 127.
 * opkg_configure: kmod-tun.postinst returned 127.
immagino che dipenda dalla mia versione kernel. Ho il firmware AGTHP 2.2.2_001 con kernel 4.1.52, non c'è modo di installare un openvpn client su questa versione?

Offline FrancYescO

  • VIP
  • *****
  • 3069
Re:OpenVPN su AGTEF/AGTHP
« Risposta #268 il: 24 Giugno 2020, 23:50 »
gia non c'era modo su >=2.1.0 figuriamoci su 2.2.2 che ha ancora un'altro kernel

Offline ivan1970

  • Membro Giovane
  • **
  • 68
Re:OpenVPN su AGTEF/AGTHP
« Risposta #269 il: 27 Giugno 2020, 16:56 »
Ma il problema qual’è? Perché non si riescono a compilare?
« Ultima modifica: 27 Giugno 2020, 21:09 da MisterFTTH »