OpenVPN su AGTEF/AGTHP

  • 307 Risposte
  • 45915 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline roleo

  • VIP
  • *****
  • 4597
    • Repository ilpuntotecnico.com
Re:OpenVPN su AGTEF
« Risposta #15 il: 19 Novembre 2017, 08:49 »
Aggiunta la rotta ma non è cambiato nulla, penso che il problema sia che non si crei il bridge tra vpn e wan...

Se aggiungi le regole di firewalling senza la rotta "redirect-gateway def1" funziona oppure sono necessarie entrambe le cose?

@^NiCo^
Immagino che uno script si possa fare. Ma le variabili sono tante per cui bisogna fare un bel lavoro. Se ci sono volontari...
Per quanto riguarda la generazione dei certificati è possibile generarli su un PC, io le prime volte ho fatto così.
--- SONO TUTTI OPEN CON IL SOURCE DEGLI ALTRI ---

Non rispondo in pm a tutte quelle domande che hanno una risposta nel forum.
Usate il pulsante "Ricerca".

Offline Diavulrus

  • Membro Anziano
  • ***
  • 128
  • Sesso: Maschio
Re:OpenVPN su AGTEF
« Risposta #16 il: 19 Novembre 2017, 11:55 »
Se aggiungi le regole di firewalling senza la rotta "redirect-gateway def1" funziona oppure sono necessarie entrambe le cose?

Ho provato a commentare la rotta e con le regole di firewalling impostate internet funziona comunque.
Io la regola la lascio comunque con l'opzione bypass-dhcp perché la rete da cui mi connetto solitamente utilizza la stessa subnet della mia LAN ma, salvo esigenze particolari, non dovrebbe creare problemi il non averla.
FTTC TIM 200/20
AGTEF - 1.1.1

Offline aezakmi123

  • Membro Anziano
  • ***
  • 195
Re:OpenVPN su AGTEF
« Risposta #17 il: 19 Novembre 2017, 23:20 »
Ho seguito passo passo la guida ma non riesco a connettermi, qualcuno può aiutarmi?
I log
Codice: [Seleziona]
Sun Nov 19 23:01:23 2017 OpenVPN 2.4.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Sep 26 2017
Sun Nov 19 23:01:23 2017 Windows version 6.2 (Windows 8 or greater) 64bit
Sun Nov 19 23:01:23 2017 library versions: OpenSSL 1.0.2l  25 May 2017, LZO 2.10
Enter Management Password:
Sun Nov 19 23:01:23 2017 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25341
Sun Nov 19 23:01:23 2017 Need hold release from management interface, waiting...
Sun Nov 19 23:01:23 2017 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25341
Sun Nov 19 23:01:24 2017 MANAGEMENT: CMD 'state on'
Sun Nov 19 23:01:24 2017 MANAGEMENT: CMD 'log all on'
Sun Nov 19 23:01:24 2017 MANAGEMENT: CMD 'echo all on'
Sun Nov 19 23:01:24 2017 MANAGEMENT: CMD 'hold off'
Sun Nov 19 23:01:24 2017 MANAGEMENT: CMD 'hold release'
Sun Nov 19 23:01:24 2017 MANAGEMENT: >STATE:1511128884,RESOLVE,,,,,,
Sun Nov 19 23:01:24 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]87.10.127.95:1194
Sun Nov 19 23:01:24 2017 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Nov 19 23:01:24 2017 UDP link local: (not bound)
Sun Nov 19 23:01:24 2017 UDP link remote: [AF_INET]87.10.127.95:1194
Sun Nov 19 23:01:24 2017 MANAGEMENT: >STATE:1511128884,WAIT,,,,,,
Sun Nov 19 23:02:24 2017 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Sun Nov 19 23:02:24 2017 TLS Error: TLS handshake failed
Sun Nov 19 23:02:24 2017 SIGUSR1[soft,tls-error] received, process restarting
Sun Nov 19 23:02:24 2017 MANAGEMENT: >STATE:1511128944,RECONNECTING,tls-error,,,,,
Sun Nov 19 23:02:24 2017 Restart pause, 5 second(s)
Sun Nov 19 23:02:29 2017 MANAGEMENT: >STATE:1511128949,RESOLVE,,,,,,
Sun Nov 19 23:02:29 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]87.10.127.95:1194
Sun Nov 19 23:02:29 2017 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Nov 19 23:02:29 2017 UDP link local: (not bound)
Sun Nov 19 23:02:29 2017 UDP link remote: [AF_INET]87.10.127.95:1194
Sun Nov 19 23:02:29 2017 MANAGEMENT: >STATE:1511128949,WAIT,,,,,,

Ho anche provato seguendo questo post
Citazione
Ho risolto impostando il forward oltre che della LAN anche della WAN e ora funziona tutto.
Ecco i comandi:
Codice: [Seleziona]
uci set firewall.vpn_forwarding_wan_in=forwarding
uci set firewall.vpn_forwarding_wan_in.src=vpn
uci set firewall.vpn_forwarding_wan_in.dest=wan

uci set firewall.vpn_forwarding_wan_out=forwarding
uci set firewall.vpn_forwarding_wan_out.src=wan
uci set firewall.vpn_forwarding_wan_out.dest=vpn

uci commit network
/etc/init.d/network reload
uci commit firewall
/etc/init.d/firewall reload

Offline roleo

  • VIP
  • *****
  • 4597
    • Repository ilpuntotecnico.com
--- SONO TUTTI OPEN CON IL SOURCE DEGLI ALTRI ---

Non rispondo in pm a tutte quelle domande che hanno una risposta nel forum.
Usate il pulsante "Ricerca".

Offline nclmrc

  • Membro Anziano
  • ***
  • 205
Re:OpenVPN su AGTEF
« Risposta #19 il: 20 Novembre 2017, 13:52 »
@roleo c'e un errore nel codice quando copia i certificati in /etc/openvpn/keys. Manca keys
cp /etc/easy-rsa/keys/ca.crt /etc/easy-rsa/keys/my-server.* /etc/easy-rsa/keys/dh2048.pem /etc/openvpn
cp /etc/easy-rsa/keys/ca.crt /etc/easy-rsa/keys/my-server.* /etc/easy-rsa/keys/dh2048.pem /etc/openvpn/keys
« Ultima modifica: 20 Novembre 2017, 14:01 da nclmrc »

Offline gianluigi84

  • Nuovo Iscritto
  • *
  • 18
Re:OpenVPN su AGTEF
« Risposta #20 il: 24 Novembre 2017, 07:45 »
Ciao a tutti, sono riuscito a configurare il tutto ma ho un piccolo problema. In pratica quando sono fuori casa e mi collego dal cellulare in 4g se controllo l'ip pubblico del cellulare in quel momento risulta quello del provider mobile e non quello del router, suggerimenti? Grazie

Offline roleo

  • VIP
  • *****
  • 4597
    • Repository ilpuntotecnico.com
Re:OpenVPN su AGTEF
« Risposta #21 il: 24 Novembre 2017, 09:45 »
@nclmrc
Sistemato grazie.

Ciao a tutti, sono riuscito a configurare il tutto ma ho un piccolo problema. In pratica quando sono fuori casa e mi collego dal cellulare in 4g se controllo l'ip pubblico del cellulare in quel momento risulta quello del provider mobile e non quello del router, suggerimenti? Grazie

Nella configurazione base che ho fatto al primo post, solo il traffico della sottorete 192.168.1.x passa per la vpn.
Il traffico internet va diretto.
Leggi i post successivi sempre in prima pagina.

« Ultima modifica: 24 Novembre 2017, 09:49 da roleo »
--- SONO TUTTI OPEN CON IL SOURCE DEGLI ALTRI ---

Non rispondo in pm a tutte quelle domande che hanno una risposta nel forum.
Usate il pulsante "Ricerca".

Offline gianluigi84

  • Nuovo Iscritto
  • *
  • 18
Re:OpenVPN su AGTEF
« Risposta #22 il: 24 Novembre 2017, 16:32 »
Nella configurazione base che ho fatto al primo post, solo il traffico della sottorete 192.168.1.x passa per la vpn.
Il traffico internet va diretto.
Leggi i post successivi sempre in prima pagina.

Ciao roleo, si ho letto ma non c'è modo per far passare tutto dalla vpn?
Grazie :)

Offline roleo

  • VIP
  • *****
  • 4597
    • Repository ilpuntotecnico.com
Re:OpenVPN su AGTEF
« Risposta #23 il: 24 Novembre 2017, 16:39 »
Ciao roleo, si ho letto ma non c'è modo per far passare tutto dalla vpn?
Grazie :)

Appunto, c'è scritto nella prima pagina.
--- SONO TUTTI OPEN CON IL SOURCE DEGLI ALTRI ---

Non rispondo in pm a tutte quelle domande che hanno una risposta nel forum.
Usate il pulsante "Ricerca".

Offline gianluigi84

  • Nuovo Iscritto
  • *
  • 18
Re:OpenVPN su AGTEF
« Risposta #24 il: 24 Novembre 2017, 19:28 »
Appunto, c'è scritto nella prima pagina.

Si, l'errore che facevo era quello di aggiungere la riga push "redirect-gateway def1" al file sbagliato, ovvero /etc/config/openvpn. Il file da modificare invece è /etc/openvpn/my-vpn.conf

Se dovesse tornare utile a qualcuno per navigare su internet con l'ip del router la procedura è:

Codice: [Seleziona]
echo "push "redirect-gateway def1"" >>/etc/openvpn/my-vpn.conf
uci set firewall.vpn_forwarding_wan_in=forwarding
uci set firewall.vpn_forwarding_wan_in.src=vpn
uci set firewall.vpn_forwarding_wan_in.dest=wan

uci set firewall.vpn_forwarding_wan_out=forwarding
uci set firewall.vpn_forwarding_wan_out.src=wan
uci set firewall.vpn_forwarding_wan_out.dest=vpn

uci commit network
/etc/init.d/network reload
uci commit firewall
/etc/init.d/firewall reload


 ;)
« Ultima modifica: 01 Dicembre 2017, 21:51 da Miguel89 »

Offline puandr

  • Membro Anziano
  • ***
  • 309
    • Riconoscimi
Re:OpenVPN su AGTEF
« Risposta #25 il: 01 Dicembre 2017, 16:14 »
La seguente è un'interessante applicazione risultante dall'aver installato OpenVPN sul modem DGA.

La portabilità del numero fisso sullo smartphone:
https://youtu.be/GLBi0r-tNBk


Offline aezakmi123

  • Membro Anziano
  • ***
  • 195
Re:OpenVPN su AGTEF
« Risposta #26 il: 02 Dicembre 2017, 16:42 »
È da un po' che sto cercando di farlo funzionare, ho provato anche a generare i certificati da PC e importarli sul router. Su Ubuntu sono riuscito a configurarlo e connettermi ad OpenVPN senza problemi mentre sullo scolapasta quando cerco di connettermi rimane in waiting for server e di conseguenza connection timeout
La mia rete lan è 192.168.1.1 perciò non ho modificato i comandi da dare

L'unica cosa che ho fatto è stato modificare nel file per il client
remote my-server-name 1194     con il DDNS e aggiungere i certificati e key nella stessa cartella

Sbaglio qualcosa?

Offline Diavulrus

  • Membro Anziano
  • ***
  • 128
  • Sesso: Maschio
Re:OpenVPN su AGTEF
« Risposta #27 il: 02 Dicembre 2017, 19:21 »
....
Sbaglio qualcosa?

Dovresti  provare a postare il log del client (oscurando le informazioni sensibili) e da lì si può iniziare a capire cosa non funziona
FTTC TIM 200/20
AGTEF - 1.1.1

Offline aezakmi123

  • Membro Anziano
  • ***
  • 195
Re:OpenVPN su AGTEF
« Risposta #28 il: 02 Dicembre 2017, 20:08 »
Dopo un pomeriggio proprio grazie ai log sono riuscito a capire il problema, era la chiave  :facepalm:

Offline eeye13

  • Nuovo Iscritto
  • *
  • 38
Re:OpenVPN su AGTEF
« Risposta #29 il: 11 Dicembre 2017, 13:57 »
salve, ho provato a configurare OpenVPN ma dal cellulare non riesce a connettersi alla vpn. vi posto i log:

Codice: [Seleziona]
Client:
2017-12-11 13:52:22 ----- OpenVPN Start -----
OpenVPN core 3.1.2 ios arm64 64-bit built on Dec  5 2016 12:50:25
2017-12-11 13:52:22 Frame=512/2048/512 mssfix-ctrl=1250
2017-12-11 13:52:22 UNUSED OPTIONS
4 [resolv-retry] [infinite]
5 [nobind]
6 [persist-key]
7 [persist-tun]
13 [verb] [3]

2017-12-11 13:52:22 EVENT: RESOLVE
2017-12-11 13:52:22 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:52:22 EVENT: WAIT
2017-12-11 13:52:22 SetTunnelSocket returned 1
2017-12-11 13:52:22 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:52:23 NET Internet:ReachableViaWWAN/WR t------
2017-12-11 13:52:32 Server poll timeout, trying next remote entry...
2017-12-11 13:52:32 EVENT: RECONNECTING
2017-12-11 13:52:32 EVENT: RESOLVE
2017-12-11 13:52:32 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:52:32 EVENT: WAIT
2017-12-11 13:52:32 SetTunnelSocket returned 1
2017-12-11 13:52:32 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:52:42 Server poll timeout, trying next remote entry...
2017-12-11 13:52:42 EVENT: RECONNECTING
2017-12-11 13:52:42 EVENT: RESOLVE
2017-12-11 13:52:42 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:52:42 EVENT: WAIT
2017-12-11 13:52:42 SetTunnelSocket returned 1
2017-12-11 13:52:42 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:52:52 Server poll timeout, trying next remote entry...
2017-12-11 13:52:52 EVENT: RECONNECTING
2017-12-11 13:52:52 EVENT: RESOLVE
2017-12-11 13:52:52 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:52:52 EVENT: WAIT
2017-12-11 13:52:52 SetTunnelSocket returned 1
2017-12-11 13:52:52 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:53:02 Server poll timeout, trying next remote entry...
2017-12-11 13:53:02 EVENT: RECONNECTING
2017-12-11 13:53:02 EVENT: RESOLVE
2017-12-11 13:53:02 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:53:02 EVENT: WAIT
2017-12-11 13:53:02 SetTunnelSocket returned 1
2017-12-11 13:53:02 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:53:12 Server poll timeout, trying next remote entry...
2017-12-11 13:53:12 EVENT: RECONNECTING
2017-12-11 13:53:12 EVENT: RESOLVE
2017-12-11 13:53:12 Contacting 79.12.xxx.xxx:1194 via UDP
2017-12-11 13:53:12 EVENT: WAIT
2017-12-11 13:53:12 SetTunnelSocket returned 1
2017-12-11 13:53:12 Connecting to [mioddns.ddns.net]:1194 (79.12.xxx.xxx) via UDPv4
2017-12-11 13:53:22 EVENT: CONNECTION_TIMEOUT [ERR]
2017-12-11 13:53:22 EVENT: DISCONNECTED
2017-12-11 13:53:22 Raw stats on disconnect:
  BYTES_OUT : 840
  PACKETS_OUT : 60
  CONNECTION_TIMEOUT : 1
  N_RECONNECT : 5
2017-12-11 13:53:22 Performance stats on disconnect:
  CPU usage (microseconds): 49642
  Network bytes per CPU second: 16921
  Tunnel bytes per CPU second: 0
2017-12-11 13:53:22 EVENT: DISCONNECT_PENDING
2017-12-11 13:53:22 ----- OpenVPN Stop -----

Server:
Mon Dec 11 13:52:11 2017 OpenVPN 2.3.18 arm-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Nov 23 2017
Mon Dec 11 13:52:11 2017 library versions: OpenSSL 1.0.2m  2 Nov 2017, LZO 2.10
Mon Dec 11 13:52:11 2017 TUN/TAP device tun0 opened
Mon Dec 11 13:52:11 2017 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Mon Dec 11 13:52:11 2017 /sbin/ifconfig tun0 10.8.0.1 pointopoint 10.8.0.2 mtu 1500
Mon Dec 11 13:52:11 2017 GID set to nogroup
Mon Dec 11 13:52:11 2017 UID set to nobody
Mon Dec 11 13:52:11 2017 UDPv4 link local (bound): [undef]
Mon Dec 11 13:52:11 2017 UDPv4 link remote: [undef]
Mon Dec 11 13:52:11 2017 Initialization Sequence Completed

Idee? Grazie!
« Ultima modifica: 11 Dicembre 2017, 14:06 da MisterFTTH »