[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)

  • 9442 Risposte
  • 1917829 Visite

0 Utenti e 4 Visitatori stanno visualizzando questo topic.

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2564
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9435 il: 01 Aprile 2021, 11:41 »
E' molto semplice, avvialo a fatica sul firmware 1.0.3 e fai un reset (tastino posteriore 10 secondi e lasci). Aspetti che ti si riavvia, avrai di nuovo il firmware 1.0.3 pulito.

Che qualcosa possa andar storto durante l'upgrade pu succedere (soprattutto con i vecchi comandi nel ramo stable della guida), ma con bank planning fatto correttamente non dovresti aver avuto problemi ad avviare uno qualsiasi dei due firmware una volta caricato da TFTP.

Si l'rm -rf /overlay/* va assolutamente fatto per aggiornamenti come il tuo. Attualmente hai il firmware 1.0.3 caricato da TFTP che si avvia "male" da bank_1 a causa di file in /overlay/bank_1 non corretti. Nei passaggi del bank planning c' un rm -rf /overlay/* che evita di ricadere in situazioni simili qualora si dovesse ricaricare qualcosa da TFTP in bank_1. La parte che ti probabilmente andata storta il flashing del new.bin in bank_2, il che non un problema se l'overlay di bank_1 ancora pulita poihc qualsiasi firmware caricato da TFTP parte senza problemi. Il reset che ti ho suggerito di fare all'inizio di questo post altro non che un rm -rf /overlay/bank_1

Appena sei di nuovo in 1.0.3 funzionante riprova root, bank planning e upgrade come hai gi fatto. Stavolta segui la guida in versione latest https://hack-technicolor.readthedocs.io/en/latest/QuickStart/ (non ancora stata portata in stable a causa di numerosi cambiamenti di cui aspetto conferme)
« Ultima modifica: 01 Aprile 2021, 11:47 da LuKePicci »

Offline Vit

  • Nuovo Iscritto
  • *
  • 5
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9436 il: 02 Aprile 2021, 10:33 »
...ti ringrazio molto e comunque LuKePicci, ieri notte ero convinto che ce l'avevamo fatta, funzionava TUTTO, ma proprio TUTTO, e stavo gi riportando qui ogni buona notizia: si era installato perfettamente anche l'ultimo aggiornamento 2.2.1 con la splendida interfaccia Ansuel, e -incredibilmente- ero perfino riuscito a far girare la stampante di rete via USB... un SOGNO...
Prima di cena, felice come una Pasqua (per l'appunto), spengo col pulsante posteriore: ripeto in quel preciso momento funzionava TUTTO, volevo semplicemente vederlo riavviare dopo cena, nel suo splendore.
Da quel preciso momento, il Modem risulta completamente CAPUT: ad ogni riaccensione si illuminano di rosso i led "Info" e "@" con colore leggero e permanente, NULL'ALTRO appare vitale: niente luce o vita sullo switch LAN e quel ch' peggio nessuna reazione neppure tenendo premuto il Reset, ovvero non parte neppure pi il bootloader; sembra incomprensibilmente un problema hardware: com' possibile che sia emerso semplicemente spegnendo un apparecchio che funzionava completamente e perfettamente (peraltro riavviato via software pi volte e senza problemi)? nell'interfaccia avevo impostato in ON il risparmio energetico dei led: pu aver creato un problema del genere?

Purtroppo ho ritentato l'accensione da ieri sera decine e decine di volte, anche aspettando, ma il Modem non d altri cenni di vita...
Sono ormai rassegnato, mai successa una cosa del genere a qualcuno di voi??

Offline LuKePicci

  • Global Moderator
  • VIP
  • *****
  • 2564
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9437 il: 02 Aprile 2021, 11:44 »
Se lo accendi tenendo premuto il tasto reset non va nemmeno in bootp? In tal caso davvero morto. Probabilmente nemmeno da seriale vedi nulla in questo stato.

Offline Vit

  • Nuovo Iscritto
  • *
  • 5
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9438 il: 02 Aprile 2021, 14:26 »
.. proprio cos purtroppo, sono pressoch certo che il processore non parta neppure: sei hai presente, su un dispositivo funzionante, nell'istante in cui viene acceso, si presentano le 2 luci "i" + "@" in colore rosso tenue per 1-2 secondi e poi cambiano colore iniziando a processare il FW o il Bootloader. Ora per un motivo del tutto sconosciuto quello stato invece che durare 1-2 secondi PERMANENTE, nessun'altro segno di vita, n reazione al tasto Reset, sia in avvio che dopo, sia con pressione breve, media o molto lunga... morto patocco.
Com' stata possibile una cosa del genere? Il sistema funzionava bene come non mai, e l'ho semplicemente spento col tasto posteriore; da quel momento, morto.
E' possibile che non andasse impostata quell'opzione di Risparmio Energetico sui led? qualcuno di voi l'ha mai utilizzata?

Offline natalinux

  • VIP
  • *****
  • 8283
  • Sesso: Maschio
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9439 il: 02 Aprile 2021, 15:00 »
l'ho utilizzata, led spenti ma funzionava tutto
─ ─ ─ ─ ─ ─ ─ ─ ─
Ver. Mint (17.2) GUI MediaAccess TG789vac v2 gui 9.6.75 (Tim)
Ver. Cobalt (18.3.k) AGTHP_2.2.1 GUI DGA4132 gui 9.6.75 (Tim)
NordVPN

Offline FrancYescO

  • VIP
  • *****
  • 3020
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9440 il: 02 Aprile 2021, 15:02 »
dubito qualunque funzione possa avertelo mandato in quello stato, probabilmente la flash ha deciso di rompersi in quel momento, magari mentre era acceso si era danneggiata la partizione del bootloader e te ne sei accorto solo dopo il riavvio quando doveva venir utilizzata.

Offline Vit

  • Nuovo Iscritto
  • *
  • 5
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9441 il: 03 Aprile 2021, 12:03 »
Nonostante il tragico epilogo, oltretutto avendo avuto l'ebbrezza di un apparecchio meravigliosamente funzionante per ben 8 ore, desidero concludere ringraziando nuovamente LuKePicci, natalinux e FrancYescO per avermi comunque risposto in modo generosamente tempestivo.
Vorrei ricambiare in qualche modo e a beneficio dei futuri partecipanti a questo forum, condividendo i dettagli del successo che avevo (brevemente) ottenuto nell'impostare il server di stampa USB fruendolo da Windows 7.
Come tanti ammonivano nei vari forum, la via del CUPS perigliosa e di scarsa soddisfazione: la stampa riusciva, ma risultava terribilmente rallentata, al punto da mandare in errore di Timeout la stampante (pare che responsabili siano alcuni servizi/demoni residenti tipo "avahi" anche se non ho indagato oltre).
La soluzione stata:
- Sul Router: Condivisione stampante: Abilitata, Interfaccia Web: Off, Condivisione file Samba: ON
- Su Windows: installare la stampante in LOCALE (eventualmente riciclando un dispositivo gi installato in precedenza, io ho testato una HP1200 con il pi recente UPD 7.0.0.24832)
- Riavviare lo Spooler di Stampa e rimuovere qualsiasi porta (HP) creata in precedenza mediante CUPS
- Aggiungere una LOCAL PORT (porta locale) specificando: \\[IP del router senza porta]\[nome Samba o CUPS automaticamente assegnato in precedenza alla stampante] ad esempio \\192.168.1.250\HP_LaserJet-1200_00CNBF274044
- Indirizzare il dispositivo precedentemente installato come locale verso tale porta

Cos facendo ed evitando invece la procedura standard di "nuova installazione di una stampante di rete" via Samba, la stampante girava perfettamente e stampava velocissima!

P.S. Il Router tuttora in silenziosa agonia e vi saluta con gli ultimi 2 led rimasti in vita

Offline larsen64it

  • VIP
  • *****
  • 2087
Re:[GUIDA] Root e Modding Smart Modem Plus AGTEF DGA4130 (VBNT-K)
« Risposta #9442 il: 03 Aprile 2021, 14:03 »
Cups installa solo una stampante raw (diretta)
Citazione
pare che responsabili siano alcuni servizi/demoni residenti tipo "avahi" anche se non ho indagato oltre
Per abilitare quel servizio servono pacchetti non presenti nel firmware.
Se ti funzionava meglio con samba, buon per te, ma non una regola generale.
Per inteso samba solo file sharing, ma fornisce anche un "servizio" che consente di trovare un server di stampa, cups appunto.
Sarebbe interessante sapere a che punto ti si blocca il boot loader.
Ricambio il saluto al router.
« Ultima modifica: 03 Aprile 2021, 14:59 da larsen64it »