OpenWRT AGPWI [help configurazione client mode - lan]

  • 28 Risposte
  • 9449 Visite

0 Utenti e 1 Visitatore stanno visualizzando questo topic.

Offline maranatha_it

  • Nuovo Iscritto
  • *
  • 9
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #15 il: 06 Settembre 2018, 21:04 »
 >:(Non so bene come ho fatto ho rifatto procedura più volte ed ora accetta.
Riesco a collegare un pc tramite cavo lan.
Domande:
Posso spostare la wifi da legacy a N?
Posso accedere tramite wifi con altri dispositivi?
L'usb posta sul retro posso sfruttarla per alimentare?
Il wifi N è migliorabile dalle impostazioni ho letto qualcosina sul forzare sui 40htz...
« Ultima modifica: 06 Settembre 2018, 21:26 da maranatha_it »

Offline AlessioZ_

  • Membro Anziano
  • ***
  • 122
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #16 il: 07 Settembre 2018, 00:23 »
Da me và in default con Wireless-N;
Se puoi entrare nel pannello di OpenWRT da altri dispositivi? Sì.
Se invece chiedi di usare l'apparato come repeater: no.
USB tira fuori 5v, sì.
40 MHz non funziona da me oppure era instabile,slinkava, non ricordo, però aveva qualche problema.


Offline maranatha_it

  • Nuovo Iscritto
  • *
  • 9
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #17 il: 07 Settembre 2018, 09:49 »
Se non erro sulle opzioni c'è scritto operation frequenza [label |o scelta| N] poi il canale ecc... Ho impostato N per provare ma non so se conviene lasciare di default è magari sceglie lui. Hai abilitato usb per memorie esterne o print Server?
E' possibile da qualche parte disabilitare dhcp non mi è chiaro dove per lasciare che il router principale gestisca.
Speed test anche su rete fibra mi segna Download Mbps 6.83 .. :(
Ma c'è qualche funzione che limita la banda in download? Stesso identico valore ADSL e FIBRA
« Ultima modifica: 07 Settembre 2018, 19:54 da maranatha_it »

Offline AlessioZ_

  • Membro Anziano
  • ***
  • 122
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #18 il: 09 Settembre 2018, 08:55 »
Io ho lasciato in defa, sta fisso con la N.
I miei speedtest arrivano molto oltre, 40-45mbps.
Sicuro che non sia il link tra router-client wireless ad essere molto lontano? (quanti dB?)
Se ti avvicini cambia qualcosa?

Interfaccia LAN
da lì disabiliti il DHCP così i client ethernet che colleghi prendono il DHCP da 192.168.1.1

Per i 5v accendi Storage Device

Offline maranatha_it

  • Nuovo Iscritto
  • *
  • 9
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #19 il: 09 Settembre 2018, 12:45 »
La connessione è in N perchè mi supera 100mbps il problema è la connessione internet che non arriva ai 7 mega sempre. La distanza non centra perchè fa lo stesso ad 1 metro. Proverò anche il discorso DHCP ma è davvero strano non è che hai impostato qualcosa di diverso?

Offline alfy81

  • Nuovo Iscritto
  • *
  • 39
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #20 il: 04 Marzo 2019, 17:44 »
Ciao a tutti,
ho bisogno di voi
sono giorni che sto dietro a OpenWRT per AGPWI,
ieri sera ho flashato l'ultima build brcm63xx fin qui tutto ok.
In tranquillità sono riuscito a farlo collegare in Client Mode Wireless alla mia rete wireless,
si connette, lui vede il web, risponde a ping, tracert, mi fa scaricare software per LuCi
Tutto ok.
MA
non mi passa la connessione ai dispositivi che collego tramite eth.

Grazie infinitamente a chi vorrà darmi una dritta.

si connette, lui vede il web, risponde a ping, tracert, mi fa scaricare software per LuCi
Ciao, scusami, come fai a scaricare, anche io ho fatto la stessa configurazione.
« Ultima modifica: 04 Marzo 2019, 17:50 da alfy81 »

Offline alfy81

  • Nuovo Iscritto
  • *
  • 39
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #21 il: 04 Marzo 2019, 17:49 »
Ponticella, come al solito, a led rosso:
192.168.1.1
Da qui carichi: ImmCFE+OpenWRT_CC.bin
che trovi qui: https://www.alessiotalamonti.it/file/?dir=AGPWI_OPENWRT

Aspetti 2 minuti, refresh, sempre su ip 192.168.1.1
root/12345
Così hai la 15.01
io ti consiglio di mettere l'ultima, la 18.06

vai in System
Firmware upgrade / Restore

carichi: update_openwrt-18.06.1-brcm63xx-generic-A4001N1-squashfs-sysupgrade.bin
che trovi sempre qui: https://www.alessiotalamonti.it/file/?dir=AGPWI_OPENWRT

altri 2min di attesa, refresh stesso ip, stessa user stessa pass (root - 12345)

prima cosa cambia ip della lan, non tenere 192.168.1.1 che in teoria è uguale a quello del tuo router/modem principale,
io ho scelto 192.168.1.100

fatto questo, ad ip cambiato, connetti l'AGPWI direttamente al tuo router principale, sarà visibile a tutti i PC della tua rete ed inoltre avrà internet per
completare le successive operazioni.

apri una sessione di ssh
ip: 192.168.1.100
porta : 22
user root
la password non serve, perchè sarà null, salvo se la configuri tramite gui.
Quindi sei dentro,
dai:
opkg update

rimuovi i driver wireless attuali, così:
opkg remove kmod-b43

ed installi i brcmsmac, così:
opkg install kmod-brcmsmac

riavvia il dispositivo, così facendo vedrà il controller WiFi in modo corretto (cioè B G N);

ora
vai nella sezione WiFi, fai SCAN
seleziona la rete dove dovrà agganciarsi,
metti la password,
ti creerà un interfaccia che si chiama WWAN (Wireless Wide Area Network)
il client wireless impostalo con ip statico,
esempio:
ip 192.168.1.200
subnet 255.255.255.0
gateway 192.168.1.1

vedrai che aggancerà la rete,
ora devi creare il bridge (quello che non riuscivo a fare, grazie mavelot, grazie roleo)

riapri una sessione di ssh,
ip: 192.168.1.100
porta : 22
user root

opkg update
opkg install relayd
opkg install luci-proto-relay
opkg install nano

nano /etc/config/network

in fondo alla config
inserisci

config interface 'bridge'
   option proto 'relay'
   option ipaddr '192.168.1.200' 
   option delegate '0'
   list network 'lan'
   list network 'wwan'

ctrl+x e Y
per salvare;

vai nella GUI web sezione firewall
dove vedi reject metti accept
togli le spunte da MSS e Masquerading
Salva e applica,
ora
riavvia e
dovresti essere ok

fai sapere,
Ciao.

prima cosa cambia ip della lan, non tenere 192.168.1.1 che in teoria è uguale a quello del tuo router/modem principale,
io ho scelto 192.168.1.100
il mio router/modem principale ha ip 192.168.1.254, gli posso lasciare quello di default 192.168.1.1 o gli posso dare anche 192.168.2.1 ?
« Ultima modifica: 04 Marzo 2019, 17:51 da alfy81 »

Offline alfy81

  • Nuovo Iscritto
  • *
  • 39
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #22 il: 08 Marzo 2019, 14:09 »
@AlessioZ_
Ciao, ti volevo chiedere, questa procedura permette all'AGPWI di diventare un Repeater ?
Siccome io l'ho configurato nel seguente modo:
Modem/Principale : IP 192.168.1.254
AGPWI                      : IP 192.168.2.1
Poi andando nella sezione Network -> Wireless ho fatto Scan e mi sono agganciato alla Wifi quindi ho creato un Client permettendomi si andare su internet.
Adesso ci stà il problema che se rivado in Network -> Wireless e faccio Add non funziona più, e qui che entra in gioco il fatto di Repeater.
Nel tuo post, la configurazione è un po' diversa, il modem e l'AGPWI stanno sulla stessa rete e quindi con usando Relayd ti permette di andare su internet però non parli di Repeater, giusto ?

p.s. il mio scopo è farlo diventare anche Repeater, conosci un modo per farlo ?

Offline alfy81

  • Nuovo Iscritto
  • *
  • 39
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #23 il: 15 Marzo 2019, 10:48 »
@AlessioZ_
Ciao, volevo chiederti se il tuo AGPWI senza antenne ha instabilità con la Wifi, diciamo che come Repeater non funziona, però se creo una connessione 3G/4G è abilito la Wifi per condividere la rete, dopo 5-10 minuti si disconnette e diviene disponibile dopo 4-5 minuti, una cosa molto antipatica. Ho provato di tutto, cambiando i vari canali 1,6,11, ho cambiato da Legacy a N, ma nulla...si disconnette in continuazione, sarà per l'incompatibilità del driver ? NON credo.
Ho anche disinstallato il driver kmod-bc43 e messo kmod-brcmsmac, funziona bene la scansione delle reti, si aggancia senza problemi, però quando condivido la rete dà problemi,
Quale può essere la causa ?
Ti ringrazio
« Ultima modifica: 15 Marzo 2019, 10:50 da alfy81 »

Offline AlessioZ_

  • Membro Anziano
  • ***
  • 122
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #24 il: 15 Marzo 2019, 10:56 »
Ciao,  il mio viene utilizzo da un amico come client mode,
ovvero si aggancia al modem principale tramite rete wireless esistente, questo modem ha internet, e può estendere la rete tramite le 4 porte eth (quindi aggancia in wireless e "ripete-passa la connessione" via cavo).

Repeater wireless non funziona sicuramente.

Non ha alcuna disconnessione.
La causa può essere che stai agganciando una rete molto distante?



Offline alfy81

  • Nuovo Iscritto
  • *
  • 39
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #25 il: 15 Marzo 2019, 11:15 »
Scusami se non ti ho fatto capire il mio problema, il mio problema è creando una mia connessione 3G/4G sull'AGPWI se attivo la Wifi sull'AGPWI per condividere la rete, fecendolo diventare un' Access Point, via Ethernet non ci sono problemi, mentre se con altri dispositivi mi collego in Wifi all'AGPWI dopo 5-10 minuti la Wifi dell'AGPWI sparisce, è come se si disattiva e poi si attiva in automatico dopo 4-5 miunuti.

Offline AlessioZ_

  • Membro Anziano
  • ***
  • 122
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #26 il: 18 Marzo 2019, 22:19 »
Il problema è questo: tu lo usi in un altro modo.
Tu ti ci connetti al wireless del AGPWI,
qui invece no,
è l'AGPWI che si connette ad una rete wireless esistente e la ripete tramite switch eth.
« Ultima modifica: 21 Marzo 2019, 14:15 da AlessioZ_ »

Offline AlessioZ_

  • Membro Anziano
  • ***
  • 122
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #27 il: 12 Maggio 2019, 08:15 »
Ciao,
oggi ho dovuto modificare un AGPWI, per usarlo nella modalità che chiedevi.
Ebbene hai ragione.
Io ho usato le seguenti per risolvere:

Network > Interfaces > Lan
Physical Settings
Accendi Enable STP
ed anche Enable IGMP snooping

Con il driver  kmod-brcmsmac non superavo la velocità di 7Mbps
mentre con il driver kmod-bc43 raggiungo 20Mbps
che comunque è poco avendo una fibra con portante da 160Mbps però meglio che niente.
Scordati il WirelessN con bc43, almeno io non riesco. La vede sempre e solo BG.


Offline tatankam

  • Nuovo Iscritto
  • *
  • 25
Re:OpenWRT AGPWI [help configurazione client mode - lan]
« Risposta #28 il: 24 Aprile 2020, 12:27 »
...

Tu sei un mito.
Finalmente sono riuscito a farlo funzionare, come ho riportato qui:
https://www.ilpuntotecnico.com/forum/index.php/topic,73760.msg263735.html#msg263735

Il mio problema maggiore era che il tutto funzionava male, si disconnetteva.
Ma grazie a questa tua indicazione ora è molto stabile:
rimuovi i driver wireless attuali, così:
opkg remove kmod-b43

ed installi i brcmsmac, così:
opkg install kmod-brcmsmac


Grazie!
« Ultima modifica: 24 Aprile 2020, 12:32 da MisterFTTH »