Hardware e Software > Connessioni ADSL/VDSL/FTTC

Alice Gate VoIP 2 Plus wi-fi AGIF 1.1.1 dial face hardware F9 & seriale

<< < (2/3) > >>

Zibri:
Ho visto solo ora questo post..
Innanzitutto, non capisco che intendi dicendo che comunica solo via seriale..
Se lasci andare il boot non lo pinghi nemmeno?

Inoltre, una volta interrotto il boot da seriale, non riesci a raggiungere http://192.168.1.199 ? Devi pero' impostare ip fisso al tuo pc (non dhcp) 192.168.1.100 netmask 255.255.255.0 gateway: 192.168.1.199 (oppure: nessuno).

L'ip del router quando interrmpi il boot via seriale e': 192.168.1.199

Rileggiti la prima pagina del mio post: :P
https://www.ilpuntotecnico.com/forum/index.php/topic,9764.0.html

Cosa ti fa essere certo che si sia cancellato il firmware? Mi pare molto strano.. oltretutto ne ha due in flash.

Quello con cui dialoghi via seriale e' il bootloader (si chiama U-boot). Lasciandolo andare avanti non scrive altro?

bergio70:
ormai sono per un problema hardware...

nessun ping, settando come hai descritto non ottieni nulla, nessun ping a 192.168.1.199 .. meno che mai come pagina html, ovviamente.

Interrompendo il boot via seriale o meno non cambia nulla, lasciandolo proseguire e fermandolo il risultato è sempre quello riportato nel primo post, ma via ethernet nulla.

avevo già letto quella pagina, infatti ho preparato il cavo seriale grazie alle tue info ... la sieriale è una fatta in casa all'epoca per un cellulare nokia, non ricordo se utilizza il solito max3232 o altri, ma dialoga perfettamente con il router, dunque lei dovrebbe essere in ordine, almeno così pare.

Non ho nulla per giudicare che il firmware sia andato a farsi frggere o mneo, come potrei, ma la cosa è avvenuta in concomitanza con un reset "lungo", anche se questo non dovrebbe aver nulla  ache fare con la dipartita del firmware.

Ormai sono quasi rassegnato a giubilarlo, dispiace, ma era solo una sperimentazione, e non tutte vanno a buon fine!!

grazie dell'aiuto e buona serata

daniele



Zibri:
Tranquillo ché lo scopriamo insieme... mi hai messo in curiosita'..
Il modo di vedere cosa c'e' esiste. Come pure il modo di rimandargli un firmware ma sara' una cosa lunga e pallosetta.

Ti mando un pm.

bergio70:
sono stati due giorni pesantucci...
ora il coso si sta riposando lontano dal tavolo, dove lo vedo di meno e non mi irrita.

In verità la cosa è strana, inizialmente il router era perfettamente visibila da ethernet, solito ind. 192.168.1.1, risultatav conensso sull'adsl, ma router e modem non si vedevano, probabilmente teleco prevedeva l'utilizzo del solito software che effettua la connessione nel momento del bisogno...
resettato il tutto, reset lungo in cui i led si comportano come da previsione.Una possibilità è che gli abbia interrotto un eventuale upgrade da parte di telecom... nulla di richiesto bene inteso... la cosa è partita nel momento sbagliato e spegnendo altro ho tolo corrente anche a lui.
Rifatto retet lungo, ricollegato tutto lo ho lasciato collegato per una mezza giornata, ovviamente senza esito.
Solo allora mi sono accorto che non era pià visibile dalla rete.
Preparata la seriale il risultato lo vedi sopra, lasciandolo acceso in entrambe le situazioni, sia fermando il boot, sia lasciandolo andare avanti per i fatti suoi non fa nulla di più.
Dopo un pò solo un led rosso acecso e nulla di più.
Ho provato con gli insulti ma è refrattario (!).

domattina sono in giro per le 6,30 e scappo a  riposare.

ciao


Zibri:
Ok.. allora se e' solo un problema di firmware, tutto quello che devi fare e' tirargli su una IMG usando i comandi del bootloader (cioe' scrivendo direttamente sulla flash usando il comando mm (mm.b).

Per fare cio', con uno script dovresti trasformare una img in una serie di comandi mw.b e poi mandarli al router.
L'operazione sara' lunga ma dovrebbe funzionare.

Prima di cio' pero' sarebbe il caso di mandare al bootloader i comandi:

jlayout

e

imls

tanto per vedere cosa c'e' al momento.. perche' se c'e' anche una sola immagine allora ti bastera' dargli il comando jboot seguito dal parametro che identifica l'immagine nella flash.

Posta i log di imls e jlayout e vediamo.

Navigazione

[0] Indice dei post

[#] Pagina successiva

[*] Pagina precedente

Vai alla versione completa