Hardware e Software > Connessioni ADSL/VDSL/FTTC

Alice Gate VoIP 2 Plus wi-fi AGIF 1.1.1 dial face hardware F9 & seriale

<< < (3/3)

Zibri:
Alternativamente, potresti fare una cosa ancora piu' paracula:

fai un boot da NFS. Una volta fatto il boot aggiorni il firmware e via.

ti ricordo sempre che nel caso di comunicazione fra bootloader e pc, il pc deve avere indirizzo fisso 192.168.1.100 ed il router avra' 192.168.1.199.

Non potrei pingarlo.. ma c'e'.

alternativamente puoi anche fare un boot tramite TFTP.. sempre con gli stessi ip address.

nel caso di un boot da tftp o da nfs (credo) tu debba passargli una immagine del kernel credo e non un IMG... ovviamente tale immagine e' dentro all'IMG del firmware e si puo' estrarre.

Potrei sbagliarmi pero'; in quel caso bastera' passargli un img.. tocca controllare.


bergio70:
ti cheido scusa Zibri, ma solo ora ho potuto dedicare un p di tempo all'oggetto.

Mi consideri pi informatico di quel che sono... sinceramente ne ho capito ben poco di quanto   mi hai scritto, questo il risultato fornito dal bootloader...


FUSIV-DIALFACE #
FUSIV-DIALFACE # jlayout
img 0,size:6934380,counter:0x2,checksum:0x343b4544,description:UNKNOWN1
img 1,size:7032684,counter:0xd,checksum:0x354ce121,description:Image downloaded from: http://217.27.80.38:80/Firmware/TR069/AGPirelli/AGIF_1.2.0d.rmt
factory 7,size:474,counter:0x7,checksum:0x8de8,description:rg_factory
FUSIV-DIALFACE #

FUSIV-DIALFACE # imls
FUSIV-DIALFACE #
FUSIV-DIALFACE #

il che mi fa pensare che img 0 abbia dei problemi ... ma mi astengo da prove pellegrine,
dato che di danni ne ho gi fatti da solo.

buona domenica, per quel che ne resta.

daniele



Zibri:
Perfetto fai il boot dalla 1 allora.. qual e' il problema?

Mi pare sia jboot 1 o una cosa simile.. ma e' banale.. guarda l'help dei comandi :)

jimcarrey83:
Hit any key to stop autoboot:  0
FUSIV-DIALFACE # jlayout
img 0,size:7032684,counter:0x2,checksum:0x354b2ada,description:UNKNOWN1
img 1:uninitialized
factory 7,size:474,counter:0x7,checksum:0x8ced,description:rg_factory
FUSIV-DIALFACE # loadb
## Ready for binary (kermit) download to 0x80400000 at 57600 bps...
## Total Size      = 0x006b5119 = 7033113 Bytes
## Start Addr      = 0x80400000
FUSIV-DIALFACE # jlayout
img 0,size:7032684,counter:0x2,checksum:0x354b2ada,description:UNKNOWN1
img 1:uninitialized
factory 7,size:474,counter:0x7,checksum:0x8ced,description:rg_factory
FUSIV-DIALFACE # jboot 1
boot image at section 1
bad magic number (0x6b4f6c) on section 1: defaulting on the active image
## Booting image at bf800094 ...
Bad Magic Number

Salve, qualcuno mi sa dare una spiegazione del perch non riesco ad avviare ne il primo jboot n il secondo? :(

col jboot 1 mi da quell'errore, mentre con lo 0 carica e poi esce la spia rossa :((

ciao zibri, come si fa a trasformare una img con i comandi mw.b.. ecc ecc?

mavelot:
Mi trovo nella stessa situazione.

Ho fatto le stesse identiche cose....dopo alcuni reset di fabbrica il router morto.
Dopo starting kernel non succede nulla.

Ho provato a cancellare tutti e 2 i banchi, a caricare diverse versioni del firm (1.2.0d 1.3.0) niente da fare
l'unica cosa che vorrei tentare il boot del solo kernel....ma non so come fare...

Navigazione

[0] Indice dei post

[*] Pagina precedente

Vai alla versione completa